aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/base.bbclass6
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers.inc3
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.7.0.bb1
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.8.1.bb1
4 files changed, 10 insertions, 1 deletions
diff --git a/classes/base.bbclass b/classes/base.bbclass
index e0f9184f58..e26a45e756 100644
--- a/classes/base.bbclass
+++ b/classes/base.bbclass
@@ -75,6 +75,12 @@ def base_dep_prepend(d):
if (bb.data.getVar('HOST_SYS', d, 1) !=
bb.data.getVar('BUILD_SYS', d, 1)):
deps += " virtual/${TARGET_PREFIX}gcc virtual/libc "
+ elif bb.data.inherits_class('native', d) and \
+ bb.data.getVar('PN', d, True) not in \
+ ("linux-libc-headers-native", "quilt-native",
+ "unifdef-native", "shasum-native",
+ "stagemanager-native", "coreutils-native"):
+ deps += " linux-libc-headers-native"
return deps
DEPENDS_prepend="${@base_dep_prepend(d)} "
diff --git a/recipes/linux-libc-headers/linux-libc-headers.inc b/recipes/linux-libc-headers/linux-libc-headers.inc
index 0487e65fab..0b0d05a0d2 100644
--- a/recipes/linux-libc-headers/linux-libc-headers.inc
+++ b/recipes/linux-libc-headers/linux-libc-headers.inc
@@ -1,7 +1,8 @@
DESCRIPTION = "Sanitized set of 2.6 kernel headers for the C library's use."
SECTION = "devel"
LICENSE = "GPL"
+NATIVE_INSTALL_WORKS = "1"
+BBCLASSEXTEND = "native"
RDEPENDS_${PN}-dev = ""
RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPV})"
-
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.7.0.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.7.0.bb
index b66e768bb1..0a1159a8fb 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.7.0.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.7.0.bb
@@ -1,6 +1,7 @@
require linux-libc-headers.inc
INHIBIT_DEFAULT_DEPS = "1"
+NATIVE_INSTALL_WORKS = "0"
PR = "r4"
# NOTE: no need to package these headers, since the c library includes them.
PACKAGES = ""
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.8.1.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.8.1.bb
index 4893cab100..6cbd8baf83 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.8.1.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.8.1.bb
@@ -1,5 +1,6 @@
require linux-libc-headers.inc
+NATIVE_INSTALL_WORKS = "0"
HOMEPAGE = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/"
# license note from the package:
# Linux-libc-headers are derived from linux kernel headers. For license of a