aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/freesmartphone/aurora_git.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/recipes/freesmartphone/aurora_git.bb b/recipes/freesmartphone/aurora_git.bb
index 46a3ed6d52..65f996b6ec 100644
--- a/recipes/freesmartphone/aurora_git.bb
+++ b/recipes/freesmartphone/aurora_git.bb
@@ -4,9 +4,9 @@ AUTHOR = "Simon Busch <morphis@gravedo.de>"
HOMEPAGE = "http://www.freesmartphone.org"
SECTION = "fso"
LICENSE = "GPLv2"
-SRCREV = "6db9e04728bd0434e6b79939ee18be43017afeef"
+SRCREV = "26811e215c322d1aeb2cf04d083960a2abe774cb"
PV = "0.1.0+gitr${SRCPV}"
-PR = "r2"
+PR = "r4"
SRC_URI = "\
${FREESMARTPHONE_GIT}/aurora.git;protocol=git;branch=master \
@@ -14,6 +14,8 @@ SRC_URI = "\
"
S = "${WORKDIR}/git/aurora"
+DEPENDS = "shiboken-native libshiboken python"
+
RDEPENDS_${PN} = "\
python-logging \
python-textutils \
@@ -25,6 +27,8 @@ RDEPENDS_${PN} = "\
inherit autotools python-dir update-rc.d
+EXTRA_OECONF_append = "--enable-qws-support"
+
INITSCRIPT_NAME = "aurora-daemon"
INITSCRIPT_PARAMS = "defaults 90"
@@ -33,5 +37,6 @@ do_install_append() {
install -m 0755 ${WORKDIR}/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/
}
-PACKAGES = "${PN}"
+PACKAGES = "${PN}-dbg ${PN}"
+FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/aurora/.debug"
FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/aurora"