aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/ofono/ofono.inc19
-rw-r--r--recipes/ofono/ofono/ofono42
-rw-r--r--recipes/ofono/ofono_0.37.bb9
-rw-r--r--recipes/ofono/ofono_0.40.bb9
-rw-r--r--recipes/ofono/ofono_git.bb13
5 files changed, 92 insertions, 0 deletions
diff --git a/recipes/ofono/ofono.inc b/recipes/ofono/ofono.inc
new file mode 100644
index 0000000000..9089670007
--- /dev/null
+++ b/recipes/ofono/ofono.inc
@@ -0,0 +1,19 @@
+HOMEPAGE = "http://www.ofono.org"
+SUMMARY = "open source telephony"
+DESCRIPTION = "oFono is a stack for mobile telephony devices on Linux. oFono supports speaking to telephony devices through specific drivers, or with generic AT commands."
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
+ file://src/ofono.h;beginline=1;endline=20;md5=85d349dd8ec342c8f40d90e520f22779"
+
+inherit autotools pkgconfig update-rc.d
+
+DEPENDS = "dbus glib-2.0 udev"
+
+INITSCRIPT_NAME = "ofono"
+INITSCRIPT_PARAMS = "defaults 22"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/ofono ${D}${sysconfdir}/init.d/ofono
+}
+
diff --git a/recipes/ofono/ofono/ofono b/recipes/ofono/ofono/ofono
new file mode 100644
index 0000000000..6d46fb8966
--- /dev/null
+++ b/recipes/ofono/ofono/ofono
@@ -0,0 +1,42 @@
+#!/bin/sh
+
+DAEMON=/usr/sbin/ofonod
+PIDFILE=/var/run/ofonod.pid
+DESC="Telephony daemon"
+
+if [ -f /etc/default/ofono] ; then
+ . /etc/default/ofono
+fi
+
+set -e
+
+do_start() {
+ $DAEMON
+}
+
+do_stop() {
+ start-stop-daemon --stop --name ofonod --quiet
+}
+
+case "$1" in
+ start)
+ echo "Starting $DESC"
+ do_start
+ ;;
+ stop)
+ echo "Stopping $DESC"
+ do_stop
+ ;;
+ restart|force-reload)
+ echo "Restarting $DESC"
+ do_stop
+ sleep 1
+ do_start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes/ofono/ofono_0.37.bb b/recipes/ofono/ofono_0.37.bb
new file mode 100644
index 0000000000..1c1c50111d
--- /dev/null
+++ b/recipes/ofono/ofono_0.37.bb
@@ -0,0 +1,9 @@
+require ofono.inc
+
+PR = "r0"
+
+SRC_URI = "http://www.kernel.org/pub/linux/network/ofono/${P}.tar.bz2 \
+ file://ofono"
+
+SRC_URI[md5sum] = "fa9a6f91506db2ac5bf313ff0bde65f3"
+SRC_URI[sha256sum] = "0ac71d8a846d564ef6940c47bcc410b76df750aadf7903cb56876d991275f6db"
diff --git a/recipes/ofono/ofono_0.40.bb b/recipes/ofono/ofono_0.40.bb
new file mode 100644
index 0000000000..e952218eb5
--- /dev/null
+++ b/recipes/ofono/ofono_0.40.bb
@@ -0,0 +1,9 @@
+require ofono.inc
+
+PR = "r0"
+
+SRC_URI = "http://www.kernel.org/pub/linux/network/ofono/${P}.tar.bz2 \
+ file://ofono"
+
+SRC_URI[md5sum] = "a986891d41fdb025c01455008e108075"
+SRC_URI[sha256sum] = "e5c6532ea109ddacecc87031c4c8a37a604cbc26e063a2d1338b951bb226ec9a"
diff --git a/recipes/ofono/ofono_git.bb b/recipes/ofono/ofono_git.bb
new file mode 100644
index 0000000000..3e2c4108cf
--- /dev/null
+++ b/recipes/ofono/ofono_git.bb
@@ -0,0 +1,13 @@
+require ofono.inc
+
+S = "${WORKDIR}/git"
+PV = "0.12-git${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://git.kernel.org/pub/scm/network/ofono/ofono.git;protocol=git \
+ file://ofono"
+
+do_configure_prepend () {
+ ${S}/bootstrap
+}
+