summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/libtool/libtool-cross_2.2.6a.bb29
-rw-r--r--recipes/libtool/libtool-cross_2.2.6b.bb27
2 files changed, 33 insertions, 23 deletions
diff --git a/recipes/libtool/libtool-cross_2.2.6a.bb b/recipes/libtool/libtool-cross_2.2.6a.bb
index 0303cbb349..8b7ab3fba1 100644
--- a/recipes/libtool/libtool-cross_2.2.6a.bb
+++ b/recipes/libtool/libtool-cross_2.2.6a.bb
@@ -1,5 +1,5 @@
require libtool_${PV}.bb
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
SRC_URI += "\
file://cross_compile.patch \
@@ -23,22 +23,27 @@ do_compile () {
:
}
-do_stage () {
- install -m 0755 ${HOST_SYS}-libtool ${bindir}/${HOST_SYS}-libtool
- install -d ${STAGING_DIR_HOST}${target_datadir}/libtool ${STAGING_DIR_HOST}${target_datadir}/aclocal
- install -c ${S}/libltdl/config/config.guess ${STAGING_DIR_HOST}${target_datadir}/libtool/
- install -c ${S}/libltdl/config/config.sub ${STAGING_DIR_HOST}${target_datadir}/libtool/
- install -c -m 0644 ${S}/libltdl/config/ltmain.sh ${STAGING_DIR_HOST}${target_datadir}/libtool/
- install -c -m 0644 ${S}/libltdl/m4/libtool.m4 ${STAGING_DIR_HOST}${target_datadir}/aclocal/
- install -c -m 0644 ${S}/libltdl/m4/ltdl.m4 ${STAGING_DIR_HOST}${target_datadir}/aclocal/
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/${HOST_SYS}-libtool
+ install -d ${D}${datadir}/libtool/
+ install -d ${D}${datadir}/aclocal/
+ install -c ${S}/libltdl/config/config.guess ${D}${datadir}/libtool/
+ install -c ${S}/libltdl/config/config.sub ${D}${datadir}/libtool/
+ install -c -m 0644 ${S}/libltdl/config/ltmain.sh ${D}${datadir}/libtool/
+ install -c -m 0644 ${S}/libltdl/m4/libtool.m4 ${D}${datadir}/aclocal/
+ install -c -m 0644 ${S}/libltdl/m4/ltdl.m4 ${D}${datadir}/aclocal/
if [ -e ${WORKDIR}/dolt.m4 ] ; then
- install -c -m 0644 ${WORKDIR}/dolt.m4 ${STAGING_DIR_HOST}${target_datadir}/aclocal/
+ install -c -m 0644 ${WORKDIR}/dolt.m4 ${D}${datadir}/aclocal/
fi
}
+SYSROOT_PREPROCESS_FUNCS += "libtoolcross_sysroot_preprocess"
-do_install () {
- :
+libtoolcross_sysroot_preprocess () {
+ install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/
+ install -m 755 ${D}${bindir}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool
}
PACKAGES = ""
+NATIVE_INSTALL_WORKS = "1"
diff --git a/recipes/libtool/libtool-cross_2.2.6b.bb b/recipes/libtool/libtool-cross_2.2.6b.bb
index 0303cbb349..e9461c7c5c 100644
--- a/recipes/libtool/libtool-cross_2.2.6b.bb
+++ b/recipes/libtool/libtool-cross_2.2.6b.bb
@@ -23,22 +23,27 @@ do_compile () {
:
}
-do_stage () {
- install -m 0755 ${HOST_SYS}-libtool ${bindir}/${HOST_SYS}-libtool
- install -d ${STAGING_DIR_HOST}${target_datadir}/libtool ${STAGING_DIR_HOST}${target_datadir}/aclocal
- install -c ${S}/libltdl/config/config.guess ${STAGING_DIR_HOST}${target_datadir}/libtool/
- install -c ${S}/libltdl/config/config.sub ${STAGING_DIR_HOST}${target_datadir}/libtool/
- install -c -m 0644 ${S}/libltdl/config/ltmain.sh ${STAGING_DIR_HOST}${target_datadir}/libtool/
- install -c -m 0644 ${S}/libltdl/m4/libtool.m4 ${STAGING_DIR_HOST}${target_datadir}/aclocal/
- install -c -m 0644 ${S}/libltdl/m4/ltdl.m4 ${STAGING_DIR_HOST}${target_datadir}/aclocal/
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/${HOST_SYS}-libtool
+ install -d ${D}${datadir}/libtool/
+ install -d ${D}${datadir}/aclocal/
+ install -c ${S}/libltdl/config/config.guess ${D}${datadir}/libtool/
+ install -c ${S}/libltdl/config/config.sub ${D}${datadir}/libtool/
+ install -c -m 0644 ${S}/libltdl/config/ltmain.sh ${D}${datadir}/libtool/
+ install -c -m 0644 ${S}/libltdl/m4/libtool.m4 ${D}${datadir}/aclocal/
+ install -c -m 0644 ${S}/libltdl/m4/ltdl.m4 ${D}${datadir}/aclocal/
if [ -e ${WORKDIR}/dolt.m4 ] ; then
- install -c -m 0644 ${WORKDIR}/dolt.m4 ${STAGING_DIR_HOST}${target_datadir}/aclocal/
+ install -c -m 0644 ${WORKDIR}/dolt.m4 ${D}${datadir}/aclocal/
fi
}
+SYSROOT_PREPROCESS_FUNCS += "libtoolcross_sysroot_preprocess"
-do_install () {
- :
+libtoolcross_sysroot_preprocess () {
+ install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/
+ install -m 755 ${D}${bindir}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool
}
PACKAGES = ""
+NATIVE_INSTALL_WORKS = "1"