summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/blueman/blueman_1.10.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/blueman/blueman_1.10.bb b/recipes/blueman/blueman_1.10.bb
new file mode 100644
index 0000000000..61309023c5
--- /dev/null
+++ b/recipes/blueman/blueman_1.10.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Blueman is a GTK+ Bluetooth Manager"
+HOMEPAGE = "http://www.blueman-project.org/"
+SECTION = "optional"
+DEPENDS = "gtk+ glib-2.0 bluez4 intltool python python-native python-pyrex startup-notification"
+RDEPENDS = "python-dbus python-pygobject python dbus bluez4 python-pygtk python-notify obex-data-server \
+"
+
+PR = "r1"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF += "--with-no-runtime-deps-check"
+
+BLUEZ_LIBS = "-L${libdir} -lbluetooth"
+BLUEZ_CFLAGS = "-I${includedir}"
+
+SRC_URI = "\
+ http://download.tuxfamily.org/blueman/blueman-${PV}.tar.gz\
+ "
+
+FILES_${PN}-dbg += "${libdir}/python2.6/site-packages/.debug"
+FILES_${PN} += "${libdir} ${datadir}"
+
+do_configure_prepend() {
+ sed -i "s/py_prefix=.*$/py_prefix=\"${@"${STAGING_DIR_TARGET}".replace("/","\/")}\/usr\"/" ${S}/acinclude.m4
+ sed -i "s/py_exec_prefix=.*$/py_exec_prefix=\"${@"${STAGING_DIR_TARGET}".replace("/","\/")}\/usr\"/" ${S}/acinclude.m4
+}