summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/xfsprogs/xfsprogs_2.8.16.bb6
-rw-r--r--recipes/xfsprogs/xfsprogs_3.1.2.bb5
2 files changed, 7 insertions, 4 deletions
diff --git a/recipes/xfsprogs/xfsprogs_2.8.16.bb b/recipes/xfsprogs/xfsprogs_2.8.16.bb
index 1fb4f7ba4c..28caafd4a2 100644
--- a/recipes/xfsprogs/xfsprogs_2.8.16.bb
+++ b/recipes/xfsprogs/xfsprogs_2.8.16.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "XFS Filesystem Utilities"
HOMEPAGE = "http://oss.sgi.com/projects/xfs"
LICENSE = "GPL"
SECTION = "base"
-PR = "r2"
+PR = "r3"
DEPENDS = "util-linux-ng"
SRC_URI = "http://slackware.osuosl.org/slackware-12.0/source/a/xfsprogs/xfsprogs_2.8.16-1.tar.gz"
@@ -11,8 +11,10 @@ PARALLEL_MAKE = ""
inherit autotools
EXTRA_OECONF = "--enable-gettext=no"
+EXTRA_OEMAKE = "'LIBTOOL=${HOST_SYS}-libtool'"
+
do_configure () {
- export LIBTOOL="${STAGING_BINDIR_NATIVE}/${HOST_SYS}-libtool"
+ export LIBTOOL="${HOST_SYS}-libtool"
export DEBUG="-DNDEBUG"
oe_runconf
}
diff --git a/recipes/xfsprogs/xfsprogs_3.1.2.bb b/recipes/xfsprogs/xfsprogs_3.1.2.bb
index 832d5ab727..daec1c2667 100644
--- a/recipes/xfsprogs/xfsprogs_3.1.2.bb
+++ b/recipes/xfsprogs/xfsprogs_3.1.2.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://oss.sgi.com/projects/xfs"
LICENSE = "GPL"
SECTION = "base"
DEPENDS = "util-linux-ng"
-PR = "r1"
+PR = "r2"
SRC_URI = "ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz"
SRC_URI[md5sum] = "86d10178ee6897cb099c97303e6d9da0"
@@ -12,13 +12,14 @@ SRC_URI[sha256sum] = "9128046ea978a65560b0e87406af9646a283fa0b54eab1801b971d8a89
PARALLEL_MAKE = ""
inherit autotools
EXTRA_OECONF = "--enable-gettext=no"
+LIBTOOL = "${HOST_SYS}-libtool"
+EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
TARGET_CC_ARCH += "${LDFLAGS}"
FILES_${PN}-dev += "${base_libdir}/libhandle.la \
${base_libdir}/libhandle.so"
do_configure () {
- export LIBTOOL="${STAGING_BINDIR_NATIVE}/${HOST_SYS}-libtool"
export DEBUG="-DNDEBUG"
oe_runconf
}