summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/linux/linux-omap-2.6.32/cm-t35/0001-omap3-cm-t35-add-mux-initialization.patch153
-rw-r--r--recipes/linux/linux-omap-2.6.32/dss2/0015-OMAP-DSS-Add-DSS2-support-for-Beagle.patch40
-rw-r--r--recipes/linux/linux-omap-2.6.32/holes.patch39
-rw-r--r--recipes/linux/linux-omap_2.6.32.bb10
4 files changed, 70 insertions, 172 deletions
diff --git a/recipes/linux/linux-omap-2.6.32/cm-t35/0001-omap3-cm-t35-add-mux-initialization.patch b/recipes/linux/linux-omap-2.6.32/cm-t35/0001-omap3-cm-t35-add-mux-initialization.patch
index 07f901c9a6..e69de29bb2 100644
--- a/recipes/linux/linux-omap-2.6.32/cm-t35/0001-omap3-cm-t35-add-mux-initialization.patch
+++ b/recipes/linux/linux-omap-2.6.32/cm-t35/0001-omap3-cm-t35-add-mux-initialization.patch
@@ -1,153 +0,0 @@
-Date: Wed, 09 Dec 2009 15:22:20 +0200
-From: Mike Rapoport <mike@compulab.co.il>
-To: Koen Kooi <koen@dominion.thruhere.net>
-Subject: Re: linux-omap 2.6.32 updates
-
-
-Mike Rapoport wrote:
->> The tdo24m patch is indeed in the linux-omap tree and the mux patch should be
->> different for the updated linux-omap (at least with
->> SRCREV = "6833f1a8cdcb65a370f898bde6b6af63f81962df").
->>
->> Attached the actual patch needed to initialize cm-t35 mux and updated recipe
->> diff that uses this patch.
->>
->> I don't know yet if Tony is going to merge my latest patches before the merge
->> window closes. If you're going to bump SRCREV once again in the next few days,
->> it's possible that cm-t35 patches won't be needed at all.
-
---
-Sincerely yours,
-Mike.
-
-
-diff --git a/arch/arm/mach-omap2/Kconfig b/arch/arm/mach-omap2/Kconfig
-index 16c0c13..66de47b 100644
---- a/arch/arm/mach-omap2/Kconfig
-+++ b/arch/arm/mach-omap2/Kconfig
-@@ -136,6 +136,7 @@ config MACH_CM_T35
- bool "CompuLab CM-T35 module"
- depends on ARCH_OMAP3 && ARCH_OMAP34XX
- select OMAP_PACKAGE_CUS
-+ select OMAP_MUX
-
- config MACH_IGEP0020
- bool "IGEP0020"
-diff --git a/arch/arm/mach-omap2/board-cm-t35.c b/arch/arm/mach-omap2/board-cm-t35.c
-index 507c922..1591aae 100644
---- a/arch/arm/mach-omap2/board-cm-t35.c
-+++ b/arch/arm/mach-omap2/board-cm-t35.c
-@@ -482,13 +482,98 @@ static void __init cm_t35_map_io(void)
- omap2_map_common_io();
- }
-
--#ifdef CONFIG_OMAP_MUX
- static struct omap_board_mux board_mux[] __initdata = {
-+ /* nCS and IRQ for CM-T35 ethernet */
-+ OMAP3_MUX(GPMC_NCS5, OMAP_MUX_MODE0),
-+ OMAP3_MUX(UART3_CTS_RCTX, OMAP_MUX_MODE4 | OMAP_PIN_INPUT_PULLUP),
-+
-+ /* nCS and IRQ for SB-T35 ethernet */
-+ OMAP3_MUX(GPMC_NCS4, OMAP_MUX_MODE0),
-+ OMAP3_MUX(GPMC_WAIT3, OMAP_MUX_MODE4 | OMAP_PIN_INPUT_PULLUP),
-+
-+ /* PENDOWN GPIO */
-+ OMAP3_MUX(GPMC_NCS6, OMAP_MUX_MODE4 | OMAP_PIN_INPUT),
-+
-+ /* mUSB */
-+ OMAP3_MUX(HSUSB0_CLK, OMAP_MUX_MODE0 | OMAP_PIN_INPUT),
-+ OMAP3_MUX(HSUSB0_STP, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(HSUSB0_DIR, OMAP_MUX_MODE0 | OMAP_PIN_INPUT),
-+ OMAP3_MUX(HSUSB0_NXT, OMAP_MUX_MODE0 | OMAP_PIN_INPUT),
-+ OMAP3_MUX(HSUSB0_DATA0, OMAP_MUX_MODE0 | OMAP_PIN_INPUT),
-+ OMAP3_MUX(HSUSB0_DATA1, OMAP_MUX_MODE0 | OMAP_PIN_INPUT),
-+ OMAP3_MUX(HSUSB0_DATA2, OMAP_MUX_MODE0 | OMAP_PIN_INPUT),
-+ OMAP3_MUX(HSUSB0_DATA3, OMAP_MUX_MODE0 | OMAP_PIN_INPUT),
-+ OMAP3_MUX(HSUSB0_DATA4, OMAP_MUX_MODE0 | OMAP_PIN_INPUT),
-+ OMAP3_MUX(HSUSB0_DATA5, OMAP_MUX_MODE0 | OMAP_PIN_INPUT),
-+ OMAP3_MUX(HSUSB0_DATA6, OMAP_MUX_MODE0 | OMAP_PIN_INPUT),
-+ OMAP3_MUX(HSUSB0_DATA7, OMAP_MUX_MODE0 | OMAP_PIN_INPUT),
-+
-+ /* MMC 2 */
-+ OMAP3_MUX(SDMMC2_DAT4, OMAP_MUX_MODE1 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(SDMMC2_DAT5, OMAP_MUX_MODE1 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(SDMMC2_DAT6, OMAP_MUX_MODE1 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(SDMMC2_DAT7, OMAP_MUX_MODE1 | OMAP_PIN_INPUT),
-+
-+ /* McSPI 1 */
-+ OMAP3_MUX(MCSPI1_CLK, OMAP_MUX_MODE0 | OMAP_PIN_INPUT),
-+ OMAP3_MUX(MCSPI1_SIMO, OMAP_MUX_MODE0 | OMAP_PIN_INPUT),
-+ OMAP3_MUX(MCSPI1_SOMI, OMAP_MUX_MODE0 | OMAP_PIN_INPUT),
-+ OMAP3_MUX(MCSPI1_CS0, OMAP_MUX_MODE0 | OMAP_PIN_INPUT_PULLDOWN),
-+
-+ /* McSPI 4 */
-+ OMAP3_MUX(MCBSP1_CLKR, OMAP_MUX_MODE1 | OMAP_PIN_INPUT),
-+ OMAP3_MUX(MCBSP1_DX, OMAP_MUX_MODE1 | OMAP_PIN_INPUT),
-+ OMAP3_MUX(MCBSP1_DR, OMAP_MUX_MODE1 | OMAP_PIN_INPUT),
-+ OMAP3_MUX(MCBSP1_FSX, OMAP_MUX_MODE1 | OMAP_PIN_INPUT_PULLUP),
-+
-+ /* McBSP 2 */
-+ OMAP3_MUX(MCBSP2_FSX, OMAP_MUX_MODE0 | OMAP_PIN_INPUT),
-+ OMAP3_MUX(MCBSP2_CLKX, OMAP_MUX_MODE0 | OMAP_PIN_INPUT),
-+ OMAP3_MUX(MCBSP2_DR, OMAP_MUX_MODE0 | OMAP_PIN_INPUT),
-+ OMAP3_MUX(MCBSP2_DX, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+
-+ /* serial ports */
-+ OMAP3_MUX(MCBSP3_CLKX, OMAP_MUX_MODE1 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(MCBSP3_FSX, OMAP_MUX_MODE1 | OMAP_PIN_INPUT),
-+ OMAP3_MUX(UART1_TX, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(UART1_RX, OMAP_MUX_MODE0 | OMAP_PIN_INPUT),
-+
-+ /* DSS */
-+ OMAP3_MUX(DSS_PCLK, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_HSYNC, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_VSYNC, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_ACBIAS, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA0, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA1, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA2, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA3, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA4, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA5, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA6, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA7, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA8, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA9, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA10, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA11, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA12, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA13, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA14, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA15, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA16, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA17, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA18, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA19, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA20, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA21, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA22, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+ OMAP3_MUX(DSS_DATA23, OMAP_MUX_MODE0 | OMAP_PIN_OUTPUT),
-+
-+ /* TPS IRQ */
-+ OMAP3_MUX(SYS_NIRQ, OMAP_MUX_MODE0 | OMAP_WAKEUP_EN | \
-+ OMAP_PIN_INPUT_PULLUP),
-+
- { .reg_offset = OMAP_MUX_TERMINATOR },
- };
--#else
--#define board_mux NULL
--#endif
-
- static void __init cm_t35_init(void)
- {
-@@ -501,9 +586,6 @@ static void __init cm_t35_init(void)
- cm_t35_init_led();
-
- usb_musb_init();
--
-- omap_mux_init_signal("sys_nirq",
-- OMAP_WAKEUP_EN | OMAP_PIN_INPUT_PULLUP);
- }
-
- MACHINE_START(CM_T35, "Compulab CM-T35")
-
diff --git a/recipes/linux/linux-omap-2.6.32/dss2/0015-OMAP-DSS-Add-DSS2-support-for-Beagle.patch b/recipes/linux/linux-omap-2.6.32/dss2/0015-OMAP-DSS-Add-DSS2-support-for-Beagle.patch
index 656ba85318..acffe95f36 100644
--- a/recipes/linux/linux-omap-2.6.32/dss2/0015-OMAP-DSS-Add-DSS2-support-for-Beagle.patch
+++ b/recipes/linux/linux-omap-2.6.32/dss2/0015-OMAP-DSS-Add-DSS2-support-for-Beagle.patch
@@ -1,5 +1,15 @@
---- /tmp/board-omap3beagle.c 2009-12-22 10:47:35.000000000 +0100
-+++ git/arch/arm/mach-omap2/board-omap3beagle.c 2009-12-22 10:59:53.000000000 +0100
+From: Steve Sakoman <steve@sakoman.com>
+Date: Fri, 18 Dec 2009 19:48:53 +0000 (-0800)
+Subject: OMAP: DSS: Add DSS2 support for Beagle
+X-Git-Url: http://www.sakoman.com/cgi-bin/gitweb.cgi?p=linux-omap-2.6.git;a=commitdiff_plain;h=7b5a8596f85382c7aa51971aa3889675e55a97b9
+
+OMAP: DSS: Add DSS2 support for Beagle
+---
+
+diff --git a/arch/arm/mach-omap2/board-omap3beagle.c b/arch/arm/mach-omap2/board-omap3beagle.c
+index 955da5b..f18c751 100644
+--- a/arch/arm/mach-omap2/board-omap3beagle.c
++++ b/arch/arm/mach-omap2/board-omap3beagle.c
@@ -40,6 +40,7 @@
#include <plat/board.h>
@@ -7,8 +17,8 @@
+#include <plat/display.h>
#include <plat/gpmc.h>
#include <plat/nand.h>
- #include <plat/usb.h>
-@@ -149,6 +150,105 @@
+ #include <plat/mux.h>
+@@ -149,6 +150,105 @@ static struct platform_device omap3beagle_nand_device = {
.resource = &omap3beagle_nand_resource,
};
@@ -114,7 +124,7 @@
#include "sdram-micron-mt46h32m32lf-6.h"
static struct twl4030_hsmmc_info mmc[] = {
-@@ -168,15 +268,6 @@
+@@ -168,15 +268,6 @@ static struct twl4030_hsmmc_info mmc[] = {
{} /* Terminator */
};
@@ -130,7 +140,7 @@
static struct regulator_consumer_supply beagle_vmmc1_supply = {
.supply = "vmmc",
};
-@@ -232,16 +323,6 @@
+@@ -232,16 +323,6 @@ static struct twl4030_gpio_platform_data beagle_gpio_data = {
.setup = beagle_twl_gpio_setup,
};
@@ -147,7 +157,7 @@
/* VMMC1 for MMC1 pins CMD, CLK, DAT0..DAT3 (20 mA, plus card == max 220 mA) */
static struct regulator_init_data beagle_vmmc1 = {
.constraints = {
-@@ -419,14 +500,8 @@
+@@ -419,14 +500,8 @@ static struct platform_device keys_gpio = {
},
};
@@ -162,7 +172,7 @@
omap2_init_common_hw(mt46h32m32lf6_sdrc_params,
mt46h32m32lf6_sdrc_params);
omap_init_irq();
-@@ -437,9 +512,9 @@
+@@ -437,9 +512,9 @@ static void __init omap3_beagle_init_irq(void)
}
static struct platform_device *omap3_beagle_devices[] __initdata = {
@@ -173,14 +183,12 @@
};
static void __init omap3beagle_flash_init(void)
-@@ -522,8 +597,9 @@
+@@ -513,6 +588,8 @@ static void __init omap3_beagle_init(void)
/* Ensure SDRC pins are mux'd for self-refresh */
- omap_mux_init_signal("sdrc_cke0", OMAP_PIN_OUTPUT);
- omap_mux_init_signal("sdrc_cke1", OMAP_PIN_OUTPUT);
--}
-
+ omap_cfg_reg(H16_34XX_SDRC_CKE0);
+ omap_cfg_reg(H17_34XX_SDRC_CKE1);
++
+ beagle_display_init();
-+}
+ }
+
static void __init omap3_beagle_map_io(void)
- {
- omap2_set_globals_343x();
diff --git a/recipes/linux/linux-omap-2.6.32/holes.patch b/recipes/linux/linux-omap-2.6.32/holes.patch
new file mode 100644
index 0000000000..504bf40021
--- /dev/null
+++ b/recipes/linux/linux-omap-2.6.32/holes.patch
@@ -0,0 +1,39 @@
+From patchwork Thu Jan 7 12:30:08 2010
+Content-Type: text/plain; charset="utf-8"
+MIME-Version: 1.0
+Content-Transfer-Encoding: 7bit
+Subject: ARCH OMAP : enable ARCH_HAS_HOLES_MEMORYMODEL for OMAP
+Date: Thu, 07 Jan 2010 12:30:08 -0000
+From: Sriram <srk@ti.com>
+X-Patchwork-Id: 71579
+
+From: Sriram <srk@ti.com>
+
+OMAP platforms(like OMAP3530) include DSP or other co-processors
+for media acceleration. when carving out memory for the
+accelerators we can end up creating a hole in the memory map
+of sort:
+<kernel memory><hole(memory for accelerator)><kernel memory>
+
+To handle such a memory configuration ARCH_HAS_HOLES_MEMORYMODEL
+has to be enabled. For further information refer discussion at:
+http://www.mail-archive.com/linux-omap@vger.kernl.org/msg15262.html.
+
+Signed-off-by: Sriramakrishnan <srk@ti.com>
+
+---
+arch/arm/Kconfig | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
+index 5e0bcc5..88f628b 100644
+--- a/arch/arm/Kconfig
++++ b/arch/arm/Kconfig
+@@ -699,6 +699,7 @@ config ARCH_OMAP
+ select ARCH_HAS_CPUFREQ
+ select GENERIC_TIME
+ select GENERIC_CLOCKEVENTS
++ select ARCH_HAS_HOLES_MEMORYMODEL
+ help
+ Support for TI's OMAP platform (OMAP1 and OMAP2).
+
diff --git a/recipes/linux/linux-omap_2.6.32.bb b/recipes/linux/linux-omap_2.6.32.bb
index 285c260c41..b0203d8068 100644
--- a/recipes/linux/linux-omap_2.6.32.bb
+++ b/recipes/linux/linux-omap_2.6.32.bb
@@ -8,7 +8,7 @@ COMPATIBLE_MACHINE = "omap5912osk|omap1710h3|omap2430sdp|omap2420h4|beagleboard|
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_cm-t35 = "1"
-SRCREV = "6833f1a8cdcb65a370f898bde6b6af63f81962df"
+SRCREV = "89c9eaeb92c97348dcabd6cb377b646c00855f6a"
# The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
PV = "2.6.32"
@@ -17,12 +17,15 @@ SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.g
file://defconfig"
SRC_URI_append = " \
-file://sctp-fix.patch;patch=1 \
+file://usb/ehci.patch;patch=1 \
+file://usb/ehci-omap.c-mach-to-plat.diff;patch=1 \
file://cm-t35/0001-omap3-cm-t35-add-mux-initialization.patch;patch=1 \
file://cm-t35/0001-OMAP-DSS2-add-Toppoly-TDO35S-panel.patch;patch=1 \
file://cm-t35/0002-omap3-cm-t35-add-DSS2-display-support.patch;patch=1 \
file://cm-t35/0003-omap3-cm-t35-update-defconfig-for-DSS2.patch;patch=1 \
+file://cm-t35/0004-omap3-cm-t35-add-cm-t35-mux-configs.patch;patch=1 \
file://cm-t35/0006-omap3-cm-t35-update-defconfig.patch;patch=1 \
+file://cm-t35/0001-backlight-tdo24m-ensure-chip-select-changes-between-.patch;patch=1 \
file://0001-ARM-OMAP-Overo-Add-support-for-second-ethernet-po.patch;patch=1 \
file://0003-drivers-net-smsc911x-return-ENODEV-if-device-is-n.patch;patch=1 \
file://0004-drivers-input-touchscreen-ads7846-return-ENODEV.patch;patch=1 \
@@ -35,9 +38,10 @@ file://madc/0010-ARM-OMAP-Add-twl4030-madc-support-to-Overo.patch;patch=1 \
file://madc/0011-ARM-OMAP-Add-twl4030-madc-support-to-Beagle.patch;patch=1 \
file://madc/0013-ARM-OMAP-Add-missing-twl4030-madc-header-file.patch;patch=1 \
file://dss2/0012-OMAP-DSS2-Add-support-for-LG-Philips-LB035Q02-pane.patch;patch=1 \
-#file://dss2/0014-OMAP-DSS-Add-DSS2-support-for-Overo.patch;patch=1 \
+file://dss2/0014-OMAP-DSS-Add-DSS2-support-for-Overo.patch;patch=1 \
file://dss2/0015-OMAP-DSS-Add-DSS2-support-for-Beagle.patch;patch=1 \
file://dss2/0016-video-add-timings-for-hd720.patch;patch=1 \
+file://holes.patch;patch=1 \
"
SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \