summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/fastjar/fastjar-native.inc28
-rw-r--r--recipes/fastjar/fastjar-native_0.95.bb30
-rw-r--r--recipes/fastjar/fastjar-native_0.98.bb3
4 files changed, 37 insertions, 28 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 4c04071f82..54cb21d1aa 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -6306,6 +6306,10 @@ sha256=84553ff12c5245705806107448e85c96950b4b7a5eaf85461c89987be8ea644d
md5=92a70f9e56223b653bce0f58f90cf950
sha256=ca03811490c965abc9f466e75418ae48bb71f14d8e8ed4c43e8109207b85ce54
+[http://download.savannah.nongnu.org/releases/fastjar/fastjar-0.98.tar.gz]
+md5=d2d264d343d4d0e1575832cc1023c3bf
+sha256=f156abc5de8658f22ee8f08d7a72c88f9409ebd8c7933e9466b0842afeb2f145
+
[http://ftp3.ie.freebsd.org/pub/gentoo/distfiles/fbgetty-0.1.698.tar.gz]
md5=1705bc0f8f1e03fe50d324ba84ac4e56
sha256=332cbffa7c489b39a7d13d12d581c27dfc57ba098041431a6845b44785cf2d35
diff --git a/recipes/fastjar/fastjar-native.inc b/recipes/fastjar/fastjar-native.inc
new file mode 100644
index 0000000000..fa7c7ca646
--- /dev/null
+++ b/recipes/fastjar/fastjar-native.inc
@@ -0,0 +1,28 @@
+DESCRIPTION = "jar replacement written in C."
+HOMEPAGE = "http://savannah.nongnu.org/projects/fastjar/"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+INC_PR = "r1"
+
+DEPENDS = "zlib-native"
+
+SRC_URI = "http://download.savannah.nongnu.org/releases/fastjar/fastjar-${PV}.tar.gz"
+
+S = "${WORKDIR}/fastjar-${PV}"
+
+inherit autotools native
+
+EXTRA_OECONF = "--with-system-zlib --with-fastjar"
+
+do_configure () {
+ gnu-configize || die "failure running gnu-configize"
+ oe_runconf
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 755 .libs/fastjar ${STAGING_BINDIR}/fastjar
+ install -m 755 .libs/grepjar ${STAGING_BINDIR}
+}
diff --git a/recipes/fastjar/fastjar-native_0.95.bb b/recipes/fastjar/fastjar-native_0.95.bb
index 3d003306b8..6d2cdb4f24 100644
--- a/recipes/fastjar/fastjar-native_0.95.bb
+++ b/recipes/fastjar/fastjar-native_0.95.bb
@@ -1,29 +1,3 @@
-DESCRIPTION = "jar replacement written in C."
-HOMEPAGE = "http://savannah.nongnu.org/projects/fastjar/"
-SECTION = "devel"
-PRIORITY = "optional"
-LICENSE = "GPL"
+require fastjar-native.inc
-PR = "r1"
-
-DEPENDS = "zlib-native"
-
-SRC_URI = "http://download.savannah.nongnu.org/releases/fastjar/fastjar-${PV}.tar.gz"
-
-S = "${WORKDIR}/fastjar-${PV}"
-
-inherit autotools native
-
-EXTRA_OECONF = "--with-system-zlib --with-fastjar"
-
-do_configure () {
- gnu-configize || die "failure running gnu-configize"
- oe_runconf
-}
-
-do_stage() {
- #we should teach autotools.bbclass:autotools_stage_all() about ${STAGING_BINDIR}
- install -d ${STAGING_BINDIR}
- install -m 755 .libs/fastjar ${STAGING_BINDIR}/fastjar
- install -m 755 .libs/grepjar ${STAGING_BINDIR}
-}
+PR = "${INC_PR}.1"
diff --git a/recipes/fastjar/fastjar-native_0.98.bb b/recipes/fastjar/fastjar-native_0.98.bb
new file mode 100644
index 0000000000..6d2cdb4f24
--- /dev/null
+++ b/recipes/fastjar/fastjar-native_0.98.bb
@@ -0,0 +1,3 @@
+require fastjar-native.inc
+
+PR = "${INC_PR}.1"