summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/perl/perl.inc8
-rw-r--r--recipes/perl/perl_5.10.1.bb7
-rw-r--r--recipes/perl/perl_5.8.8.bb7
3 files changed, 10 insertions, 12 deletions
diff --git a/recipes/perl/perl.inc b/recipes/perl/perl.inc
new file mode 100644
index 0000000000..ddde0b8872
--- /dev/null
+++ b/recipes/perl/perl.inc
@@ -0,0 +1,8 @@
+# helper functions for perl
+def all_perl_packages(d):
+ depchains = (d.getVar("DEPCHAIN_POST", True) or "").split()
+ blacklist = ["perl-modules", "perl-misc", "perl-pod", "perl-doc"]
+ for pkg in d.getVar("PACKAGES", True).split():
+ if not pkg in blacklist and not any(pkg.endswith(post) for post in depchains):
+ yield pkg
+
diff --git a/recipes/perl/perl_5.10.1.bb b/recipes/perl/perl_5.10.1.bb
index 75993b519a..a09c59dcbc 100644
--- a/recipes/perl/perl_5.10.1.bb
+++ b/recipes/perl/perl_5.10.1.bb
@@ -210,12 +210,7 @@ FILES_${PN}-doc = "${datadir}/perl/${PV}/*/*.txt \
RPROVIDES_perl-lib = "perl-lib"
-def all_perl_packages(d):
- depchains = (d.getVar("DEPCHAIN_POST", True) or "").split()
- blacklist = ["perl-modules", "perl-misc", "perl-pod", "perl-doc"]
- for pkg in d.getVar("PACKAGES", True).split():
- if not pkg in blacklist and not any(pkg.endswith(post) for post in depchains):
- yield pkg
+require perl.inc
# Create a perl-modules package recommending all the other perl
# packages (actually the non modules packages and not created too)
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index ed489f4ac5..c8ad895e56 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -210,12 +210,7 @@ FILES_${PN}-doc = "${datadir}/perl/${PV}/*/*.txt \
RPROVIDES_perl-lib = "perl-lib"
-def all_perl_packages(d):
- depchains = (d.getVar("DEPCHAIN_POST", True) or "").split()
- blacklist = ["perl-modules", "perl-misc", "perl-pod", "perl-doc"]
- for pkg in d.getVar("PACKAGES", True).split():
- if not pkg in blacklist and not any(pkg.endswith(post) for post in depchains):
- yield pkg
+require perl.inc
# Create a perl-modules package recommending all the other perl
# packages (actually the non modules packages and not created too)