summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/gcc/gcc-4.2.1.inc1
-rw-r--r--recipes/gcc/gcc-4.2.1/fix-ICE-in-arm_unwind_emit_set.diff18
-rw-r--r--recipes/gcc/gcc-4.2.2.inc3
-rw-r--r--recipes/gcc/gcc-4.2.2/fix-ICE-in-arm_unwind_emit_set.diff18
-rw-r--r--recipes/gcc/gcc-4.2.3.inc3
-rw-r--r--recipes/gcc/gcc-4.2.3/fix-ICE-in-arm_unwind_emit_set.diff18
-rw-r--r--recipes/gcc/gcc-4.2.4.inc3
-rw-r--r--recipes/gcc/gcc-4.2.4/fix-ICE-in-arm_unwind_emit_set.diff18
-rw-r--r--recipes/gcc/gcc-4.3.1.inc3
-rw-r--r--recipes/gcc/gcc-4.3.1/fix-ICE-in-arm_unwind_emit_set.diff28
-rw-r--r--recipes/gcc/gcc-4.3.2.inc3
-rw-r--r--recipes/gcc/gcc-4.3.2/fix-ICE-in-arm_unwind_emit_set.diff28
-rw-r--r--recipes/gcc/gcc-4.3.3.inc3
-rw-r--r--recipes/gcc/gcc-4.3.3/fix-ICE-in-arm_unwind_emit_set.diff28
-rw-r--r--recipes/gcc/gcc-4.4.0/fix-ICE-in-arm_unwind_emit_set.diff28
-rw-r--r--recipes/gcc/gcc-cross_4.2.1.bb2
-rw-r--r--recipes/gcc/gcc_4.2.1.bb2
17 files changed, 8 insertions, 199 deletions
diff --git a/recipes/gcc/gcc-4.2.1.inc b/recipes/gcc/gcc-4.2.1.inc
index b48d709115..c4e2c3a0c6 100644
--- a/recipes/gcc/gcc-4.2.1.inc
+++ b/recipes/gcc/gcc-4.2.1.inc
@@ -29,7 +29,6 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://arm-thumb-cache.patch;patch=1 \
file://zecke-xgcc-cpp.patch;patch=1 \
file://unbreak-armv4t.patch;patch=1 \
- file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
file://cache-amnesia.patch;patch=1 \
file://gfortran.patch;patch=1 \
file://pr34130.patch;patch=1 \
diff --git a/recipes/gcc/gcc-4.2.1/fix-ICE-in-arm_unwind_emit_set.diff b/recipes/gcc/gcc-4.2.1/fix-ICE-in-arm_unwind_emit_set.diff
deleted file mode 100644
index 568e15abff..0000000000
--- a/recipes/gcc/gcc-4.2.1/fix-ICE-in-arm_unwind_emit_set.diff
+++ /dev/null
@@ -1,18 +0,0 @@
---- trunk/gcc/config/arm/arm.c 2006/09/19 13:18:27 117055
-+++ trunk/gcc/config/arm/arm.c 2006/09/19 13:19:24 117056
-@@ -15415,6 +15415,15 @@
- /* Move from sp to reg. */
- asm_fprintf (asm_out_file, "\t.movsp %r\n", REGNO (e0));
- }
-+ else if (GET_CODE (e1) == PLUS
-+ && GET_CODE (XEXP (e1, 0)) == REG
-+ && REGNO (XEXP (e1, 0)) == SP_REGNUM
-+ && GET_CODE (XEXP (e1, 1)) == CONST_INT)
-+ {
-+ /* Set reg to offset from sp. */
-+ asm_fprintf (asm_out_file, "\t.movsp %r, #%d\n",
-+ REGNO (e0), (int)INTVAL(XEXP (e1, 1)));
-+ }
- else
- abort ();
- break;
diff --git a/recipes/gcc/gcc-4.2.2.inc b/recipes/gcc/gcc-4.2.2.inc
index fcebabc112..0eb1223727 100644
--- a/recipes/gcc/gcc-4.2.2.inc
+++ b/recipes/gcc/gcc-4.2.2.inc
@@ -3,7 +3,7 @@ LICENSE = "GPLv3"
DEPENDS = "mpfr gmp"
-INC_PR = "r14"
+INC_PR = "r15"
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://100-uclibc-conf.patch;patch=1 \
@@ -33,7 +33,6 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://arm-thumb-cache.patch;patch=1 \
file://zecke-xgcc-cpp.patch;patch=1 \
file://unbreak-armv4t.patch;patch=1 \
- file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
file://cache-amnesia.patch;patch=1 \
file://gfortran.patch;patch=1 \
file://gcc-4.0.2-e300c2c3.patch;patch=1 \
diff --git a/recipes/gcc/gcc-4.2.2/fix-ICE-in-arm_unwind_emit_set.diff b/recipes/gcc/gcc-4.2.2/fix-ICE-in-arm_unwind_emit_set.diff
deleted file mode 100644
index 568e15abff..0000000000
--- a/recipes/gcc/gcc-4.2.2/fix-ICE-in-arm_unwind_emit_set.diff
+++ /dev/null
@@ -1,18 +0,0 @@
---- trunk/gcc/config/arm/arm.c 2006/09/19 13:18:27 117055
-+++ trunk/gcc/config/arm/arm.c 2006/09/19 13:19:24 117056
-@@ -15415,6 +15415,15 @@
- /* Move from sp to reg. */
- asm_fprintf (asm_out_file, "\t.movsp %r\n", REGNO (e0));
- }
-+ else if (GET_CODE (e1) == PLUS
-+ && GET_CODE (XEXP (e1, 0)) == REG
-+ && REGNO (XEXP (e1, 0)) == SP_REGNUM
-+ && GET_CODE (XEXP (e1, 1)) == CONST_INT)
-+ {
-+ /* Set reg to offset from sp. */
-+ asm_fprintf (asm_out_file, "\t.movsp %r, #%d\n",
-+ REGNO (e0), (int)INTVAL(XEXP (e1, 1)));
-+ }
- else
- abort ();
- break;
diff --git a/recipes/gcc/gcc-4.2.3.inc b/recipes/gcc/gcc-4.2.3.inc
index b324f176dd..1627a96e38 100644
--- a/recipes/gcc/gcc-4.2.3.inc
+++ b/recipes/gcc/gcc-4.2.3.inc
@@ -3,7 +3,7 @@ LICENSE = "GPLv3"
DEPENDS = "mpfr gmp"
-INC_PR = "r10"
+INC_PR = "r11"
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://100-uclibc-conf.patch;patch=1 \
@@ -33,7 +33,6 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://arm-thumb-cache.patch;patch=1 \
file://zecke-xgcc-cpp.patch;patch=1 \
file://unbreak-armv4t.patch;patch=1 \
- file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
file://cache-amnesia.patch;patch=1 \
file://gfortran.patch;patch=1 \
file://gcc-4.0.2-e300c2c3.patch;patch=1 \
diff --git a/recipes/gcc/gcc-4.2.3/fix-ICE-in-arm_unwind_emit_set.diff b/recipes/gcc/gcc-4.2.3/fix-ICE-in-arm_unwind_emit_set.diff
deleted file mode 100644
index 568e15abff..0000000000
--- a/recipes/gcc/gcc-4.2.3/fix-ICE-in-arm_unwind_emit_set.diff
+++ /dev/null
@@ -1,18 +0,0 @@
---- trunk/gcc/config/arm/arm.c 2006/09/19 13:18:27 117055
-+++ trunk/gcc/config/arm/arm.c 2006/09/19 13:19:24 117056
-@@ -15415,6 +15415,15 @@
- /* Move from sp to reg. */
- asm_fprintf (asm_out_file, "\t.movsp %r\n", REGNO (e0));
- }
-+ else if (GET_CODE (e1) == PLUS
-+ && GET_CODE (XEXP (e1, 0)) == REG
-+ && REGNO (XEXP (e1, 0)) == SP_REGNUM
-+ && GET_CODE (XEXP (e1, 1)) == CONST_INT)
-+ {
-+ /* Set reg to offset from sp. */
-+ asm_fprintf (asm_out_file, "\t.movsp %r, #%d\n",
-+ REGNO (e0), (int)INTVAL(XEXP (e1, 1)));
-+ }
- else
- abort ();
- break;
diff --git a/recipes/gcc/gcc-4.2.4.inc b/recipes/gcc/gcc-4.2.4.inc
index 80d38f91cf..5afd08ba7c 100644
--- a/recipes/gcc/gcc-4.2.4.inc
+++ b/recipes/gcc/gcc-4.2.4.inc
@@ -3,7 +3,7 @@ LICENSE = "GPLv3"
DEPENDS = "mpfr gmp"
-INC_PR = "r6"
+INC_PR = "r7"
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://100-uclibc-conf.patch;patch=1 \
@@ -33,7 +33,6 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://arm-thumb-cache.patch;patch=1 \
file://zecke-xgcc-cpp.patch;patch=1 \
file://unbreak-armv4t.patch;patch=1 \
- file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
file://cache-amnesia.patch;patch=1 \
file://gfortran.patch;patch=1 \
file://gcc-4.0.2-e300c2c3.patch;patch=1 \
diff --git a/recipes/gcc/gcc-4.2.4/fix-ICE-in-arm_unwind_emit_set.diff b/recipes/gcc/gcc-4.2.4/fix-ICE-in-arm_unwind_emit_set.diff
deleted file mode 100644
index 568e15abff..0000000000
--- a/recipes/gcc/gcc-4.2.4/fix-ICE-in-arm_unwind_emit_set.diff
+++ /dev/null
@@ -1,18 +0,0 @@
---- trunk/gcc/config/arm/arm.c 2006/09/19 13:18:27 117055
-+++ trunk/gcc/config/arm/arm.c 2006/09/19 13:19:24 117056
-@@ -15415,6 +15415,15 @@
- /* Move from sp to reg. */
- asm_fprintf (asm_out_file, "\t.movsp %r\n", REGNO (e0));
- }
-+ else if (GET_CODE (e1) == PLUS
-+ && GET_CODE (XEXP (e1, 0)) == REG
-+ && REGNO (XEXP (e1, 0)) == SP_REGNUM
-+ && GET_CODE (XEXP (e1, 1)) == CONST_INT)
-+ {
-+ /* Set reg to offset from sp. */
-+ asm_fprintf (asm_out_file, "\t.movsp %r, #%d\n",
-+ REGNO (e0), (int)INTVAL(XEXP (e1, 1)));
-+ }
- else
- abort ();
- break;
diff --git a/recipes/gcc/gcc-4.3.1.inc b/recipes/gcc/gcc-4.3.1.inc
index f475eba417..0b05f0a88c 100644
--- a/recipes/gcc/gcc-4.3.1.inc
+++ b/recipes/gcc/gcc-4.3.1.inc
@@ -7,7 +7,7 @@ LICENSE = "GPLv3"
DEPENDS = "mpfr gmp"
-INC_PR = "r18"
+INC_PR = "r19"
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://fedora/gcc43-c++-builtin-redecl.patch;patch=1;pnum=0 \
@@ -50,7 +50,6 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://arm-softfloat.patch;patch=1 \
file://arm-thumb.patch;patch=1 \
file://arm-thumb-cache.patch;patch=1 \
- file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
file://cache-amnesia.patch;patch=1 \
file://gfortran-4.3.x.patch;patch=1 \
file://gcc-4.0.2-e300c2c3.patch;patch=1 \
diff --git a/recipes/gcc/gcc-4.3.1/fix-ICE-in-arm_unwind_emit_set.diff b/recipes/gcc/gcc-4.3.1/fix-ICE-in-arm_unwind_emit_set.diff
deleted file mode 100644
index b8a147d3d9..0000000000
--- a/recipes/gcc/gcc-4.3.1/fix-ICE-in-arm_unwind_emit_set.diff
+++ /dev/null
@@ -1,28 +0,0 @@
---- /tmp/arm.c 2008-03-17 14:24:39.590464969 +0100
-+++ gcc-4.3.0/gcc/config/arm/arm.c 2008-03-17 14:12:21.614701982 +0100
-@@ -15959,6 +15959,9 @@
- int regno;
- int lo_mask = mask & 0xFF;
- int pushed_words = 0;
-+ rtx e0;
-+ rtx e1;
-+ unsigned reg;
-
- gcc_assert (mask);
-
-@@ -16025,6 +16028,15 @@
-
- return;
- }
-+ else if (GET_CODE (e1) == PLUS
-+ && GET_CODE (XEXP (e1, 0)) == REG
-+ && REGNO (XEXP (e1, 0)) == SP_REGNUM
-+ && GET_CODE (XEXP (e1, 1)) == CONST_INT)
-+ {
-+ /* Set reg to offset from sp. */
-+ asm_fprintf (asm_out_file, "\t.movsp %r, #%d\n",
-+ REGNO (e0), (int)INTVAL(XEXP (e1, 1)));
-+ }
- else
- {
- if (mask & 0xFF)
diff --git a/recipes/gcc/gcc-4.3.2.inc b/recipes/gcc/gcc-4.3.2.inc
index a6e6b7bd19..5483b8fd66 100644
--- a/recipes/gcc/gcc-4.3.2.inc
+++ b/recipes/gcc/gcc-4.3.2.inc
@@ -7,7 +7,7 @@ LICENSE = "GPLv3"
DEPENDS = "mpfr gmp"
-INC_PR = "r8"
+INC_PR = "r9"
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://fedora/gcc43-c++-builtin-redecl.patch;patch=1;pnum=0 \
@@ -47,7 +47,6 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://904-flatten-switch-stmt-00.patch;patch=1 \
file://arm-nolibfloat.patch;patch=1 \
file://arm-softfloat.patch;patch=1 \
- file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
file://cache-amnesia.patch;patch=1 \
file://gfortran-4.3.x.patch;patch=1 \
file://gcc-4.0.2-e300c2c3.patch;patch=1 \
diff --git a/recipes/gcc/gcc-4.3.2/fix-ICE-in-arm_unwind_emit_set.diff b/recipes/gcc/gcc-4.3.2/fix-ICE-in-arm_unwind_emit_set.diff
deleted file mode 100644
index b8a147d3d9..0000000000
--- a/recipes/gcc/gcc-4.3.2/fix-ICE-in-arm_unwind_emit_set.diff
+++ /dev/null
@@ -1,28 +0,0 @@
---- /tmp/arm.c 2008-03-17 14:24:39.590464969 +0100
-+++ gcc-4.3.0/gcc/config/arm/arm.c 2008-03-17 14:12:21.614701982 +0100
-@@ -15959,6 +15959,9 @@
- int regno;
- int lo_mask = mask & 0xFF;
- int pushed_words = 0;
-+ rtx e0;
-+ rtx e1;
-+ unsigned reg;
-
- gcc_assert (mask);
-
-@@ -16025,6 +16028,15 @@
-
- return;
- }
-+ else if (GET_CODE (e1) == PLUS
-+ && GET_CODE (XEXP (e1, 0)) == REG
-+ && REGNO (XEXP (e1, 0)) == SP_REGNUM
-+ && GET_CODE (XEXP (e1, 1)) == CONST_INT)
-+ {
-+ /* Set reg to offset from sp. */
-+ asm_fprintf (asm_out_file, "\t.movsp %r, #%d\n",
-+ REGNO (e0), (int)INTVAL(XEXP (e1, 1)));
-+ }
- else
- {
- if (mask & 0xFF)
diff --git a/recipes/gcc/gcc-4.3.3.inc b/recipes/gcc/gcc-4.3.3.inc
index 6ccb0f1895..5802492d58 100644
--- a/recipes/gcc/gcc-4.3.3.inc
+++ b/recipes/gcc/gcc-4.3.3.inc
@@ -7,7 +7,7 @@ LICENSE = "GPLv3"
DEPENDS = "mpfr gmp"
-INC_PR = "r4"
+INC_PR = "r5"
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://fedora/gcc43-c++-builtin-redecl.patch;patch=1;pnum=0 \
@@ -47,7 +47,6 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://904-flatten-switch-stmt-00.patch;patch=1 \
file://arm-nolibfloat.patch;patch=1 \
file://arm-softfloat.patch;patch=1 \
- file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
file://cache-amnesia.patch;patch=1 \
file://gfortran-4.3.x.patch;patch=1 \
file://gcc-4.0.2-e300c2c3.patch;patch=1 \
diff --git a/recipes/gcc/gcc-4.3.3/fix-ICE-in-arm_unwind_emit_set.diff b/recipes/gcc/gcc-4.3.3/fix-ICE-in-arm_unwind_emit_set.diff
deleted file mode 100644
index b8a147d3d9..0000000000
--- a/recipes/gcc/gcc-4.3.3/fix-ICE-in-arm_unwind_emit_set.diff
+++ /dev/null
@@ -1,28 +0,0 @@
---- /tmp/arm.c 2008-03-17 14:24:39.590464969 +0100
-+++ gcc-4.3.0/gcc/config/arm/arm.c 2008-03-17 14:12:21.614701982 +0100
-@@ -15959,6 +15959,9 @@
- int regno;
- int lo_mask = mask & 0xFF;
- int pushed_words = 0;
-+ rtx e0;
-+ rtx e1;
-+ unsigned reg;
-
- gcc_assert (mask);
-
-@@ -16025,6 +16028,15 @@
-
- return;
- }
-+ else if (GET_CODE (e1) == PLUS
-+ && GET_CODE (XEXP (e1, 0)) == REG
-+ && REGNO (XEXP (e1, 0)) == SP_REGNUM
-+ && GET_CODE (XEXP (e1, 1)) == CONST_INT)
-+ {
-+ /* Set reg to offset from sp. */
-+ asm_fprintf (asm_out_file, "\t.movsp %r, #%d\n",
-+ REGNO (e0), (int)INTVAL(XEXP (e1, 1)));
-+ }
- else
- {
- if (mask & 0xFF)
diff --git a/recipes/gcc/gcc-4.4.0/fix-ICE-in-arm_unwind_emit_set.diff b/recipes/gcc/gcc-4.4.0/fix-ICE-in-arm_unwind_emit_set.diff
deleted file mode 100644
index b8a147d3d9..0000000000
--- a/recipes/gcc/gcc-4.4.0/fix-ICE-in-arm_unwind_emit_set.diff
+++ /dev/null
@@ -1,28 +0,0 @@
---- /tmp/arm.c 2008-03-17 14:24:39.590464969 +0100
-+++ gcc-4.3.0/gcc/config/arm/arm.c 2008-03-17 14:12:21.614701982 +0100
-@@ -15959,6 +15959,9 @@
- int regno;
- int lo_mask = mask & 0xFF;
- int pushed_words = 0;
-+ rtx e0;
-+ rtx e1;
-+ unsigned reg;
-
- gcc_assert (mask);
-
-@@ -16025,6 +16028,15 @@
-
- return;
- }
-+ else if (GET_CODE (e1) == PLUS
-+ && GET_CODE (XEXP (e1, 0)) == REG
-+ && REGNO (XEXP (e1, 0)) == SP_REGNUM
-+ && GET_CODE (XEXP (e1, 1)) == CONST_INT)
-+ {
-+ /* Set reg to offset from sp. */
-+ asm_fprintf (asm_out_file, "\t.movsp %r, #%d\n",
-+ REGNO (e0), (int)INTVAL(XEXP (e1, 1)));
-+ }
- else
- {
- if (mask & 0xFF)
diff --git a/recipes/gcc/gcc-cross_4.2.1.bb b/recipes/gcc/gcc-cross_4.2.1.bb
index b2dba3956a..c080143517 100644
--- a/recipes/gcc/gcc-cross_4.2.1.bb
+++ b/recipes/gcc/gcc-cross_4.2.1.bb
@@ -1,4 +1,4 @@
-PR = "r20"
+PR = "r21"
require gcc-${PV}.inc
require gcc-cross4.inc
diff --git a/recipes/gcc/gcc_4.2.1.bb b/recipes/gcc/gcc_4.2.1.bb
index dd88ccdc27..711aa35a32 100644
--- a/recipes/gcc/gcc_4.2.1.bb
+++ b/recipes/gcc/gcc_4.2.1.bb
@@ -1,4 +1,4 @@
-PR = "r14"
+PR = "r15"
require gcc-${PV}.inc
require gcc-configure-target.inc