summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/cpan.bbclass15
-rw-r--r--recipes/perl/perl_5.10.1.bb2
-rw-r--r--recipes/perl/perl_5.8.8.bb2
3 files changed, 6 insertions, 13 deletions
diff --git a/classes/cpan.bbclass b/classes/cpan.bbclass
index dfc092601e..24e0c6e326 100644
--- a/classes/cpan.bbclass
+++ b/classes/cpan.bbclass
@@ -13,6 +13,8 @@ export PERL_INC = "${STAGING_LIBDIR}/perl/${@get_perl_version(d)}/CORE"
export PERL_LIB = "${STAGING_DATADIR}/perl/${@get_perl_version(d)}"
export PERL_ARCHLIB = "${STAGING_LIBDIR}/perl/${@get_perl_version(d)}"
+NATIVE_INSTALL_WORKS = "1"
+
cpan_do_configure () {
yes '' | perl Makefile.PL ${EXTRA_CPANFLAGS}
if [ "${BUILD_SYS}" != "${HOST_SYS}" ]; then
@@ -31,16 +33,7 @@ cpan_do_compile () {
}
cpan_do_install () {
- if [ ${@is_target(d)} = "yes" ]; then
- oe_runmake install_vendor
- fi
-}
-
-cpan_do_stage () {
- if [ ${@is_target(d)} = "no" ]; then
- oe_runmake install_vendor
- fi
+ oe_runmake DESTDIR="${D}" install_vendor
}
-
-EXPORT_FUNCTIONS do_configure do_compile do_install do_stage
+EXPORT_FUNCTIONS do_configure do_compile do_install
diff --git a/recipes/perl/perl_5.10.1.bb b/recipes/perl/perl_5.10.1.bb
index 86b08dc092..e7c90d8fc3 100644
--- a/recipes/perl/perl_5.10.1.bb
+++ b/recipes/perl/perl_5.10.1.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPL"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r7"
+PR = "r8"
# Not tested enough
DEFAULT_PREFERENCE = "-1"
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index c73fe4e5e9..29ae66c66b 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPL"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r34"
+PR = "r35"
# Major part of version
PVM = "5.8"