summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini8
-rw-r--r--recipes/blueman/blueman_1.21.bb31
2 files changed, 39 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 19889d6f3d..08166db163 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -3086,6 +3086,10 @@ sha256=b1e6d5912546d2a4b704ec65c2b9664aa3b4663e7d800e06803330335a2cb764
md5=f9058305c42038678d5023fcabba22a4
sha256=f4a92834a538dc9dbb93fde76933e849b24639faa1721b24549f209b8b590f71
+[http://download.tuxfamily.org/blueman/blueman-1.21.tar.gz]
+md5=26b70341b3d3da28da62c917c8b20377
+sha256=86200dab50b1595c9a9537586c07de90ccfa084b954bb74f3e8732cc000fe3af
+
[http://gpe.linuxtogo.org/download/source/blueprobe-0.13.tar.gz]
md5=33745b0e86603124654773c1361df33e
sha256=b4318d0e1ba7422ba4415838448718e037efe4d8236cf12132075ccf36d1803d
@@ -3586,6 +3590,10 @@ sha256=9427fa9b45f3c322bf4fe2463c99c972e6ae03df630899b38be4f29133708a0e
md5=aeb526108f13b91c02b115c8d86f9659
sha256=03fc9dbdc6f44afd2da55c0ab36646d2d063708cc35f3f4569b913b064f11d83
+[http://www.busybox.net/downloads/busybox-1.14.3.tar.gz]
+md5=dfb197b8de260ff284f7222ed23614fe
+sha256=b5a0c76d414cca97fb21622a5d09fa5a58f59890f5c9ce4f8b851c4e8b73a163
+
[http://www.busybox.net/downloads/busybox-1.2.0.tar.gz]
md5=6af69ebbbf8adc874ccb6d67dca95df5
sha256=df6e3b0079194251a2ff68d7be7b06025c79f4fe62f4a73158ee52ff4bc515a0
diff --git a/recipes/blueman/blueman_1.21.bb b/recipes/blueman/blueman_1.21.bb
new file mode 100644
index 0000000000..744c05302e
--- /dev/null
+++ b/recipes/blueman/blueman_1.21.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "GTK+ Bluetooth Manager, designed for common bluetooth tasks."
+HOMEPAGE = "http://blueman-project.org/"
+SECTION = "optional"
+
+DEPENDS = "gtk+ glib-2.0 bluez4 intltool python \
+ python-native python-pyrex \
+ startup-notification \
+"
+
+RDEPENDS = "python-dbus python-pygobject python \
+ dbus bluez4 python-pygtk obex-data-server \
+"
+
+PR = "r1"
+
+SRC_URI = "http://download.tuxfamily.org/blueman/blueman-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF += "--with-no-runtime-deps-check"
+
+do_configure_prepend() {
+ sed -i "s/py_prefix=.*$/py_prefix=\"${@"${STAGING_DIR_TARGET}".replace("/","\/")}\/usr\"/" ${S}/acinclude.m4
+ sed -i "s/py_exec_prefix=.*$/py_exec_prefix=\"${@"${STAGING_DIR_TARGET}".replace("/","\/")}\/usr\"/" ${S}/acinclude.m4
+}
+
+FILES_${PN}-dbg += "${libdir}/python2.6/site-packages/.debug"
+FILES_${PN} += "${libdir} ${datadir}"
+
+BLUEZ_LIBS = "-L${libdir} -lbluetooth"
+BLUEZ_CFLAGS = "-I${includedir}"