summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/machine/include/omap3.inc2
-rw-r--r--recipes/linux/linux-omap-psp-2.6.32/0001-BeagleBoard-Adjust-USER-button-pin-for-xM.patch28
-rw-r--r--recipes/linux/linux-omap-psp-2.6.32/beagleboard/configs/cpuidle12
-rw-r--r--recipes/linux/linux-omap-psp-2.6.32/beagleboard/defconfig3
-rw-r--r--recipes/linux/linux-omap-psp_2.6.32.bb1
5 files changed, 38 insertions, 8 deletions
diff --git a/conf/machine/include/omap3.inc b/conf/machine/include/omap3.inc
index 98cb4acd3a..270b34cc71 100644
--- a/conf/machine/include/omap3.inc
+++ b/conf/machine/include/omap3.inc
@@ -3,7 +3,7 @@ SOC_FAMILY = "omap3"
require conf/machine/include/tune-cortexa8.inc
PREFERRED_PROVIDER_virtual/kernel = "linux-omap"
# Increase this everytime you change something in the kernel
-MACHINE_KERNEL_PR = "r82"
+MACHINE_KERNEL_PR = "r83"
KERNEL_IMAGETYPE = "uImage"
diff --git a/recipes/linux/linux-omap-psp-2.6.32/0001-BeagleBoard-Adjust-USER-button-pin-for-xM.patch b/recipes/linux/linux-omap-psp-2.6.32/0001-BeagleBoard-Adjust-USER-button-pin-for-xM.patch
new file mode 100644
index 0000000000..af6c0249d6
--- /dev/null
+++ b/recipes/linux/linux-omap-psp-2.6.32/0001-BeagleBoard-Adjust-USER-button-pin-for-xM.patch
@@ -0,0 +1,28 @@
+From 6fc2495bb9f1fa166f7f4190ecd0b988034f54ea Mon Sep 17 00:00:00 2001
+From: Jason Kridner <jkridner@beagleboard.org>
+Date: Sat, 17 Jul 2010 14:28:22 -0500
+Subject: [PATCH] BeagleBoard: Adjust USER button pin for xM
+
+---
+ arch/arm/mach-omap2/board-omap3beagle.c | 5 +++++
+ 1 files changed, 5 insertions(+), 0 deletions(-)
+
+diff --git a/arch/arm/mach-omap2/board-omap3beagle.c b/arch/arm/mach-omap2/board-omap3beagle.c
+index 7c9e40a..f93616b 100644
+--- a/arch/arm/mach-omap2/board-omap3beagle.c
++++ b/arch/arm/mach-omap2/board-omap3beagle.c
+@@ -829,6 +829,11 @@ static void __init omap3_beagle_init(void)
+ {
+ omap3_mux_init(board_mux, OMAP_PACKAGE_CBB);
+ omap3_beagle_i2c_init();
++
++ if (cpu_is_omap3630()) {
++ gpio_buttons[0].gpio = 4;
++ }
++
+ platform_add_devices(omap3_beagle_devices,
+ ARRAY_SIZE(omap3_beagle_devices));
+ omap_serial_init();
+--
+1.6.6.1
+
diff --git a/recipes/linux/linux-omap-psp-2.6.32/beagleboard/configs/cpuidle b/recipes/linux/linux-omap-psp-2.6.32/beagleboard/configs/cpuidle
index 678585c870..88e4fbe36e 100644
--- a/recipes/linux/linux-omap-psp-2.6.32/beagleboard/configs/cpuidle
+++ b/recipes/linux/linux-omap-psp-2.6.32/beagleboard/configs/cpuidle
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.32
-# Sun Jul 18 00:26:08 2010
+# Wed Jul 21 20:44:42 2010
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -85,7 +85,7 @@ CONFIG_KALLSYMS=y
CONFIG_HOTPLUG=y
CONFIG_PRINTK=y
CONFIG_BUG=y
-# CONFIG_ELF_CORE is not set
+CONFIG_ELF_CORE=y
CONFIG_BASE_FULL=y
CONFIG_FUTEX=y
CONFIG_EPOLL=y
@@ -380,10 +380,10 @@ CONFIG_CPU_FREQ_TABLE=y
CONFIG_CPU_FREQ_DEBUG=y
CONFIG_CPU_FREQ_STAT=y
CONFIG_CPU_FREQ_STAT_DETAILS=y
-# CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE is not set
+CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_POWERSAVE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE is not set
-CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND=y
+# CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_CONSERVATIVE is not set
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
CONFIG_CPU_FREQ_GOV_POWERSAVE=y
@@ -409,6 +409,7 @@ CONFIG_NEON=y
# Userspace binary formats
#
CONFIG_BINFMT_ELF=y
+# CONFIG_CORE_DUMP_DEFAULT_ELF_HEADERS is not set
CONFIG_HAVE_AOUT=y
CONFIG_BINFMT_AOUT=m
CONFIG_BINFMT_MISC=y
@@ -1736,10 +1737,8 @@ CONFIG_VIDEO_WM8775=m
# CONFIG_VIDEO_KS0127 is not set
# CONFIG_VIDEO_OV7670 is not set
CONFIG_VIDEO_MT9V011=m
-CONFIG_VIDEO_MT9V113=m
# CONFIG_VIDEO_TCM825X is not set
CONFIG_VIDEO_MT9P012=m
-CONFIG_VIDEO_MT9T112=m
# CONFIG_VIDEO_DW9710 is not set
# CONFIG_VIDEO_OV3640 is not set
# CONFIG_VIDEO_IMX046 is not set
@@ -2511,7 +2510,6 @@ CONFIG_ECHO=m
CONFIG_OTUS=m
# CONFIG_COMEDI is not set
# CONFIG_ASUS_OLED is not set
-CONFIG_RTL8192SU=m
# CONFIG_INPUT_MIMIO is not set
# CONFIG_TRANZPORT is not set
diff --git a/recipes/linux/linux-omap-psp-2.6.32/beagleboard/defconfig b/recipes/linux/linux-omap-psp-2.6.32/beagleboard/defconfig
index 92237f2fda..eff98b4ac3 100644
--- a/recipes/linux/linux-omap-psp-2.6.32/beagleboard/defconfig
+++ b/recipes/linux/linux-omap-psp-2.6.32/beagleboard/defconfig
@@ -3048,3 +3048,6 @@ CONFIG_HAS_IOMEM=y
CONFIG_HAS_IOPORT=y
CONFIG_HAS_DMA=y
CONFIG_NLATTR=y
+CONFIG_ELF_CORE=y
+# CONFIG_CORE_DUMP_DEFAULT_ELF_HEADERS is not set
+
diff --git a/recipes/linux/linux-omap-psp_2.6.32.bb b/recipes/linux/linux-omap-psp_2.6.32.bb
index 0388baffda..c9a6d06cd5 100644
--- a/recipes/linux/linux-omap-psp_2.6.32.bb
+++ b/recipes/linux/linux-omap-psp_2.6.32.bb
@@ -128,6 +128,7 @@ SRC_URI = "git://arago-project.org/git/people/sriram/ti-psp-omap.git;protocol=gi
file://cam/0069-mt9t112-Fix-pll-p-dividers-abstraction.patch \
file://cam/0070-mt9t112-Adjust-50-60Hz-flickering-settings.patch \
file://cam/0071-mt9t112-Trigger-autofocus-at-the-end-of-context-swit.patch \
+ file://0001-BeagleBoard-Adjust-USER-button-pin-for-xM.patch \
file://defconfig"
SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \