aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/shr.conf8
-rw-r--r--recipes/images/shr-image.bb2
-rw-r--r--recipes/images/shr-image.inc8
-rw-r--r--recipes/tasks/task-shr-minimal.bb17
-rw-r--r--recipes/tasks/task-shr.bb13
5 files changed, 15 insertions, 33 deletions
diff --git a/conf/distro/shr.conf b/conf/distro/shr.conf
index 2bea23906a..66563625aa 100644
--- a/conf/distro/shr.conf
+++ b/conf/distro/shr.conf
@@ -195,11 +195,3 @@ DISTRO_EXTRA_RDEPENDS += "\
angstrom-libc-fixup-hack \
${DISTRO_EXTRA_APPS} \
"
-
-# Additional content II (can be masked with BAD_RECOMMENDATIONS)
-DISTRO_EXTRA_RRECOMMENDS += " \
- openssh-sftp-server \
-"
-
-# avahi-daemon \
-# avahi-autoipd \
diff --git a/recipes/images/shr-image.bb b/recipes/images/shr-image.bb
index e889f2dfb9..23f4f64e4c 100644
--- a/recipes/images/shr-image.bb
+++ b/recipes/images/shr-image.bb
@@ -7,12 +7,14 @@ RDEPENDS += "\
task-shr-apps \
task-shr-games \
task-shr-gtk \
+ task-shr-cli \
"
IMAGE_INSTALL += "\
task-shr-apps \
task-shr-games \
task-shr-gtk \
+ task-shr-cli \
"
# perform some SHR convenience tweaks to the rootfs
diff --git a/recipes/images/shr-image.inc b/recipes/images/shr-image.inc
index bbda84d93b..f06d86b429 100644
--- a/recipes/images/shr-image.inc
+++ b/recipes/images/shr-image.inc
@@ -3,7 +3,7 @@
#------------------------------------------------------
PV = "2.0"
-PR = "r10"
+PR = "r11"
DEPENDS += "task-shr-minimal"
@@ -130,7 +130,6 @@ shr_rootfs_gta02_postprocess() {
cd ${IMAGE_ROOTFS}/boot
ln -s uImage uImage-GTA02.bin
cd $curdir
- #sed -i 's/#SCORouting=PCM/SCORouting=PCM/' ${IMAGE_ROOTFS}/etc/bluetooth/audio.conf
}
shr_rootfs_gta01_postprocess() {
@@ -139,14 +138,9 @@ shr_rootfs_gta01_postprocess() {
cd ${IMAGE_ROOTFS}/boot
ln -s uImage uImage-GTA01.bin
cd $curdir
- #sed -i 's/#SCORouting=PCM/SCORouting=PCM/' ${IMAGE_ROOTFS}/etc/bluetooth/audio.conf
}
ROOTFS_POSTPROCESS_COMMAND += " shr_rootfs_postprocess"
ROOTFS_POSTPROCESS_COMMAND_append_om-gta02 = ";shr_rootfs_gta02_postprocess"
ROOTFS_POSTPROCESS_COMMAND_append_om-gta01 = ";shr_rootfs_gta01_postprocess"
-
-#do_testlab() {
-# :
-#}
diff --git a/recipes/tasks/task-shr-minimal.bb b/recipes/tasks/task-shr-minimal.bb
index 8538391df3..5b16a2a14b 100644
--- a/recipes/tasks/task-shr-minimal.bb
+++ b/recipes/tasks/task-shr-minimal.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "SHR Lite Image Feed"
-PR = "r20"
+PR = "r21"
PV = "2.0"
LICENSE = "GPL"
@@ -67,11 +67,8 @@ RDEPENDS_${PN}-base = "\
sysfsutils \
modutils-initscripts \
module-init-tools-depmod \
- rsync \
- screen \
fbset \
fbset-modes \
- openssh-sftp-server \
cron \
logrotate\
util-linux-ng-fdisk \
@@ -79,13 +76,8 @@ RDEPENDS_${PN}-base = "\
"
RDEPENDS_${PN}-cli = "\
- screen \
nano \
- iptables \
mtd-utils \
- s3c24xx-gpio \
- mickeydbus \
- mickeyterm \
"
RDEPENDS_${PN}-fso = "\
@@ -112,15 +104,9 @@ RDEPENDS_${PN}-audio_append_om-gta02 = "\
"
RDEPENDS_${PN}-x = "\
- glibc-utils \
- glibc-charmap-utf-8 \
e-wm-menu-shr \
shr-wizard \
shr-theme-gry \
- etk-theme-shr \
- ${@get_rdepends(bb, d)} \
- libx11-locale \
- libmokoui2 \
xcursor-transparent-theme \
xinput-calibrator \
"
@@ -145,7 +131,6 @@ RDEPENDS_${PN}-gtk = "\
openmoko-icon-theme-standard2 \
shr-theme-gtk-e17lookalike \
vala-terminal \
- tangogps \
pyphonelog \
matchbox-keyboard-im \
"
diff --git a/recipes/tasks/task-shr.bb b/recipes/tasks/task-shr.bb
index 25e1b170c3..1f072500d2 100644
--- a/recipes/tasks/task-shr.bb
+++ b/recipes/tasks/task-shr.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "SHR Fat Image Feed"
-PR = "r3"
+PR = "r4"
PV = "2.0"
LICENSE = "GPL"
@@ -9,6 +9,7 @@ PACKAGES = "\
${PN}-gtk \
${PN}-apps \
${PN}-games \
+ ${PN}-cli \
"
RDEPENDS_${PN}-gtk = "\
@@ -17,6 +18,7 @@ RDEPENDS_${PN}-gtk = "\
libpurple-protocol-msn \
libpurple-protocol-icq \
vagalume \
+ tangogps \
gpe-sketchbook \
"
@@ -27,9 +29,16 @@ RDEPENDS_${PN}-apps += "\
midori \
intone \
"
+RDEPENDS_${PN}-apps += "\
+ task-shr-minimal-cli \
+ screen \
+ rsync \
+ mickeydbus \
+ mickeyterm \
+ openssh-sftp-server \
+"
RDEPENDS_${PN}-games += "\
mokomaze \
numptyphysics \
"
-