aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/images/console-at91sam9-image.bb33
-rw-r--r--recipes/images/net-at91sam9-image.bb52
-rw-r--r--recipes/images/x11-at91sam9-image.bb63
-rw-r--r--recipes/images/x11-tslib-at91sam9-image.bb106
-rw-r--r--recipes/images/x11-xinput-at91sam9-image.bb110
5 files changed, 315 insertions, 49 deletions
diff --git a/recipes/images/console-at91sam9-image.bb b/recipes/images/console-at91sam9-image.bb
index 7aae0fb13e..aeb6ed5e6c 100644
--- a/recipes/images/console-at91sam9-image.bb
+++ b/recipes/images/console-at91sam9-image.bb
@@ -1,18 +1,23 @@
-#Angstrom bootstrap at91sam9 image
+#Angstrom basic console at91sam9 image
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
ANGSTROM_EXTRA_INSTALL += " \
- usbview \
- mplayer \
- thttpd \
- madplay \
- alsa-utils-aplay \
+ alsa-utils-alsamixer \
+ alsa-utils-alsactl \
alsa-utils-amixer \
- iperf \
+ alsa-utils-aplay \
+# bash-sh \
dosfstools \
+ iperf \
+ madplay \
mtd-utils \
+ mplayer \
# nbench-byte \
+# owl-wifi \
+# thttpd \
+ ttcp \
+# usbview \
"
DEPENDS = "task-base-extended \
@@ -30,5 +35,19 @@ IMAGE_LINGUAS = ""
#we dont need the kernel in the image
ROOTFS_POSTPROCESS_COMMAND += "rm -f ${IMAGE_ROOTFS}/boot/*Image*; "
+at91sam9_rootfs_postprocess() {
+ curdir=$PWD
+ cd ${IMAGE_ROOTFS}
+
+ # bash-sh: pkg_postinst_bash command shall be run again
+ # (overloaded by busybox shell)
+ # cd bin
+ # ln -sf bash sh
+
+ cd $curdir
+}
+
+ROOTFS_POSTPROCESS_COMMAND += "at91sam9_rootfs_postprocess; "
+
inherit image
diff --git a/recipes/images/net-at91sam9-image.bb b/recipes/images/net-at91sam9-image.bb
new file mode 100644
index 0000000000..856ae18579
--- /dev/null
+++ b/recipes/images/net-at91sam9-image.bb
@@ -0,0 +1,52 @@
+#Angstrom network centric at91sam9 image
+
+IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
+
+ANGSTROM_EXTRA_INSTALL += " \
+ madplay \
+ alsa-utils-aplay \
+ alsa-utils-amixer \
+ alsa-utils-alsamixer \
+ alsa-utils-alsactl \
+ iperf \
+ dosfstools \
+ mtd-utils \
+ bash-sh \
+ mplayer \
+ iproute2 \
+ iptables \
+ bridge-utils \
+ canutils \
+ "
+
+DEPENDS = "task-base-extended \
+ ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)} \
+ "
+
+IMAGE_INSTALL = "task-base-extended \
+ ${ANGSTROM_EXTRA_INSTALL} \
+ ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)} \
+ "
+
+export IMAGE_BASENAME = "net-at91sam9-image"
+IMAGE_LINGUAS = ""
+
+#we dont need the kernel in the image
+ROOTFS_POSTPROCESS_COMMAND += "rm -f ${IMAGE_ROOTFS}/boot/*Image*; "
+
+at91sam9_rootfs_postprocess() {
+ curdir=$PWD
+ cd ${IMAGE_ROOTFS}
+
+ # bash-sh: pkg_postinst_bash command shall be run again
+ # (overloaded by busybox shell)
+ cd bin
+ ln -sf bash sh
+
+ cd $curdir
+}
+
+ROOTFS_POSTPROCESS_COMMAND += "at91sam9_rootfs_postprocess; "
+
+inherit image
+
diff --git a/recipes/images/x11-at91sam9-image.bb b/recipes/images/x11-at91sam9-image.bb
index d0ca0b64b6..55e1976b9f 100644
--- a/recipes/images/x11-at91sam9-image.bb
+++ b/recipes/images/x11-at91sam9-image.bb
@@ -1,20 +1,13 @@
# Angstrom x11-gpe-image with additional apps included
XSERVER = "xserver-xorg \
xf86-input-evdev \
- xf86-input-mouse \
- xf86-video-fbdev \
- xf86-input-keyboard \
- xinput-calibrator \
- "
-# xf86-input-tslib \
-
+ xf86-input-tslib \
+ xf86-video-fbdev "
require x11-gpe-image.bb
export IMAGE_BASENAME = "x11-at91sam9-image"
-# SPLASH = "exquisite exquisite-themes exquisite-theme-angstrom"
-
DEPENDS = "task-base"
IMAGE_INSTALL += "\
@@ -38,57 +31,43 @@ IMAGE_INSTALL += "\
matchbox-panel-hacks \
usbview \
mplayer \
- thttpd \
madplay \
alsa-utils-aplay \
alsa-utils-amixer \
+ alsa-utils-alsamixer \
+ alsa-utils-alsactl \
iperf \
fbv \
dosfstools \
mtd-utils \
-# gpe-mini-browser2 \
+ bash-sh \
tslib-conf \
tslib-calibrate \
tslib-tests \
libstdc++ \
- nano \
-# nbench-byte \
pointercal \
- gstreamer \
- gst-plugins-base \
- gst-plugins-good \
- gst-plugins-bad \
- gst-plugins-ugly \
- gst-plugin-avi \
- gst-plugin-mpegstream \
- gst-plugin-qtdemux \
- gst-plugin-mpegvideoparse \
- gst-plugin-asf \
- gst-plugin-alsa \
- gst-plugin-ossaudio \
- gst-plugin-audioresample \
- gst-plugin-audioconvert \
- gst-plugin-ximagesink \
- gst-plugin-fbdevsink \
- gst-plugin-faad \
- gst-plugin-mad \
- gst-plugin-playbin \
- gst-plugin-decodebin \
- gst-plugin-typefindfunctions \
- gst-ffmpeg \
-# gst-plugin-on2-8170 \
-# on2-8170-libs \
- owl-wifi \
+# ${IMAGE_EXTRA_INSTALL} \
+# gpe-mini-browser \
+# nbench-byte \
"
-IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
-
# IMAGE_LINGUAS += " se no dk fi"
-#zap root password for release images
-ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
ROOTFS_POSTPROCESS_COMMAND += "set_image_autologin; "
ROOTFS_POSTPROCESS_COMMAND += "install_linguas; "
#we dont need the kernel in the image
ROOTFS_POSTPROCESS_COMMAND += "rm -f ${IMAGE_ROOTFS}/boot/*Image*; "
+at91sam9_rootfs_postprocess() {
+ curdir=$PWD
+ cd ${IMAGE_ROOTFS}
+
+ # bash-sh: pkg_postinst_bash command shall be run again
+ # (overloaded by busybox shell)
+ cd bin
+ ln -sf bash sh
+
+ cd $curdir
+}
+
+ROOTFS_POSTPROCESS_COMMAND += "at91sam9_rootfs_postprocess; "
diff --git a/recipes/images/x11-tslib-at91sam9-image.bb b/recipes/images/x11-tslib-at91sam9-image.bb
new file mode 100644
index 0000000000..a3c4b3692c
--- /dev/null
+++ b/recipes/images/x11-tslib-at91sam9-image.bb
@@ -0,0 +1,106 @@
+# Angstrom x11-gpe-image with additional apps included
+XSERVER = "xserver-xorg \
+ xf86-input-evdev \
+ xf86-input-tslib \
+ xf86-video-fbdev "
+
+require x11-gpe-image.bb
+
+# SPLASH = "exquisite exquisite-themes exquisite-theme-angstrom"
+
+export IMAGE_BASENAME = "x11-xorg-at91sam9-image"
+
+DEPENDS = "task-base"
+
+IMAGE_INSTALL += "\
+ alsa-utils-alsactl \
+ alsa-utils-alsamixer \
+ alsa-utils-amixer \
+ alsa-utils-aplay \
+ bash-sh \
+ dosfstools \
+ fbv \
+ gnome-mplayer \
+ gpe-calculator \
+ gpe-calendar \
+ gpe-clock \
+ gpe-contacts \
+ gpe-edit \
+ gpe-filemanager \
+ gpe-gallery \
+ gpe-go \
+ gpe-irc \
+# gpe-mini-browser2 \
+ gpe-mixer \
+ gpe-scap \
+ gpe-sketchbook \
+ gpe-terminal \
+ gpe-tetris \
+ gpe-watch \
+ gpe-windowlist \
+# gstreamer \
+# gst-plugins-base \
+# gst-plugins-good \
+# gst-plugins-bad \
+# gst-plugins-ugly \
+# gst-plugin-avi \
+# gst-plugin-mpegstream \
+# gst-plugin-qtdemux \
+# gst-plugin-mpegvideoparse \
+# gst-plugin-asf \
+# gst-plugin-alsa \
+# gst-plugin-ossaudio \
+# gst-plugin-audioresample \
+# gst-plugin-audioconvert \
+# gst-plugin-ximagesink \
+# gst-plugin-fbdevsink \
+# gst-plugin-faad \
+# gst-plugin-mad \
+# gst-plugin-playbin \
+# gst-plugin-decodebin \
+# gst-plugin-typefindfunctions \
+# gst-ffmpeg \
+ iperf \
+ libstdc++ \
+ madplay \
+ matchbox-panel-hacks \
+ mplayer \
+ mtd-utils \
+ nano \
+ owl-wifi \
+ pointercal \
+# thttpd \
+ tslib-conf \
+ tslib-calibrate \
+ tslib-tests \
+# nbench-byte \
+ usbview \
+ ${ANGSTROM_EXTRA_INSTALL} \
+# ${IMAGE_EXTRA_INSTALL} \
+ "
+
+IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
+
+# IMAGE_LINGUAS += " se no dk fi"
+
+#zap root password for release images
+ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
+ROOTFS_POSTPROCESS_COMMAND += "set_image_autologin; "
+ROOTFS_POSTPROCESS_COMMAND += "install_linguas; "
+
+#we dont need the kernel in the image
+ROOTFS_POSTPROCESS_COMMAND += "rm -f ${IMAGE_ROOTFS}/boot/*Image*; "
+
+at91sam9_rootfs_postprocess() {
+ curdir=$PWD
+ cd ${IMAGE_ROOTFS}
+
+ # bash-sh: pkg_postinst_bash command shall be run again
+ # (overloaded by busybox shell)
+ cd bin
+ ln -sf bash sh
+
+ cd $curdir
+}
+
+ROOTFS_POSTPROCESS_COMMAND += "at91sam9_rootfs_postprocess; "
diff --git a/recipes/images/x11-xinput-at91sam9-image.bb b/recipes/images/x11-xinput-at91sam9-image.bb
new file mode 100644
index 0000000000..c3b54976ac
--- /dev/null
+++ b/recipes/images/x11-xinput-at91sam9-image.bb
@@ -0,0 +1,110 @@
+# Angstrom x11-gpe-image with additional apps included
+XSERVER = " \
+ xserver-xorg \
+ xf86-input-evdev \
+ xf86-video-fbdev \
+ xf86-input-mouse \
+ xf86-input-keyboard \
+ xinput-calibrator \
+ "
+
+require x11-gpe-image.bb
+
+# SPLASH = "exquisite exquisite-themes exquisite-theme-angstrom"
+
+export IMAGE_BASENAME = "x11-xorg-at91sam9-image"
+
+DEPENDS = "task-base"
+
+IMAGE_INSTALL += "\
+ alsa-utils-alsactl \
+ alsa-utils-alsamixer \
+ alsa-utils-amixer \
+ alsa-utils-aplay \
+ bash-sh \
+ dosfstools \
+ fbv \
+ gnome-mplayer \
+ gpe-calculator \
+ gpe-calendar \
+ gpe-clock \
+ gpe-contacts \
+ gpe-edit \
+ gpe-filemanager \
+ gpe-gallery \
+ gpe-go \
+ gpe-irc \
+# gpe-mini-browser2 \
+ gpe-mixer \
+ gpe-scap \
+ gpe-sketchbook \
+ gpe-terminal \
+ gpe-tetris \
+ gpe-watch \
+ gpe-windowlist \
+# gstreamer \
+# gst-plugins-base \
+# gst-plugins-good \
+# gst-plugins-bad \
+# gst-plugins-ugly \
+# gst-plugin-avi \
+# gst-plugin-mpegstream \
+# gst-plugin-qtdemux \
+# gst-plugin-mpegvideoparse \
+# gst-plugin-asf \
+# gst-plugin-alsa \
+# gst-plugin-ossaudio \
+# gst-plugin-audioresample \
+# gst-plugin-audioconvert \
+# gst-plugin-ximagesink \
+# gst-plugin-fbdevsink \
+# gst-plugin-faad \
+# gst-plugin-mad \
+# gst-plugin-playbin \
+# gst-plugin-decodebin \
+# gst-plugin-typefindfunctions \
+# gst-ffmpeg \
+ iperf \
+ libstdc++ \
+ madplay \
+ matchbox-panel-hacks \
+ mplayer \
+ mtd-utils \
+ nano \
+ owl-wifi \
+ pointercal \
+# thttpd \
+ tslib-conf \
+ tslib-calibrate \
+ tslib-tests \
+# nbench-byte \
+ usbview \
+ ${ANGSTROM_EXTRA_INSTALL} \
+# ${IMAGE_EXTRA_INSTALL} \
+ "
+
+IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
+
+# IMAGE_LINGUAS += " se no dk fi"
+
+#zap root password for release images
+ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
+ROOTFS_POSTPROCESS_COMMAND += "set_image_autologin; "
+ROOTFS_POSTPROCESS_COMMAND += "install_linguas; "
+
+#we dont need the kernel in the image
+ROOTFS_POSTPROCESS_COMMAND += "rm -f ${IMAGE_ROOTFS}/boot/*Image*; "
+
+at91sam9_rootfs_postprocess() {
+ curdir=$PWD
+ cd ${IMAGE_ROOTFS}
+
+ # bash-sh: pkg_postinst_bash command shall be run again
+ # (overloaded by busybox shell)
+ cd bin
+ ln -sf bash sh
+
+ cd $curdir
+}
+
+ROOTFS_POSTPROCESS_COMMAND += "at91sam9_rootfs_postprocess; "