aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/UnixTTCP/UnixTTCP_1.12.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/UnixTTCP/UnixTTCP_1.12.bb b/recipes/UnixTTCP/UnixTTCP_1.12.bb
new file mode 100644
index 0000000000..cf4e076209
--- /dev/null
+++ b/recipes/UnixTTCP/UnixTTCP_1.12.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Test TCP connection."
+# Makes a connection on port 5001 and transfers fabricated
+# buffers or data copied from stdin.
+LICENSE = "Public Domain"
+
+PR = "r0"
+PN = "unixttcp"
+
+SRC_URI = "http://www.pcausa.com/Utilities/pcattcp/UnixTTCP.zip \
+ "
+S = "${WORKDIR}/UnixTTCP"
+
+do_compile () {
+ ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} -o ttcp ttcp.c
+}
+
+do_stage() {
+ install -d ~/bin
+ install -m 0755 ${S}/ttcp ~/bin
+}
+
+# Wrong Checksums for now.
+SRC_URI[md5sum] = "4061bf263cdd6bbccacedcca9b6370aa"
+SRC_URI[sha256sum] = "d209f58b6765c0eb0ee2e7cf27b9cd4bdaab861ae9adab9f9367700552423847"