aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/batctl/batctl.inc20
-rw-r--r--recipes/batctl/batctl_2011.3.0.bb6
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes/batctl/batctl.inc b/recipes/batctl/batctl.inc
new file mode 100644
index 0000000000..cc13b4c2df
--- /dev/null
+++ b/recipes/batctl/batctl.inc
@@ -0,0 +1,20 @@
+DESCRIPTION = "Control application for B.A.T.M.A.N. routing protocol kernel module for multi-hop ad-hoc mesh networks."
+HOMEPAGE = "http://www.open-mesh.net/"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPLv2+"
+
+INC_PR = "r0"
+
+RDEPENDS_${PN} = "kernel-module-batman-adv"
+
+SRC_URI = "http://downloads.open-mesh.net/batman/stable/sources/batctl/batctl-${PV}.tar.gz"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 batctl ${D}${bindir}
+}
diff --git a/recipes/batctl/batctl_2011.3.0.bb b/recipes/batctl/batctl_2011.3.0.bb
new file mode 100644
index 0000000000..97d8e174ba
--- /dev/null
+++ b/recipes/batctl/batctl_2011.3.0.bb
@@ -0,0 +1,6 @@
+require batctl.inc
+PR = "${INC_PR}.0"
+
+
+SRC_URI[md5sum] = "8eb197896049bb04a6beef56015a16b6"
+SRC_URI[sha256sum] = "94922fd167d2bca5193cc7465bfc212c2c3595da70e653506493dfc65e4410fb"