aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/sysstat/sysstat.inc22
-rw-r--r--recipes/sysstat/sysstat_8.1.5.bb16
-rw-r--r--recipes/sysstat/sysstat_8.1.6.bb24
-rw-r--r--recipes/sysstat/sysstat_9.0.6.bb2
5 files changed, 32 insertions, 36 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 1f4fdc1b9a..90f402c387 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -25838,6 +25838,10 @@ sha256=26c05ef7666881eb1d60291a4293e67d75dbf048ca8a30f6b9eb3dc86ad1b6b0
md5=d7b8f27b83ff080ff824177d65a7dae0
sha256=0a63da1c99b6a9b6a93b6fd0a9391c7d8216f658d2bea0ba81999e261c6b6649
+[http://pagesperso-orange.fr/sebastien.godard/sysstat-9.0.6.tar.gz]
+md5=c05ca01878a4069199d9af93cbe39c8e
+sha256=464a4e23ab3b7d6886a5b8aa108e05b1a7f42654e1c398a040c88c81f30168c9
+
[http://cyberelk.net/tim/data/system-config-printer/1.1/system-config-printer-1.1.7.tar.bz2]
md5=a77bde5adc5ee8822b0764ff786ccc09
sha256=fdd50cb114151c66b8180c0ce90ba0e99f77a69770ac21598a87be935eec2224
diff --git a/recipes/sysstat/sysstat.inc b/recipes/sysstat/sysstat.inc
new file mode 100644
index 0000000000..dcc6c85456
--- /dev/null
+++ b/recipes/sysstat/sysstat.inc
@@ -0,0 +1,22 @@
+DESCRIPTION = "The sysstat utilities are a collection of performance monitoring tools for Linux."
+HOMEPAGE = "http://pagesperso-orange.fr/sebastien.godard/"
+LICENSE = "GPL"
+SECTION = "console/utils"
+INC_PR = "r2"
+
+DEPENDS = "virtual/libintl"
+
+SRC_URI = "http://pagesperso-orange.fr/sebastien.godard/sysstat-${PV}.tar.gz"
+
+inherit autotools
+
+do_configure_prepend() {
+ sed -i s,'-g $(MAN_GROUP)','', Makefile.in
+}
+
+FILES_${PN} += "${libdir}/sa"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+LDFLAGS_append_linux-uclibc = " -lintl"
+LDFLAGS_append_linux-uclibceabi = " -lintl"
+LDFLAGS_append_linux-uclibcspe = " -lintl"
diff --git a/recipes/sysstat/sysstat_8.1.5.bb b/recipes/sysstat/sysstat_8.1.5.bb
index 0f394ed259..1aed038a54 100644
--- a/recipes/sysstat/sysstat_8.1.5.bb
+++ b/recipes/sysstat/sysstat_8.1.5.bb
@@ -1,15 +1,3 @@
-DESCRIPTION = "The sysstat utilities are a collection of performance monitoring tools for Linux."
-HOMEPAGE = "http://pagesperso-orange.fr/sebastien.godard/"
-LICENSE = "GPL"
-SECTION = "console/utils"
-
-SRC_URI = "http://pagesperso-orange.fr/sebastien.godard/sysstat-${PV}.tar.gz"
-
-inherit autotools
-
-do_configure_prepend() {
- sed -i s,'-g $(MAN_GROUP)','', Makefile.in
-}
-
-FILES_${PN} += "${libdir}/sa"
+require sysstat.inc
+PR = "${INC_PR}.0"
diff --git a/recipes/sysstat/sysstat_8.1.6.bb b/recipes/sysstat/sysstat_8.1.6.bb
index 42dd5e2d75..8dce9efedd 100644
--- a/recipes/sysstat/sysstat_8.1.6.bb
+++ b/recipes/sysstat/sysstat_8.1.6.bb
@@ -1,22 +1,2 @@
-DESCRIPTION = "The sysstat utilities are a collection of performance monitoring tools for Linux."
-HOMEPAGE = "http://pagesperso-orange.fr/sebastien.godard/"
-LICENSE = "GPL"
-SECTION = "console/utils"
-PR = "r1"
-
-DEPENDS = "virtual/libintl"
-
-SRC_URI = "http://pagesperso-orange.fr/sebastien.godard/sysstat-${PV}.tar.gz"
-
-inherit autotools
-
-do_configure_prepend() {
- sed -i s,'-g $(MAN_GROUP)','', Makefile.in
-}
-
-FILES_${PN} += "${libdir}/sa"
-
-TARGET_CC_ARCH += "${LDFLAGS}"
-LDFLAGS_append_linux-uclibc = " -lintl"
-LDFLAGS_append_linux-uclibceabi = " -lintl"
-LDFLAGS_append_linux-uclibcspe = " -lintl"
+require sysstat.inc
+PR = "${INC_PR}.0"
diff --git a/recipes/sysstat/sysstat_9.0.6.bb b/recipes/sysstat/sysstat_9.0.6.bb
new file mode 100644
index 0000000000..8dce9efedd
--- /dev/null
+++ b/recipes/sysstat/sysstat_9.0.6.bb
@@ -0,0 +1,2 @@
+require sysstat.inc
+PR = "${INC_PR}.0"