aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/perl/perl.inc2
-rw-r--r--recipes/perl/perl_5.10.1.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes/perl/perl.inc b/recipes/perl/perl.inc
index ddde0b8872..3d8b9bbcca 100644
--- a/recipes/perl/perl.inc
+++ b/recipes/perl/perl.inc
@@ -1,7 +1,7 @@
# helper functions for perl
def all_perl_packages(d):
depchains = (d.getVar("DEPCHAIN_POST", True) or "").split()
- blacklist = ["perl-modules", "perl-misc", "perl-pod", "perl-doc"]
+ blacklist = ["perl-modules", "perl-misc", "perl-pod", "perl-doc", "perl-module-cpanplus-internals-source-sqlite", "perl-module-cpanplus-internals-source-sqlite-tie"]
for pkg in d.getVar("PACKAGES", True).split():
if not pkg in blacklist and not any(pkg.endswith(post) for post in depchains):
yield pkg
diff --git a/recipes/perl/perl_5.10.1.bb b/recipes/perl/perl_5.10.1.bb
index 4e6bc331f5..33ddffef78 100644
--- a/recipes/perl/perl_5.10.1.bb
+++ b/recipes/perl/perl_5.10.1.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPLv1+"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r19"
+PR = "r20"
# 5.10.1 has Module::Build built-in
PROVIDES += "libmodule-build-perl"