aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/help2man/help2man_1.36.4.bb7
-rw-r--r--recipes/help2man/help2man_1.38.2.bb7
2 files changed, 12 insertions, 2 deletions
diff --git a/recipes/help2man/help2man_1.36.4.bb b/recipes/help2man/help2man_1.36.4.bb
index 34d9c00dcd..138ae4f019 100644
--- a/recipes/help2man/help2man_1.36.4.bb
+++ b/recipes/help2man/help2man_1.36.4.bb
@@ -11,7 +11,7 @@ SRC_URI = "${GNU_MIRROR}/help2man/${P}.tar.gz"
inherit autotools
-PR = "r1"
+PR = "r2"
EXTRA_OECONF += "PERL=/usr/bin/perl"
@@ -19,6 +19,11 @@ do_configure () {
oe_runconf
}
+do_install_append () {
+ # Make sure we use /usr/bin/env perl
+ sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man
+}
+
FILES_${PN} += "/usr/lib/hacklocaledir.so"
SRC_URI[md5sum] = "d31a0a38c2ec71faa06723f6b8bd3076"
diff --git a/recipes/help2man/help2man_1.38.2.bb b/recipes/help2man/help2man_1.38.2.bb
index fff2ee4689..72793362aa 100644
--- a/recipes/help2man/help2man_1.38.2.bb
+++ b/recipes/help2man/help2man_1.38.2.bb
@@ -4,7 +4,7 @@ LICENSE = "GPLv3"
DEPENDS = "gettext-native perl-native liblocale-gettext-perl-native"
DEPENDS_virtclass-native = ""
RDEPENDS_pn-help2man = "gettext perl liblocale-gettext-perl"
-PR = "r0"
+PR = "r1"
SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz"
SRC_URI[md5sum] = "426671c6fe79e5ef2233303367eab5a6"
@@ -20,3 +20,8 @@ BBCLASSEXTEND = "native"
do_configure() {
oe_runconf
}
+
+do_install_append () {
+ # Make sure we use /usr/bin/env perl
+ sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man
+}