aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/libsdl/libsdl-mixer_1.2.11.bb23
2 files changed, 27 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 8252329fd5..7ce7a86342 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -1050,6 +1050,10 @@ sha256=88fcb1dbf934af33163667a6677312065c7d0a7f01cd764e3374c4c19b386ec4
md5=a357558552436b0b5ea0333b3e2327df
sha256=75c4520cde3b1d10ae7846983bde66d114fea9479f6acef352850dae92a1100c
+[http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-1.2.11.tar.gz]
+md5=65ada3d997fe85109191a5fb083f248c
+sha256=86145ac39cac6d2c6169c226f937648dca5e89dcd828751763dd174fa9af9cf9
+
[http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-1.2.6.tar.gz]
md5=2b8beffad9179d80e598c22c80efb135
sha256=89f94840b1b42ddfe53a8aee415331516f1bbdd942b42d25e74906a332cdf22a
diff --git a/recipes/libsdl/libsdl-mixer_1.2.11.bb b/recipes/libsdl/libsdl-mixer_1.2.11.bb
new file mode 100644
index 0000000000..5ecd2944a2
--- /dev/null
+++ b/recipes/libsdl/libsdl-mixer_1.2.11.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Simple DirectMedia Layer mixer library."
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/libsdl libmikmod libvorbis"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz"
+S = "${WORKDIR}/SDL_mixer-${PV}"
+
+export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
+
+inherit autotools_stage
+
+EXTRA_OECONF = "--disable-music-mp3"
+# although we build smpeg... need to find out how
+# to deal with optional dependencies
+
+do_compile() {
+ # Override SDL_LIBS to include a linker rpath so the linker
+ # can find the correct libdl.so when it links playwave to
+ # libSDL_mixer.so.
+ oe_runmake SDL_LIBS="$(pkg-config sdl --libs) -Wl,-rpath-link,${STAGING_LIBDIR}"
+}