aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/phoneme/files/b160-newer-libc.patch11
-rw-r--r--recipes/phoneme/phoneme-advanced-foundation_0.0.b160.bb5
-rw-r--r--recipes/phoneme/phoneme-advanced.inc4
3 files changed, 16 insertions, 4 deletions
diff --git a/recipes/phoneme/files/b160-newer-libc.patch b/recipes/phoneme/files/b160-newer-libc.patch
new file mode 100644
index 0000000000..814de0d1c2
--- /dev/null
+++ b/recipes/phoneme/files/b160-newer-libc.patch
@@ -0,0 +1,11 @@
+diff -uNr cdc.orig/src/linux/native/java/lang/UNIXProcess_md.c cdc/src/linux/native/java/lang/UNIXProcess_md.c
+--- cdc.orig/src/linux/native/java/lang/UNIXProcess_md.c 2010-08-20 11:25:25.000000000 +0200
++++ cdc/src/linux/native/java/lang/UNIXProcess_md.c 2010-08-20 11:32:33.000000000 +0200
+@@ -38,6 +38,7 @@
+ #include <signal.h>
+ #include <string.h>
+ #include <errno.h>
++#include <sys/stat.h>
+
+ #ifdef JDK
+ /* path in the environment */
diff --git a/recipes/phoneme/phoneme-advanced-foundation_0.0.b160.bb b/recipes/phoneme/phoneme-advanced-foundation_0.0.b160.bb
index 34adeae570..5efce915cc 100644
--- a/recipes/phoneme/phoneme-advanced-foundation_0.0.b160.bb
+++ b/recipes/phoneme/phoneme-advanced-foundation_0.0.b160.bb
@@ -1,11 +1,12 @@
-PR = "r1"
+PR = "r2"
require phoneme-advanced.inc
BUILDREV = "b160"
SRCREV = "20424"
-SRC_URI += "file://${BUILDREV}-makefile-fix.patch;striplevel=0"
+SRC_URI += "file://${BUILDREV}-makefile-fix.patch;striplevel=0 \
+ file://${BUILDREV}-newer-libc.patch;striplevel=0"
FILES_${PN} += "\
${COMMON_DIR}/bin/cvm \
diff --git a/recipes/phoneme/phoneme-advanced.inc b/recipes/phoneme/phoneme-advanced.inc
index be3ff92790..b055875129 100644
--- a/recipes/phoneme/phoneme-advanced.inc
+++ b/recipes/phoneme/phoneme-advanced.inc
@@ -85,14 +85,14 @@ do_configure() {
pmo HOST_RANLIB "${BUILD_RANLIB}"
pmo "# C/C++ toolchain binaries"
- pmo TARGET_CC "${CC}"
+ pmo TARGET_CC "${CC} "
pmo TARGET_CC_PATH "${CC}"
pmo CCFLAGS "${CFLAGS}"
pmo TARGET_CCC "${CXX}"
pmo TARGET_PATH "${CXX}"
pmo CCCFLAGS "${CXXFLAGS}"
pmo TARGET_AR "${AR}"
- pmo TARGET_LD "${CC}"
+ pmo TARGET_LD "${CC} ${LDFLAGS}"
pmo TARGET_RANLIB "${RANLIB}"
pmo USE_GCC2 false