aboutsummaryrefslogtreecommitdiffstats
path: root/busybox
diff options
context:
space:
mode:
Diffstat (limited to 'busybox')
-rw-r--r--busybox/busybox_1.00.bb0
-rw-r--r--busybox/busybox_1.00.oe75
-rw-r--r--busybox/slingbox_1.00.bb0
-rw-r--r--busybox/slingbox_1.00.oe45
-rw-r--r--busybox/switchbox_1.00.bb0
-rw-r--r--busybox/switchbox_1.00.oe50
6 files changed, 0 insertions, 170 deletions
diff --git a/busybox/busybox_1.00.bb b/busybox/busybox_1.00.bb
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/busybox/busybox_1.00.bb
diff --git a/busybox/busybox_1.00.oe b/busybox/busybox_1.00.oe
deleted file mode 100644
index 940c6e1d6e..0000000000
--- a/busybox/busybox_1.00.oe
+++ /dev/null
@@ -1,75 +0,0 @@
-DESCRIPTION = "BusyBox version ${PV}. \
-BusyBox combines tiny versions of many common UNIX utilities into a single \
-small executable. It provides minimalist replacements for most of the \
-utilities you usually find in GNU fileutils, shellutils, etc. The utilities \
-in BusyBox generally have fewer options than their full-featured GNU \
-cousins; however, the options that are included provide the expected \
-functionality and behave very much like their GNU counterparts. BusyBox \
-provides a fairly complete POSIX environment for any small or embedded \
-system."
-HOMEPAGE = "http://www.busybox.net"
-LICENSE = "GPL"
-SECTION = "base"
-PRIORITY = "required"
-PR = "r9"
-
-SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
- file://add-getkey-applet.patch;patch=1 \
- file://udhcpscript.patch;patch=1 \
- file://dhcpretrytime.patch;patch=1 \
- file://hdparm_M.patch;patch=1 \
- file://udhcppidfile.patch;patch=1 \
- file://udhcppidfile-breakage.patch;patch=1 \
- file://iproute-flush-cache.patch;patch=1;pnum=0 \
- file://defconfig \
- file://busybox-cron \
- file://busybox-httpd \
- file://busybox-udhcpd \
- file://syslog \
- file://hwclock.sh \
- file://default.script"
-
-S = "${WORKDIR}/busybox-${PV}"
-
-export EXTRA_CFLAGS = "${CFLAGS}"
-EXTRA_OEMAKE_append = " CROSS=${HOST_PREFIX}"
-FILES_${PN} += " ${datadir}/udhcpc"
-
-inherit cml1 update-rc.d
-
-INITSCRIPT_NAME = "syslog"
-INITSCRIPT_PARAMS = "defaults"
-
-do_configure () {
- install -m 0644 ${WORKDIR}/defconfig ${S}/.config
- cml1_do_configure
-}
-
-do_compile () {
- unset CFLAGS
- base_do_compile
-}
-
-do_install () {
- install -d ${D}/etc/init.d
- oe_runmake 'PREFIX=${D}' install
- install -m 0755 ${WORKDIR}/syslog ${D}/etc/init.d/
- if grep "CONFIG_CROND=y" ${WORKDIR}/defconfig; then
- install -m 0755 ${WORKDIR}/busybox-cron ${D}/etc/init.d/
- fi
- if grep "CONFIG_HTTPD=y" ${WORKDIR}/defconfig; then
- install -m 0755 ${WORKDIR}/busybox-httpd ${D}/etc/init.d/
- fi
- if grep "CONFIG_UDHCPD=y" ${WORKDIR}/defconfig; then
- install -m 0755 ${WORKDIR}/busybox-udhcpd ${D}/etc/init.d/
- fi
- if grep "CONFIG_HWCLOCK=y" ${WORKDIR}/defconfig; then
- install -m 0755 ${WORKDIR}/hwclock.sh ${D}/etc/init.d/hwclock.sh
- fi
- if grep "CONFIG_UDHCPC=y" ${WORKDIR}/defconfig; then
- install -d ${D}/etc/udhcpc.d
- install -d ${D}${datadir}/udhcpc
- install -m 0755 ${S}/examples/udhcp/simple.script ${D}/etc/udhcpc.d/50default
- install -m 0755 ${WORKDIR}/default.script ${D}${datadir}/udhcpc/default.script
- fi
-}
diff --git a/busybox/slingbox_1.00.bb b/busybox/slingbox_1.00.bb
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/busybox/slingbox_1.00.bb
diff --git a/busybox/slingbox_1.00.oe b/busybox/slingbox_1.00.oe
deleted file mode 100644
index 20f85813c1..0000000000
--- a/busybox/slingbox_1.00.oe
+++ /dev/null
@@ -1,45 +0,0 @@
-DESCRIPTION = "SlingBox version ${PV}. \
-SlingBox is a minimal version of BusyBox with just enough functionality \
-to enable ipkg to run on an Unslung NSLU2 device."
-HOMEPAGE = "http://www.busybox.net"
-LICENSE = "GPL"
-SECTION = "base"
-PRIORITY = "required"
-PR = "r1"
-
-SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
- file://defconfig \
- file://slingbox.patch;patch=1"
-
-S = "${WORKDIR}/busybox-${PV}"
-
-python () {
- # Don't build slingbox unless we're targeting an nslu2
- if oe.data.getVar("MACHINE", d, 1) != "nslu2":
- raise oe.parse.SkipPackage("switchbox only builds for the Linksys NSLU2")
-}
-
-export EXTRA_CFLAGS = "${CFLAGS}"
-EXTRA_OEMAKE_append = " CROSS=${HOST_PREFIX}"
-
-PACKAGES = "${PN}"
-FILES_${PN} = "/bin /sbin"
-FILES_${PN}-doc = ""
-FILES_${PN}-dev = ""
-FILES_${PN}-locale = ""
-
-inherit cml1
-
-do_configure () {
- install -m 0644 ${WORKDIR}/defconfig ${S}/.config
- cml1_do_configure
-}
-
-do_compile () {
- unset CFLAGS
- base_do_compile
-}
-
-do_install () {
- oe_runmake 'PREFIX=${D}' install
-}
diff --git a/busybox/switchbox_1.00.bb b/busybox/switchbox_1.00.bb
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/busybox/switchbox_1.00.bb
diff --git a/busybox/switchbox_1.00.oe b/busybox/switchbox_1.00.oe
deleted file mode 100644
index e2d9385d44..0000000000
--- a/busybox/switchbox_1.00.oe
+++ /dev/null
@@ -1,50 +0,0 @@
-DESCRIPTION = "SwitchBox version ${PV}. \
-SwitchBox is a minimal version of BusyBox with just enough functionality \
-to switch between different root filesystem options on an Unslung NSLU2 device."
-HOMEPAGE = "http://www.busybox.net"
-LICENSE = "GPL"
-SECTION = "base"
-PRIORITY = "required"
-PR = "r2"
-
-SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
- file://defconfig \
- file://linuxrc \
- file://switchbox.patch;patch=1"
-
-S = "${WORKDIR}/busybox-${PV}"
-
-python () {
- # Don't build switchbox unless we're targeting an nslu2
- if oe.data.getVar("MACHINE", d, 1) != "nslu2":
- raise oe.parse.SkipPackage("switchbox only builds for the Linksys NSLU2")
-}
-
-LDFLAGS =+ "-static"
-
-export EXTRA_CFLAGS = "${CFLAGS}"
-EXTRA_OEMAKE_append = " CROSS=${HOST_PREFIX}"
-
-PACKAGES = "${PN}"
-FILES_${PN} = "/"
-FILES_${PN}-doc = ""
-FILES_${PN}-dev = ""
-FILES_${PN}-locale = ""
-
-inherit cml1
-
-do_configure () {
- install -m 0644 ${WORKDIR}/defconfig ${S}/.config
- cml1_do_configure
-}
-
-do_compile () {
- unset CFLAGS
- base_do_compile
-}
-
-do_install () {
- oe_runmake 'PREFIX=${D}' install
- install -m 0755 ${WORKDIR}/linuxrc ${D}/
- mkdir -p ${D}/proc ${D}/mnt/tmpmnt
-}