aboutsummaryrefslogtreecommitdiffstats
path: root/conf/distro/nylon.conf
diff options
context:
space:
mode:
Diffstat (limited to 'conf/distro/nylon.conf')
-rw-r--r--conf/distro/nylon.conf142
1 files changed, 84 insertions, 58 deletions
diff --git a/conf/distro/nylon.conf b/conf/distro/nylon.conf
index 99cab2bcbb..3670f725de 100644
--- a/conf/distro/nylon.conf
+++ b/conf/distro/nylon.conf
@@ -1,73 +1,40 @@
-#############################################################################
#@TYPE: Distribution
#@NAME: Nylon Linux
#@DESCRIPTION: Distribution configuration for Nylon Mesh Linux distribution
-#############################################################################
-require conf/distro/angstrom-2008.1.conf
+# this distribution is mainly for wireless networking devices and includes
+# packages necessary for wireless LAN access point, routing, encryption and
+# especially mesh routing applications
+#
+# it is primarily aimed at the 4G Systems MeshCube (mtx-1) and other
+# mipsel based platforms
+#
+# Bruno Randolf <bruno.randolf@4g-systems.biz>
-#############################################################################
-# NAME and VERSION
-#############################################################################
-DISTRO_NAME = "nylon"
-DISTRO = ${DISTRO_NAME}
-DISTRO_VERSION = "${NYLON_VERSION}"
-BUILDNAME := "${NYLON_VERSION}"
-#DISTRO_TYPE = "release"
-DISTRO_TYPE = "debug"
-TARGET_FPU = "soft"
-SRCDATE := "20050527"
-TARGET_VENDOR = "-nylon"
-
-# Ensure some form of release config, so error out if someone thinks he knows better
-DISTRO_CHECK := "${@bb.data.getVar("DISTRO_VERSION",d,1) or bb.fatal('Remove this line or set a dummy DISTRO_VERSION")
-
-#############################################################################
-# PACKAGING
-#############################################################################
-# Chose the packaging system
-INHERIT += "nylon-mirrors"
-IMAGE_FSTYPES ?= "tar.gz jffs2"
-
-#############################################################################
-# IMAGES
-#############################################################################
-# Name the generated images in a sane way
-IMAGE_NAME = "${IMAGE_BASENAME}-${MACHINE}_${BUILDNAME}"
-KERNEL_IMAGE_NAME = "kernel-${KERNEL_VERSION}-${MACHINE}_${BUILDNAME}"
+TARGET_OS = "linux"
-#############################################################################
-# KERNEL
-#############################################################################
-KERNEL = "kernel24"
-MACHINE_KERNEL_VERSION = "2.4"
+INHERIT += "package_ipk debian nylon-mirrors"
+INHERIT += "linux-kernel-base"
-#############################################################################
-# TOOLCHAIN
-#############################################################################
-fixedCxxflags = "${@bb.data.getVar('CXXFLAGS', d, 1).replace('-fvisibility-inlines-hidden','')}"
-CXXFLAGS := ${fixedCxxflags}
+LIBC = "glibc"
+require conf/distro/include/${LIBC}.inc
+PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc-initial:gcc-cross-initial"
+PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc-intermediate:gcc-cross-intermediate"
+PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc:gcc-cross"
+PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}g++:gcc-cross"
+PREFERRED_PROVIDERS += " virtual/libx11:diet-x11"
+PREFERRED_PROVIDERS += " python:python-curses"
+PREFERRED_PROVIDER_classpath = "classpath-minimal"
-# we're not supporting pcmcia right now
-DISTRO_FEATURES = "nfs smbfs wifi pcmcia ppp ext2 vfat usbhost pci"
+TARGET_FPU = "soft"
-# FIXME: cannot build linux-libc-headers unless this is set.
-IPKGBUILDCMD = "stage-manager-ipkg-build -o 0 -g 0"
+SRCDATE := "20050527"
-#############################################################################
-# PREFERRED VERSIONS
-#############################################################################
-PREFERRED_VERSION_busybox = "1.7.2"
PREFERRED_VERSION_glibc = "2.3.3"
-PREFERRED_VERSION_glibc-initial = "2.3.2"
PREFERRED_VERSION_shorewall = "2.0.9-monolithic"
PREFERRED_VERSION_ppp-dsl = "0.1-monolithic"
-PREFERRED_VERSION_mtd-utils = "1.0.0+git"
+PREFERRED_VERSION_mtd-utils = "0.0.0+cvs20060223"
PREFERRED_VERSION_kismet = "2005-01-R1"
-PREFERRED_VERSION_automake-native = "1.10"
-PREFERRED_VERSION_pkgconfig-native = "0.23"
-PREFERRED_VERSION_netperf = "2.3"
-PREFERRED_PROVIDER_hotplug = "linux-hotplug"
PREFERRED_VERSION_gcc-cross-initial = "3.3.4"
PREFERRED_VERSION_gcc-cross-intermediate = "3.3.4"
@@ -78,8 +45,67 @@ PREFERRED_VERSION_binutils-cross = "2.14.90.0.7"
PREFERRED_VERSION_binutils-cross-sdk = "2.14.90.0.7"
PREFERRED_VERSION_binutils = "2.16"
PREFERRED_VERSION_linux-libc-headers = "2.6.18"
+
PREFERRED_VERSION_prism54-firmware = "1.0.3.0"
-#PREFERRED_VERSION_udev = "089"
-PREFERRED_VERSION_udev = "100"
+
+KERNEL_VERSION_mtx-1 = "2.4.27"
+KERNEL_VERSION_mtx-2 = "2.4.27"
+
+#PREFERRED_VERSION_glibc_mtx-3 = "2.3.5+cvs20050627"
+PREFERRED_VERSION_gcc-cross-initial_mtx-3 = "3.4.4"
+PREFERRED_VERSION_gcc-cross-intermediate_mtx-3 = "3.4.4"
+PREFERRED_VERSION_gcc-cross_mtx-3 = "3.4.4"
+PREFERRED_VERSION_gcc-cross-sdk_mtx-3 = "3.4.4"
+PREFERRED_VERSION_gcc_mtx-3 = "3.4.4"
+### did not compile with:
+#PREFERRED_VERSION_binutils-cross_mtx-3 = "2.16.91.0.7"
+#PREFERRED_VERSION_binutils-cross-sdk_mtx-3 = "2.16.91.0.7"
+### falling back to:
+PREFERRED_VERSION_binutils-cross_mtx-3 = "2.15.94.0.1"
+PREFERRED_VERSION_binutils-cross-sdk_mtx-3 = "2.15.94.0.1"
+PREFERRED_VERSION_binutils_mtx-3 = "2.16"
PREFERRED_VERSION_madwifi-modules = "0.9.3"
PREFERRED_VERSION_madwifi-tools = "0.9.3"
+
+PREFERRED_VERSION_udev = "089"
+
+KERNEL_VERSION_mtx-3 = "2.6.15.4"
+PREFERRED_PROVIDER_virtual/kernel_mtx-3a = "linux-mtx-3a"
+
+
+#PREFERRED_VERSION_glibc_mtx-3a = "2.3.5+cvs20050627"
+PREFERRED_VERSION_gcc-cross-initial_mtx-3a = "3.4.4"
+PREFERRED_VERSION_gcc-cross-intermediate_mtx-3a = "3.4.4"
+PREFERRED_VERSION_gcc-cross_mtx-3a = "3.4.4"
+PREFERRED_VERSION_gcc-cross-sdk_mtx-3a = "3.4.4"
+PREFERRED_VERSION_gcc_mtx-3a = "3.4.4"
+### did not compile with:
+#PREFERRED_VERSION_binutils-cross_mtx-3a = "2.16.91.0.7"
+#PREFERRED_VERSION_binutils-cross-sdk_mtx-3a = "2.16.91.0.7"
+### falling back to:
+PREFERRED_VERSION_binutils-cross_mtx-3a = "2.15.94.0.1"
+PREFERRED_VERSION_binutils-cross-sdk_mtx-3a = "2.15.94.0.1"
+PREFERRED_VERSION_binutils_mtx-3a = "2.16"
+
+PREFERRED_VERSION_udev = "100"
+
+KERNEL_VERSION_mtx-3a = "2.6.16.6"
+
+
+# usually overrrided from local.conf
+NYLON_RELEASE = "unstable"
+
+# use meshcub.org mirrors for CVS sources
+CVS_TARBALL_STASH = "http://meshcube.org/nylon/${NYLON_RELEASE}/sources/"
+
+export FEED_URIS = " \
+ nylon##http://meshcube.org/nylon/${NYLON_RELEASE}/feed \
+ nylon-bin##http://meshcube.org/nylon/${NYLON_RELEASE}/binary-feed"
+
+# image names
+DISTRO_VERSION = "${NYLON_VERSION}"
+BUILDNAME := "${NYLON_VERSION}"
+#this does not work: ${@base_read_file('${STAGING_DIR}/${HOST_SYS}/kernel/kernel-abiversion')}
+IMAGE_NAME = "${IMAGE_BASENAME}-${MACHINE}_${BUILDNAME}"
+KERNEL_IMAGE_NAME = "kernel-${KERNEL_VERSION}-${MACHINE}_${BUILDNAME}"
+