aboutsummaryrefslogtreecommitdiffstats
path: root/contrib
diff options
context:
space:
mode:
Diffstat (limited to 'contrib')
-rw-r--r--contrib/angstrom/extract-feedarch.sh32
-rwxr-xr-xcontrib/angstrom/omap3-mkcard.sh4
-rw-r--r--contrib/angstrom/personal-feed.sh2
-rwxr-xr-xcontrib/angstrom/sort.sh67
-rwxr-xr-xcontrib/oe-stylize.py3
-rwxr-xr-xcontrib/python/generate-manifest-2.6.py23
-rwxr-xr-xcontrib/qemu/run-qemu.sh258
-rwxr-xr-xcontrib/source-checker/bump.preferred-xorg-versions-live.sh6
8 files changed, 262 insertions, 133 deletions
diff --git a/contrib/angstrom/extract-feedarch.sh b/contrib/angstrom/extract-feedarch.sh
new file mode 100644
index 0000000000..644be25386
--- /dev/null
+++ b/contrib/angstrom/extract-feedarch.sh
@@ -0,0 +1,32 @@
+#!/bin/sh
+
+if [ ! -d archs ] ; then
+ mkdir archs
+fi
+
+for feedconfig in $(find . -name "angstrom-feed-configs_*") ; do
+ rm -rf feedtemp ; mkdir feedtemp
+ dpkg-deb -X $feedconfig feedtemp >& /dev/null
+ echo $(tail -n1 feedtemp/etc/opkg/arch.conf | awk '{print $2}') >> archs/$(tail -n2 feedtemp/etc/opkg/arch.conf | head -n1 | awk '{print $2}')
+ rm -rf feedtemp
+done
+
+# Fixups
+cat archs/iwmmxt >> archs/armv5te || true
+cat archs/omap3517-evm >> archs/armv7a || true
+rm -f archs/arm archs/iwmmxt archs/omap3517-evm
+touch archs/iwmmxt archs/sparc
+touch archs/sparc
+
+# "mipsel")
+# machines="";;
+
+cat /tmp/sort-head.sh
+for arch in archs/* ; do
+ echo -e "\t\"$(basename $arch)\")"
+ cat $arch | sort | awk '{print $1}' | uniq | xargs echo -ne '\t\t\tmachines="' | sed -e 's:machines=" :machines=":g'
+ echo '" ;;'
+ cat $arch | sort | awk '{print $1}' | uniq > /tmp/feedsort && mv /tmp/feedsort $arch
+done
+cat /tmp/sort-footer.sh
+
diff --git a/contrib/angstrom/omap3-mkcard.sh b/contrib/angstrom/omap3-mkcard.sh
index 1cf681762d..72dce06cab 100755
--- a/contrib/angstrom/omap3-mkcard.sh
+++ b/contrib/angstrom/omap3-mkcard.sh
@@ -46,11 +46,11 @@ fi
if [ -b ${DRIVE}2 ]; then
umount ${DRIVE}2
- mke2fs -j -L "rootfs" ${DRIVE}2
+ mke2fs -j -L "Angstrom" ${DRIVE}2
else
if [ -b ${DRIVE}p2 ]; then
umount ${DRIVE}p2
- mke2fs -j -L "rootfs" ${DRIVE}p2
+ mke2fs -j -L "Angstrom" ${DRIVE}p2
else
echo "Cant find rootfs partition in /dev"
fi
diff --git a/contrib/angstrom/personal-feed.sh b/contrib/angstrom/personal-feed.sh
index 948769e5d7..1951c27ab4 100644
--- a/contrib/angstrom/personal-feed.sh
+++ b/contrib/angstrom/personal-feed.sh
@@ -45,7 +45,7 @@ echo "Starting rsync..."
rsync -vz --partial --copy-links --progress --files-from=files-trans upload-queue/ personal-feed/
echo "Generating index for your personal feed..."
-( cd personal-feed ; PATH=$PATH:$(find ../../../staging/$(uname -m)* -name "ipkg-make-index" | sed s:/ipkg-make-index::g) ipkg-make-index -p Packages -m . >& /dev/null )
+( cd personal-feed ; PATH=$PATH:$(find ../../../sysroots/$(uname -m)* -name "ipkg-make-index" | sed s:/ipkg-make-index::g) ipkg-make-index -p Packages -m . >& /dev/null )
# Clean up temporary files
diff --git a/contrib/angstrom/sort.sh b/contrib/angstrom/sort.sh
index 5c8332a728..eed899db3b 100755
--- a/contrib/angstrom/sort.sh
+++ b/contrib/angstrom/sort.sh
@@ -3,6 +3,8 @@
# Angstrom feed sorting script
# This must be run in unsorted/ directory
+ipkg_tools_path="/home/angstrom/bin"
+
if [ $(basename $PWD) != "unsorted" ] ; then
echo "Not in feed dir! Exiting"
exit 1
@@ -43,47 +45,65 @@ do_sort() {
archdir=$arch
case "$arch" in
+ "486sx")
+ machines="vortex86sx" ;;
"armv4")
- machines="h3600 h3800 collie simpad htcwallaby" ;;
+ machines="collie h3600 h3800 htcwallaby jornada56x jornada7xx shark simpad" ;;
"armv4t")
- machines="micro2440 mini2440 ep93xx h6300 om-gta01 om-gta02 fic-gta01 fic-gta02" ;;
+ machines="acern30 amsdelta at2440evb cs-e9302 ep93xx eteng500 eten-m800 fic-gta01 fic-gta02 gesbc-9302 h1940 h6300 kb9202 ks8695 m8050 micro2440 mini2440 om-gta01 om-gta02 rx1950 rx3000 sarge-at91 simone smdk2440 smdk2443 topas910 ts72xx" ;;
"armv5te")
- machines="imote2 hawkboard da850-omapl138-evm da830-omapl137-evm htcalpine dm6446-evm dm6467-evm dm6467t-evm dm355-evm dm365-evm dm357-evm topas910 sheevaplug openrd-client openrd-base dm355-leopard n2100 dns323 mv2120 kuropro lspro tsx09 ts409 davinci-dvevm davinci-sffsdr neuros-osd neuros-osd2 gumstix-connex gumstix-verdex gumstix e680 a780 a1200 at91sam9263ek rokre6 rokre2 rokr-e2 akita c7x0 h2200 h3900 h4000 h5000 htcapache htctornado htcblueangel htcuniversal hx4700 nslu2le hx2000 ixp4xxle magician netbook-pro nokia770 palmt650 palmt680 palmld palmtx palmtt3 palmz72 qemuarm omap5912osk poodle spitz tosa mx27ads at91sam9g20ek mainstone hipox" ;;
+ machines="a1200 a780 a910 afeb9260 afeb9260-180 akita asus620 asus730 at91cap9adk at91-l9260 at91sam9260ek at91sam9261ek at91sam9263ek at91sam9g10ek at91sam9g20ek at91sam9g45ek at91sam9g45ekes at91sam9rlek aximx50 aximx50v bd-neon c7x0 chumby cm-x270 cm-x300 da830-omapl137-evm da850-omapl138-evm davinci-dvevm davinci-sffsdr devkitidp-pxa255 dm355-evm dm355-leopard dm357-evm dm365-evm dm6446-evm dm6467-evm dm6467t-evm dns323 e680 ea3250 em-x270 er0100 eseries ghi270 gumstix gumstix-connex gumstix-custom-connex gumstix-custom-verdex gumstix-verdex h1910 h2200 h3900 h4000 h5000 hawkboard hipox htcalpine htcapache htcblueangel htchimalaya htcsable htctornado htcuniversal hx2000 hx4700 imote2 ixp4xxle kixrp435 kuropro logicpd-pxa270 looxc550 lspro magician mainstone mh355 mp900c mtx-3 mtx-3a mv2120 mx21ads mx27ads n2100 navman-icn330 netbook-pro neuros-osd neuros-osd2 nhk15 nokia770 nslu2le omap1510inn omap1610h2 omap1710h3 omap5912osk openrd-base openrd-client palmld palmt650 palmt680 palmtc palmtt palmtt3 palmtt5 palmtx palmz31 palmz71 palmz72 poodle qemuarm rokre2 rokr-e2 rokre6 ronetix-pm9261 ronetix-pm9263 sgh-i900 sheevaplug spitz stamp9g20evb topas910 tosa triton ts409 tsx09 tx25 tx27" ;;
"armv5teb")
- machines="ixp4xxbe nslu2be" ;;
+ machines="fsg3be ixp4xxbe nslu2be" ;;
+ "armv6")
+ machines="bug mx31ads mx31moboard nokia800 om-3d7k omap2420h4 omap2430sdp smartq5 smdk6410" ;;
"armv6-novfp")
- machines="htcdiamond htckaiser htcpolaris htcraphael htcvogue" ;;
- "armv6")
- machines="smdk6410 smartq5 bug mx31ads nokia800 " ;;
- "armv7")
- machines="" ;;
+ machines="htcblackstone htcdiamond htcdream htckaiser htcnike htcpolaris htcraphael htctitan htcvogue" ;;
"armv7a")
- machines="archos5 archos5it palmpre cm-t35 igep0020 omap3-touchbook beagleboard omap3evm am3517-evm omap3517-evm dm3730-am3715-evm omap3-pandora omapzoom omapzoom2 omapzoom36x overo" ;;
+ machines="am3517-evm archos5 archos5it beagleboard bug20 cm-t35 dm37x-evm am37x-evm htcleo igep0020 nokia900 omap3517-evm omap3evm omap3-pandora omap3-touchbook omap4430-sdp omapzoom omapzoom2 omapzoom36x overo palmpre omap4430-panda" ;;
"avr32")
- machines="atngw100 at32stk1000" ;;
+ machines="at32stk1000 atngw100" ;;
"bfin")
archdir="blackfin"
machines="adsp-bf537-stamp" ;;
"geode")
- machines="alix" ;;
+ machines="alix geodegx geodelx iei-nanogx-466 xo" ;;
"i486")
- machines="x86" ;;
+ machines="wrap" ;;
"i586")
- machines="epia" ;;
+ machines="d201gly2 epia i586-generic netvisa progear x86 x86-uml" ;;
"i686")
- machines="eee701 qemux86 guinness progear" ;;
+ machines="eee701 i686-generic qemux86 guinness progear ion qemux86 vmware x86-32-nocona x86-prescott" ;;
"iwmmxt")
machines="" ;;
- "ppc405")
- machines="dht-walnut" ;;
+ "mips")
+ machines="qemumips" ;;
+ "mipsel")
+ machines="ben-nanonote db1200 lsmipsel mtx-1 mtx-2 rb500 stb225 wgt634u wl500g wrt54 xxs1500" ;;
+ "powerpc")
+ machines="gamecube p2020ds" ;;
+ "ppc405")
+ machines="dht-walnut kilauea magicbox xilinx-ml403 xilinx-ml410" ;;
+ "ppc440e")
+ machines="canyonlands sequoia xilinx-ml507" ;;
"ppc603e")
- machines="lsppchd lsppchg efika n1200" ;;
+ machines="efika lite5200 lsppchd lsppchg n1200 qemuppc storcenter" ;;
+ "ppce300c2")
+ machines="mpc8323e-rdb" ;;
"ppce300c3")
- machines="mpc8313e-rdb mpc8315e-rdb" ;;
+ machines="boc01 mpc8313e-rdb mpc8315e-rdb" ;;
"ppce500")
machines="tqm8540" ;;
+ "ppce500v2")
+ machines="calamari" ;;
+ "ppce600")
+ machines="mpc8641-hpcn" ;;
+ "sh4")
+ machines="qemush4 titan" ;;
"sparc")
- machines="" ;;
+ machines="sun4cdm" ;;
+ "x86")
+ machines="colinux" ;;
esac
if [ $(find . -name "*.ipk"| grep $arch | wc -l) -gt 0 ] ; then
@@ -103,7 +123,6 @@ for i in `find . -name "*_$arch.ipk"` ; do mv $i ../$archdir/base/ ; done
}
do_index() {
-ipkg_tools_path="/home/angstrom/bin"
echo "Processing $(basename $PWD) packages...."
BPWD=`pwd`
@@ -160,12 +179,12 @@ cd ${BPWD}
echo "Processing 'all' feed"
for i in `find . -name "*.ipk"| grep _all` ; do mkdir -p ../all/ || true ;mv $i ../all/ ; done
- (mkdir -p ../all ; cd ../all && ipkg-make-index -p Packages -m . >& /dev/null ; touch Packages.sig )
+ (mkdir -p ../all ; cd ../all && ${ipkg_tools_path}/ipkg-make-index -p Packages -m . >& /dev/null ; touch Packages.sig )
mkdir -p ../sdk ; mv *sdk.ipk ../sdk/ || true
- (mkdir -p ../sdk ; cd ../sdk && ipkg-make-index -p Packages -m . >& /dev/null ; touch Packages.sig )
+ (mkdir -p ../sdk ; cd ../sdk && ${ipkg_tools_path}/ipkg-make-index -p Packages -m . >& /dev/null ; touch Packages.sig )
-for arch in armv4t armv4 armv5teb armv5te armv6-novfp armv6 armv7a armv7 avr32 bfin geode i486 i586 i686 iwmmxt ppc405 ppc603e ppce300c3 ppce500 sparc x86_64 ; do
+for arch in 486sx armv4t armv4 armv5teb armv5te armv6-novfp armv6 armv7a avr32 bfin geode i486 i586 i686 iwmmxt mips mipsel powerpc ppc405 ppc440e ppc603e ppce300c2 ppce300c3 ppce500v2 ppce500 ppce600 sh4 sparc x86_64 x86; do
do_sort
done
diff --git a/contrib/oe-stylize.py b/contrib/oe-stylize.py
index 21e02adbf3..0a1346c180 100755
--- a/contrib/oe-stylize.py
+++ b/contrib/oe-stylize.py
@@ -45,11 +45,13 @@ OE_vars = [
'PE',
'PV',
'PR',
+ 'INC_PR',
'SRC_URI',
'S',
'GPE_TARBALL_SUFFIX',
'inherit',
'EXTRA_',
+ 'export',
'do_fetch',
'do_unpack',
'do_patch',
@@ -66,7 +68,6 @@ OE_vars = [
'addhandler',
'addtask',
'bindir',
- 'export',
'headers',
'include',
'includedir',
diff --git a/contrib/python/generate-manifest-2.6.py b/contrib/python/generate-manifest-2.6.py
index 1d1085d6e6..1a0f1d3900 100755
--- a/contrib/python/generate-manifest-2.6.py
+++ b/contrib/python/generate-manifest-2.6.py
@@ -1,7 +1,7 @@
#!/usr/bin/env python
# generate Python Manifest for the OpenEmbedded build system
-# (C) 2002-2009 Michael 'Mickey' Lauer <mlauer@vanille-media.de>
+# (C) 2002-2010 Michael 'Mickey' Lauer <mlauer@vanille-media.de>
# (C) 2007 Jeremy Laine
# licensed under MIT, see COPYING.MIT
@@ -12,7 +12,7 @@ import time
VERSION = "2.6.4"
__author__ = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
-__version__ = "20100505"
+__version__ = "20100711"
class MakefileMaker:
@@ -62,8 +62,8 @@ class MakefileMaker:
#
# generate provides line
- #
-
+ #
+
provideLine = 'PROVIDES+="'
for name in self.packages:
provideLine += "%s " % name
@@ -273,17 +273,20 @@ if __name__ == "__main__":
m.addPackage( "python-mmap", "Python Memory-Mapped-File Support", "python-core python-io",
"lib-dynload/mmap.so " )
-
+
m.addPackage( "python-multiprocessing", "Python Multiprocessing Support", "python-core python-io python-lang",
- "lib-dynload/_multiprocessing.so multiprocessing" ) # package
+ "lib-dynload/_multiprocessing.so multiprocessing" ) # package
m.addPackage( "python-netclient", "Python Internet Protocol Clients", "python-core python-crypt python-datetime python-io python-lang python-logging python-mime",
- "*Cookie*.* " +
+ "*Cookie*.* " +
"base64.* cookielib.* ftplib.* gopherlib.* hmac.* httplib.* mimetypes.* nntplib.* poplib.* smtplib.* telnetlib.* urllib.* urllib2.* urlparse.* uuid.* rfc822.* mimetools.*" )
m.addPackage( "python-netserver", "Python Internet Protocol Servers", "python-core python-netclient",
"cgi.* *HTTPServer.* SocketServer.*" )
+ m.addPackage( "python-numbers", "Python Number APIs", "python-core python-lang python-re",
+ "decimal.* numbers.*" )
+
m.addPackage( "python-pickle", "Python Persistence Support", "python-core python-codecs python-io python-re",
"pickle.* shelve.* lib-dynload/cPickle.so" )
@@ -334,16 +337,16 @@ if __name__ == "__main__":
m.addPackage( "python-threading", "Python Threading & Synchronization Support", "python-core python-lang",
"_threading_local.* dummy_thread.* dummy_threading.* mutex.* threading.* Queue.*" )
-
+
m.addPackage( "python-tkinter", "Python Tcl/Tk Bindings", "python-core",
"lib-dynload/_tkinter.so lib-tk" ) # package
-
+
m.addPackage( "python-unittest", "Python Unit Testing Framework", "python-core python-stringold python-lang",
"unittest.*" )
m.addPackage( "python-unixadmin", "Python Unix Administration Support", "python-core",
"lib-dynload/nis.so lib-dynload/grp.so lib-dynload/pwd.so getpass.*" )
-
+
m.addPackage( "python-xml", "Python basic XML support.", "python-core python-re",
"lib-dynload/pyexpat.so xml xmllib.*" ) # package
diff --git a/contrib/qemu/run-qemu.sh b/contrib/qemu/run-qemu.sh
index 922d28238c..068fd3e9d5 100755
--- a/contrib/qemu/run-qemu.sh
+++ b/contrib/qemu/run-qemu.sh
@@ -1,8 +1,15 @@
#!/bin/sh
# set -x
+# This script helps in launching QEMU to emulate OE based target systems
+# It accepts 2 arguments
+# First argument is the target architectures
+# second argument is empty if you want to do a complete init or
+# 'single' if booting into /bin/sh
+# It assumes that bridge is setup on the eth0 device on the host systems
+
# on debian-like systems
# set up bridge aptitude install bridge-utils
-#
+#
# change /etc/network/interfaces to something like below and restart
# network
@@ -11,9 +18,9 @@
#
#auto br0
#iface br0 inet static
-# address 10.0.1.37
-# netmask 255.255.0.0
-# gateway 10.0.0.1
+# address 192.168.1.1
+# netmask 255.255.255.0
+# gateway 192.168.1.254
# bridge_ports eth0
# bridge_maxwait 0
# bridge_fd 9
@@ -23,142 +30,205 @@
#
#auto eth0
-supported_archs="{arm mips x86}"
-if [ $# -ne 1 ]; then
+# before using this script make sure that the following variables are set
+# as per your build system environment
+
+# oetmpdir - Same as $TMPDIR set in OE local.conf
+# oesrcdir - Absolute path to OE metadata
+# kernel - Kernel image e.g. uImage, zImage, vmlinux etc.
+# image - The root file system created by OE console-image, x11-image etc.
+# imagetype - Image file system type e.g. ext2, ext3 etc.
+# libc - uclibc/glibc/eglibc
+# server - NFS server hosting the root file system.
+# gateway
+# netmask
+# address - IP Address of the target. You may have diffrent LAN setup
+# hostname - Name of the target
+# nfsdir - Absolute path to directory having the root file system on NFS
+# device
+# nfsboot - 'yes' if root file system is to be mounted over NFS, if booting from
+# disk image then set it to 'no'
+# networking - If target should enable networking over bridge set to 'yes' else 'no'
+# This will be set to 'yes' automatically if nfsboot is enabled
+# staticip - Set to 'yes' if IP address is assigned statically or 'no' if getting
+# from dhcp server. Note that this option is not entertained if networking
+# is disabled
+
+supported_archs="{arm mips mipsel ppc sh4 x86}"
+if [ $# -lt 2 ]; then
echo -en "
- Usage: `basename $0` <arch>
+ Usage: `basename $0` <arch> <libc>
where <arch> is one $supported_archs
- Example: `basename $0` arm
+ libc is uclibc glibc or eglibc
+ Example: `basename $0` arm eglibc
"
- exit 1
+ exit 0
fi
arch=$1
+libc=$2
+mem=256 # memory for guest server in Mb
+imagetype="ext2"
+networking="yes"
+nfsboot="yes"
+staticip="yes"
+
case $arch in
arm)
- address="10.0.1.101"
- macaddr="00:16:3e:00:00:01"
+ address="192.168.1.101"
+ macaddr="00:16:3e:00:00:01"
machine="versatilepb"
gdbport="1234"
consoleopt="console=ttyAMA0 console=ttyS0"
rootdisk="sda"
- qemu="qemu-system-arm"
- libc="uclibc"
- kernel="/scratch/oe/deploy/$libc/images/qemu$arch/zImage-qemuarm.bin"
- hdimage="/scratch/oe/deploy/$libc/images/qemu$arch/native-sdk-image-qemuarm.ext2"
- #hdimage="/scratch/oe/deploy/$libc/images/qemu$arch/console-image-qemuarm.ext2"
- ;;
+ qemuopts="-nographic"
+ kernel="zImage"
+ image="native-sdk-image"
+ ;;
mips)
- address="10.0.1.102"
- macaddr="00:16:3e:00:00:02"
+ address="192.168.1.102"
+ macaddr="00:16:3e:00:00:02"
machine="malta"
gdbport="1235"
- consoleopt="console=ttyS0"
+ consoleopt="console=ttyS0"
rootdisk="hda"
- qemu="qemu-system-mips"
- libc="uclibc"
- kernel="/scratch/oe/deploy/$libc/images/qemu$arch/vmlinux-qemumips.bin"
- hdimage="/scratch/oe/deploy/$libc/images/qemu$arch/native-sdk-image-qemumips.ext2"
- hdimage="/scratch/oe/deploy/$libc/images/qemu$arch/console-image-qemumips.ext2"
- ;;
+ qemuopts="-nographic"
+ kernel="vmlinux"
+ image="native-sdk-image"
+ ;;
+ mipsel)
+ address="192.168.1.103"
+ macaddr="00:16:3e:00:00:03"
+ machine="malta"
+ gdbport="1235"
+ consoleopt="console=ttyS0"
+ rootdisk="hda"
+ qemuopts="-nographic"
+ kernel="vmlinux"
+ image="native-sdk-image"
+ ;;
ppc|powerpc)
- arch=ppc
- address="10.0.1.103"
- macaddr="00:16:3e:00:00:03"
- machine="bamboo"
+ arch=ppc
+ address="192.168.1.104"
+ macaddr="00:16:3e:00:00:04"
+ machine="g3beige"
gdbport="1236"
- consoleopt="console=ttyS0"
- rootdisk="hdc" #hdc4
- qemu="qemu-system-ppcemb"
- libc="eglibc"
- kernel="/scratch/oe/deploy/$libc/images/qemu$arch/uImage-qemuppc.bin"
- hdimage="/scratch/oe/deploy/$libc/images/qemu$arch/helloworld-image-qemuppc.ext2"
- ;;
+ mem="1024"
+ consoleopt="console=ttyS0"
+ rootdisk="hdc"
+ qemuopts="-nographic"
+ kernel="vmlinux"
+ image="minimalist-image"
+ ;;
sh|sh4)
- arch=sh4
- address="10.0.1.104"
- macaddr="00:16:3e:00:00:04"
+ arch=sh4
+ address="192.168.1.105"
+ macaddr="00:16:3e:00:00:05"
machine="r2d"
gdbport="1237"
- #consoleopt="console=tty0 console=ttySC1"
- rootdisk="sdc2" #hdc4
- qemu="qemu-system-sh4 -serial vc -serial stdio"
- #qemu="qemu-system-sh4"
- libc="uclibc"
- kernel="/scratch/oe/deploy/$libc/images/qemu$arch/zImage-qemush4.bin"
- #kernel="/home/kraj/qemu/sh/sh-test-0.2/zImage"
- hdimage="/scratch/oe/deploy/$libc/images/qemu$arch/console-image-qemush4.ext2"
- #hdimage="/home/kraj/qemu/sh/sh-test-0.2/sh-linux-mini.img"
- ;;
+ mem="512"
+ consoleopt="console=ttySC1 noiotrap earlyprintk=sh-sci.1"
+ rootdisk="sda"
+ qemuopts="-monitor null -serial vc -serial stdio"
+ kernel="zImage"
+ image="minimalist-image"
+ ;;
x86)
- address="10.0.1.105"
- macaddr="00:16:3e:00:00:05"
+ address="192.168.1.106"
+ macaddr="00:16:3e:00:00:06"
gdbport="1237"
machine="pc"
- consoleopt="console=ttyS0"
+ mem="1024"
+ consoleopt="console=ttyS0"
rootdisk="hda"
- qemu="qemu"
- libc="uclibc"
- kernel="/scratch/oe/deploy/$libc/images/qemu$arch/bzImage-qemux86.bin"
- hdimage="/scratch/oe/deploy/$libc/images/qemu$arch/native-sdk-image-qemux86.ext2"
- hdimage="/scratch/oe/deploy/$libc/images/qemu$arch/minimalist-image-qemux86.ext2"
- hdimage="/scratch/oe/deploy/$libc/images/qemu$arch/console-image-qemux86.ext2"
- ;;
+ qemuopts=""
+ kernel="bzImage"
+ image="minimalist-image"
+ ;;
*)
- echo "Specify one architectures out of $supported_archs to emulate."
- exit 1
- ;;
+ echo "Specify one architectures out of $supported_archs to emulate."
+ exit 1
+ ;;
esac
-nfsserver="10.0.1.37" # address of NFS server
-gateway="10.0.0.1" # default gateway
-netmask="255.255.0.0" # subnet mask
+nfsserver="192.168.1.1" # address of NFS server
+gateway="192.168.1.254" # default gateway
+netmask="255.255.255.0" # subnet mask
hostname="qemu$arch" # hostname for guest server
nfsdir="/opt/oe/$hostname" # nfs directory where root file system is
device="eth0" # interface that guest server will use
-mem=256 # memory for guest server in Mb
-gdbit="-gdb tcp::$gdbport" # debug the kernel using gdb set it to -s
+#gdbit="-redir tcp:2222::22 -gdb tcp::$gdbport -S" # debug the kernel using gdb
# add -S to stop after launch and wait for
# gdb to connect
-nfsopts="rsize=8192,wsize=8192,hard,intr,tcp,nolock" # nfs options
+oetmpdir=/scratch/oe
+oesrcdir=$HOME/work/oe/openembedded
-# for NFS root
-rootfs="root=/dev/nfs rw nfsroot=$nfsserver:$nfsdir,$nfsopts"
-
-# Boot from a Disk Image
+nfsopts="rsize=8192,wsize=8192,hard,intr,tcp,nolock" # nfs options
-rootfs="root=/dev/$rootdisk rw"
+if [ $nfsboot = "yes" ]; then
+ # for NFS root
+ rootfs="root=/dev/nfs rw nfsroot=$nfsserver:$nfsdir,$nfsopts"
+ # without networking nfsroot wouldnt be possible so enable it explicitly.
+ networking="yes"
+else
+ # Boot from a Disk Image
+ rootfs="root=/dev/$rootdisk rw"
+fi
-# ip format
-#ip=<client-ip>:<server-ip>:<gw-ip>:<netmask>:<hostname>:<device>:<autoconf>
-ipopt="ip=$address::$gateway:$netmask:$hostname:$device:off"
+if [ $networking != "yes" ]; then
+ ipopt=""
+else
+if [ $staticip = "yes" ]; then
+ # ip format
+ #ip=<client-ip>:<server-ip>:<gw-ip>:<netmask>:<hostname>:<device>:<autoconf>
+ ipopt="ip=$address::$gateway:$netmask:$hostname:$device:off"
+else
+ # get IP from DHCP server on network
+ ipopt="ip=dhcp"
+fi
+fi
+qemuifup="$oesrcdir/contrib/qemu/qemu-ifup"
+qemuifdown="$oesrcdir/contrib/qemu/qemu-ifdown"
-# get IP from DHCP server on network
-#ipopt="ip=dhcp"
-init=""
-qemuifup="/home/kraj/work/oe/openembedded/contrib/qemu/qemu-ifup"
-qemuifdown="/home/kraj/work/oe/openembedded/contrib/qemu/qemu-ifdown"
+if [ $networking = "yes" ]; then
+ uid=`whoami`
+ iface=`sudo tunctl -b -u $uid`
+ netopt="-net nic,vlan=0,macaddr=$macaddr -net tap,vlan=0,ifname=$iface,script=$qemuifup,downscript=$qemuifdown"
+else
+ netopt="-net none"
+fi
-uid=`whoami`
-iface=`sudo tunctl -b -u $uid`
+if [ "x$3" == "xsingle" ]; then
+ init="init=/bin/sh"
+else
+ init=""
+fi
-netopt="-net nic,vlan=0,macaddr=$macaddr -net tap,vlan=0,ifname=$iface,script=$qemuifup,downscript=$qemuifdown"
+qemupath="$oetmpdir/sysroots/`uname -m`-linux/usr/bin"
-if [ "x$1" == "xsingle" ]
-then
- init="init=/bin/sh"
+if [ $arch = "x86" ]; then
+ qemu=$qemupath/qemu
+else
+ qemu=$qemupath/qemu-system-$arch
+fi
+kernelimage=$oetmpdir/deploy/$libc/images/qemu$arch/$kernel-qemu$arch.bin
+hdimage=$oetmpdir/deploy/$libc/images/qemu$arch/$image-qemu$arch.$imagetype
+if [ $nfsboot != "yes" ]; then
+ qemuopts="$qemuopts -drive file=$hdimage"
fi
echo "Starting QEMU ..."
set -x
- #-L /scratch/oe/deploy/$libc/images/qemu$arch \
-$qemu -M $machine --snapshot $gdbit -m $mem -kernel $kernel -hda $hdimage \
- -usb -usbdevice wacom-tablet -nographic --no-reboot -localtime \
+$qemu -M $machine --snapshot $gdbit -m $mem \
+ -kernel $kernelimage \
+ -usb -usbdevice wacom-tablet --no-reboot -localtime \
+ $qemuopts \
-append "$consoleopt $rootfs $ipopt $init debug user_debug=-1" \
$netopt
set +x
-#destroy the tap interface
-sudo tunctl -b -d $iface
+if [ $networking = "yes" ]; then
+ #destroy the tap interface
+ sudo tunctl -b -d $iface
+fi
stty sane
-# qemu-system-sh4 -M r2d -kernel ~/zImage -nographic -monitor null -serial null -serial stdio
diff --git a/contrib/source-checker/bump.preferred-xorg-versions-live.sh b/contrib/source-checker/bump.preferred-xorg-versions-live.sh
index 63ae0f4b28..b37215da2c 100755
--- a/contrib/source-checker/bump.preferred-xorg-versions-live.sh
+++ b/contrib/source-checker/bump.preferred-xorg-versions-live.sh
@@ -33,6 +33,11 @@ function updateVersions {
if ls -1 ${BBS}${GRP}/${PKG}_*.bb >/dev/null 2>/dev/null ; then
echo "PREFERRED_VERSION_${PKG} ?= \"${VER}\"" >> ${PREFS_LIVE}
fi
+ if ls -1 ${BBS}${GRP}/${PKG}-native_*.bb >/dev/null 2>/dev/null ||
+ grep "BBCLASSEXTEND.*native" ${BBS}${GRP}/${PKG}_*.bb >/dev/null 2>/dev/null ||
+ grep "BBCLASSEXTEND.*native" ${BBS}${GRP}/${PKG}.inc >/dev/null 2>/dev/null ; then
+ echo "PREFERRED_VERSION_${PKG}-native ?= \"${VER}\"" >> ${PREFS_LIVE}
+ fi
if [[ -n ${BB_VER} && ${BB_VER} != ${VER} ]] ; then
echo "bump: $GRP ${PKG} ${BB_VER} -> ${VER}" | tee -a ${OUT_LOG}
echo "cp ${BBS}${GRP}/${PKG}_${BB_VER}.bb ${BBS}${GRP}/${PKG}_${VER}.bb" >> ${OUT_CMD}
@@ -68,7 +73,6 @@ cat ${DIR}/latest.txt | while read LINE; do
GRP=`echo ${LINE} | sed "s%^\(.*\)\/\(.*\)\/\(.*\)$%\1%g;"`
VER=`echo ${LINE} | sed "s%^\(.*\)\/\(.*\)\/\(.*\)$%\3%g;"`
updateVersions ${PKG} ${GRP} ${VER}
- updateVersions ${PKG}-native ${GRP} ${VER}
done
echo "Check ${OUT_LOG} if there is something new and interesting"