aboutsummaryrefslogtreecommitdiffstats
path: root/opie-3rdparty/nmm_0.0.2.oe
diff options
context:
space:
mode:
Diffstat (limited to 'opie-3rdparty/nmm_0.0.2.oe')
-rw-r--r--opie-3rdparty/nmm_0.0.2.oe32
1 files changed, 32 insertions, 0 deletions
diff --git a/opie-3rdparty/nmm_0.0.2.oe b/opie-3rdparty/nmm_0.0.2.oe
index e69de29bb2..ab3b53c509 100644
--- a/opie-3rdparty/nmm_0.0.2.oe
+++ b/opie-3rdparty/nmm_0.0.2.oe
@@ -0,0 +1,32 @@
+DESCRIPTION = "Nime Mens Morris"
+SECTION = "opie/games"
+PRIORITY = "optional"
+MAINTAINER = "Open Embedded <oe@handhelds.org>"
+LICENSE = "GPL"
+AUTHOR = "Dirk Farin, Port by Rober Ernst"
+HOMEPAGE = "http://www.linux-solutions.at/projects/zaurus/games-Nine-Mens-Morris.html"
+
+SRC_URI = "http://handhelds.org/~zecke/oe_packages/nmm_V0.0.2.tar.gz \
+ file://Makefile.patch;patch=1 \
+ file://nmm.patch;patch=1"
+
+PV = "0.0.2"
+S = "${WORKDIR}/nmm_V${PV}"
+
+APPNAME = "nmm"
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+
+
+do_compile_prepend() {
+ oe_runmake -C images
+}
+
+do_install () {
+ install -d ${D}/${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${S}/*.png ${D}/${palmtopdir}/pics/${APPNAME}/
+
+}
+
+inherit opie
+