aboutsummaryrefslogtreecommitdiffstats
path: root/packages/aircrack/aircrack_2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/aircrack/aircrack_2.1.bb')
-rw-r--r--packages/aircrack/aircrack_2.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/packages/aircrack/aircrack_2.1.bb b/packages/aircrack/aircrack_2.1.bb
index e69de29bb2..82cee083b7 100644
--- a/packages/aircrack/aircrack_2.1.bb
+++ b/packages/aircrack/aircrack_2.1.bb
@@ -0,0 +1,23 @@
+SECTION = "console/network"
+DESCRIPTION = "Aircrack is a set of tools for wep key statistical cracking"
+HOMEPAGE = "http://www.cr0.net:8040/code/network/aircrack/"
+LICENSE = "GPLv2"
+MAINTAINER = "Olivier Fauchon <olivier@aixmarseille.com>"
+DEPENDS = ""
+PV="2.1"
+PR="r0"
+
+SRC_URI = "http://www.cr0.net:8040/code/network/aircrack-2.1.tgz \
+file://silent_patch.diff;patch=1;pnum=0"
+
+inherit autotools
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install -d ${D}/${libdir}/${PN}
+ install -m 0755 802ether ${D}/${sbindir}
+ install -m 0755 airodump ${D}/${sbindir}
+ install -m 0755 aircrack ${D}/${sbindir}
+ install -m 0755 aireplay ${D}/${sbindir}
+ install -m 0755 hopper.sh ${D}/${sbindir}
+}