aboutsummaryrefslogtreecommitdiffstats
path: root/packages/aspell/aspell-0.50.5
diff options
context:
space:
mode:
Diffstat (limited to 'packages/aspell/aspell-0.50.5')
-rw-r--r--packages/aspell/aspell-0.50.5/.mtn2git_empty0
-rw-r--r--packages/aspell/aspell-0.50.5/makefile.patch20
-rwxr-xr-x[-rw-r--r--]packages/aspell/aspell-0.50.5/mk-dirs_h.py20
3 files changed, 40 insertions, 0 deletions
diff --git a/packages/aspell/aspell-0.50.5/.mtn2git_empty b/packages/aspell/aspell-0.50.5/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/aspell/aspell-0.50.5/.mtn2git_empty
diff --git a/packages/aspell/aspell-0.50.5/makefile.patch b/packages/aspell/aspell-0.50.5/makefile.patch
index e69de29bb2..c16a32e3b9 100644
--- a/packages/aspell/aspell-0.50.5/makefile.patch
+++ b/packages/aspell/aspell-0.50.5/makefile.patch
@@ -0,0 +1,20 @@
+--- aspell-0.50.5/common/Makefile.am~ 2002-11-05 00:24:14.000000000 +0000
++++ aspell-0.50.5/common/Makefile.am 2004-06-27 14:33:37.000000000 +0100
+@@ -4,7 +4,7 @@
+ pkgdatadir = @pkgdatadir@
+ pkglibdir = @pkglibdir@
+
+-noinst_PROGRAMS = mk-dirs_h
++#noinst_PROGRAMS = mk-dirs_h
+
+ dirs.h: mk-dirs_h
+ echo '#define PREFIX "${prefix}"' > dirs.h
+@@ -12,7 +12,7 @@
+ ./mk-dirs_h ${prefix} DATA_DIR ${pkgdatadir} >> dirs.h
+ ./mk-dirs_h ${prefix} CONF_DIR ${sysconfdir} >> dirs.h
+
+-mk_dirs_h_SOURCES = mk-dirs_h.cpp
++#mk_dirs_h_SOURCES = mk-dirs_h.cpp
+
+ config.cpp: dirs.h
+
diff --git a/packages/aspell/aspell-0.50.5/mk-dirs_h.py b/packages/aspell/aspell-0.50.5/mk-dirs_h.py
index e69de29bb2..a487751e81 100644..100755
--- a/packages/aspell/aspell-0.50.5/mk-dirs_h.py
+++ b/packages/aspell/aspell-0.50.5/mk-dirs_h.py
@@ -0,0 +1,20 @@
+#!/usr/bin/env python
+
+import sys
+
+prefix=sys.argv[1]
+key=sys.argv[2]
+value=sys.argv[3]
+
+while prefix[-1] == '/':
+ prefix = prefix[:-2]
+
+plen = len(prefix)
+
+if value[:plen] == prefix:
+ value = value[plen:]
+ while value[0] == '/':
+ value = value[1:]
+ print "#define " + key + " \"<prefix:" + value + ">\"\n"
+else:
+ print "#define " + key + " \"" + value + "\"\n"