aboutsummaryrefslogtreecommitdiffstats
path: root/packages/binutils/files
diff options
context:
space:
mode:
Diffstat (limited to 'packages/binutils/files')
-rw-r--r--packages/binutils/files/.mtn2git_empty0
-rw-r--r--packages/binutils/files/better_file_error.patch17
-rw-r--r--packages/binutils/files/ld_makefile.patch22
-rw-r--r--packages/binutils/files/plt32trunc.patch24
-rw-r--r--packages/binutils/files/signed_char_fix.patch12
5 files changed, 75 insertions, 0 deletions
diff --git a/packages/binutils/files/.mtn2git_empty b/packages/binutils/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/binutils/files/.mtn2git_empty
diff --git a/packages/binutils/files/better_file_error.patch b/packages/binutils/files/better_file_error.patch
index e69de29bb2..38ef52966e 100644
--- a/packages/binutils/files/better_file_error.patch
+++ b/packages/binutils/files/better_file_error.patch
@@ -0,0 +1,17 @@
+diff -urN binutils-2.11.92.0.5/bfd/opncls.c binutils-2.11.92.0.5.new/bfd/opncls.c
+--- binutils-2.11.92.0.5/bfd/opncls.c Mon Oct 1 18:25:21 2001
++++ binutils-2.11.92.0.5.new/bfd/opncls.c Sat Oct 13 11:26:59 2001
+@@ -127,6 +127,13 @@
+ {
+ bfd *nbfd;
+ const bfd_target *target_vec;
++ struct stat s;
++
++ if (stat (filename, &s) == 0)
++ if (S_ISDIR(s.st_mode)) {
++ bfd_set_error (bfd_error_file_not_recognized);
++ return NULL;
++ }
+
+ nbfd = _bfd_new_bfd ();
+ if (nbfd == NULL)
diff --git a/packages/binutils/files/ld_makefile.patch b/packages/binutils/files/ld_makefile.patch
index e69de29bb2..c1d2ac1ece 100644
--- a/packages/binutils/files/ld_makefile.patch
+++ b/packages/binutils/files/ld_makefile.patch
@@ -0,0 +1,22 @@
+--- binutils-2.11.90.0.19.orig/ld/Makefile.am
++++ binutils-2.11.90.0.19/ld/Makefile.am
+@@ -19,7 +19,7 @@
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+
+ EMUL = @EMUL@
+ EMULATION_OFILES = @EMULATION_OFILES@
+--- binutils-2.11.90.0.19.orig/ld/Makefile.in
++++ binutils-2.11.90.0.19/ld/Makefile.in
+@@ -123,7 +123,7 @@
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+
+ EMUL = @EMUL@
+ EMULATION_OFILES = @EMULATION_OFILES@
diff --git a/packages/binutils/files/plt32trunc.patch b/packages/binutils/files/plt32trunc.patch
index e69de29bb2..4990f5dbb6 100644
--- a/packages/binutils/files/plt32trunc.patch
+++ b/packages/binutils/files/plt32trunc.patch
@@ -0,0 +1,24 @@
+--- binutils/bfd/elf32-arm.h.orig 2004-04-22 22:11:15.000000000 -0400
++++ binutils/bfd/elf32-arm.h 2004-04-22 22:28:37.000000000 -0400
+@@ -2229,6 +2229,8 @@ elf32_arm_relocate_section (output_bfd,
+ case R_ARM_PC24:
+ case R_ARM_ABS32:
+ case R_ARM_THM_PC22:
++ case R_ARM_PLT32:
++
+ if (info->shared
+ && (
+ (!info->symbolic && h->dynindx != -1)
+@@ -2262,11 +2264,6 @@ elf32_arm_relocate_section (output_bfd,
+ relocation = 0;
+ break;
+
+- case R_ARM_PLT32:
+- if (h->plt.offset != (bfd_vma)-1)
+- relocation = 0;
+- break;
+-
+ default:
+ if (unresolved_reloc)
+ _bfd_error_handler
+
diff --git a/packages/binutils/files/signed_char_fix.patch b/packages/binutils/files/signed_char_fix.patch
index e69de29bb2..b3709dabed 100644
--- a/packages/binutils/files/signed_char_fix.patch
+++ b/packages/binutils/files/signed_char_fix.patch
@@ -0,0 +1,12 @@
+diff -urN binutils-2.11.92.0.12.3/opcodes/i386-dis.c binutils-2.11.92.0.12.3.new/opcodes/i386-dis.c
+--- binutils-2.11.92.0.12.3/opcodes/i386-dis.c Fri Nov 16 17:05:55 2001
++++ binutils-2.11.92.0.12.3.new/opcodes/i386-dis.c Mon Dec 31 15:55:04 2001
+@@ -1830,7 +1830,7 @@
+ * The function returns the length of this instruction in bytes.
+ */
+
+-static char intel_syntax;
++static signed char intel_syntax;
+ static char open_char;
+ static char close_char;
+ static char separator_char;