aboutsummaryrefslogtreecommitdiffstats
path: root/packages/bitbake
diff options
context:
space:
mode:
Diffstat (limited to 'packages/bitbake')
-rw-r--r--packages/bitbake/.mtn2git_empty0
-rw-r--r--packages/bitbake/bitbake-package.inc1
-rw-r--r--packages/bitbake/bitbake.inc12
-rw-r--r--packages/bitbake/bitbake_1.0.bb11
-rw-r--r--packages/bitbake/bitbake_1.1.bb11
-rw-r--r--packages/bitbake/bitbake_svn.bb16
6 files changed, 51 insertions, 0 deletions
diff --git a/packages/bitbake/.mtn2git_empty b/packages/bitbake/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/bitbake/.mtn2git_empty
diff --git a/packages/bitbake/bitbake-package.inc b/packages/bitbake/bitbake-package.inc
index e69de29bb2..fa1e76b392 100644
--- a/packages/bitbake/bitbake-package.inc
+++ b/packages/bitbake/bitbake-package.inc
@@ -0,0 +1 @@
+FILES_${PN} += "${datadir}/bitbake"
diff --git a/packages/bitbake/bitbake.inc b/packages/bitbake/bitbake.inc
index e69de29bb2..e454db2f40 100644
--- a/packages/bitbake/bitbake.inc
+++ b/packages/bitbake/bitbake.inc
@@ -0,0 +1,12 @@
+DESCRIPTION = "BitBake is a simple tool for the execution of tasks. It is \
+derived from Portage, which is the package management system used by the \
+Gentoo Linux distribution. It is most commonly used to build packages, as it \
+can easily use its rudamentary inheritence to abstract common operations, such \
+as fetching sources, unpacking them, patching them, compiling them, and so on. \
+It is the basis of the OpenEmbedded project, which is being used for \
+OpenZaurus, Familiar, and a number of other Linux distributions."
+HOMEPAGE = "http://developer.berlios.de/projects/bitbake/"
+LICENSE = "GPL MIT"
+SECTION = "devel"
+SUMMARY = "BitBake build tool"
+PACKAGE_ARCH = "all"
diff --git a/packages/bitbake/bitbake_1.0.bb b/packages/bitbake/bitbake_1.0.bb
index e69de29bb2..9f8f054355 100644
--- a/packages/bitbake/bitbake_1.0.bb
+++ b/packages/bitbake/bitbake_1.0.bb
@@ -0,0 +1,11 @@
+include bitbake.inc
+
+# We don't need a toolchain...
+INHIBIT_DEFAULT_DEPS = "1"
+
+SRC_URI = "svn://svn.berlios.de/bitbake/tags;module=bitbake-${PV}"
+S = "${WORKDIR}/bitbake-${PV}"
+
+inherit distutils
+
+include bitbake-package.inc
diff --git a/packages/bitbake/bitbake_1.1.bb b/packages/bitbake/bitbake_1.1.bb
index e69de29bb2..9f8f054355 100644
--- a/packages/bitbake/bitbake_1.1.bb
+++ b/packages/bitbake/bitbake_1.1.bb
@@ -0,0 +1,11 @@
+include bitbake.inc
+
+# We don't need a toolchain...
+INHIBIT_DEFAULT_DEPS = "1"
+
+SRC_URI = "svn://svn.berlios.de/bitbake/tags;module=bitbake-${PV}"
+S = "${WORKDIR}/bitbake-${PV}"
+
+inherit distutils
+
+include bitbake-package.inc
diff --git a/packages/bitbake/bitbake_svn.bb b/packages/bitbake/bitbake_svn.bb
index e69de29bb2..47056eaee9 100644
--- a/packages/bitbake/bitbake_svn.bb
+++ b/packages/bitbake/bitbake_svn.bb
@@ -0,0 +1,16 @@
+include bitbake.inc
+
+# Don't use the tip of svn by default
+DEFAULT_PREFERENCE = "-1"
+
+# We don't need a toolchain...
+INHIBIT_DEFAULT_DEPS = "1"
+
+PV = "0.0svn${CVSDATE}"
+SRC_URI = "svn://svn.berlios.de/bitbake/trunk;module=bitbake"
+# SRC_URI = "svn+ssh://svn.berlios.de/bitbake/trunk;module=bitbake"
+S = "${WORKDIR}/bitbake"
+
+inherit distutils
+
+include bitbake-package.inc