aboutsummaryrefslogtreecommitdiffstats
path: root/packages/bochs/bochs_2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/bochs/bochs_2.1.bb')
-rw-r--r--packages/bochs/bochs_2.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/packages/bochs/bochs_2.1.bb b/packages/bochs/bochs_2.1.bb
index e69de29bb2..a9aed3a08c 100644
--- a/packages/bochs/bochs_2.1.bb
+++ b/packages/bochs/bochs_2.1.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "x86 Emulator based on SDL"
+SECTION = "base"
+PRIORITY = "optional"
+DEPENDS = "libsdl-qpe"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bochs/bochs-${PV}.tar.gz \
+ file://compile.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--without-x \
+ --without-x11 \
+ --without-beos \
+ --without-win32 \
+ --without-macos \
+ --without-carbon \
+ --without-nogui \
+ --without-term \
+ --without-rfb \
+ --without-amigaos \
+ --with-sdl \
+ --without-svga \
+ --without-wx"
+
+do_compile() {
+ oe_runmake bochs bximage bxcommit
+}
+
+do_install() {
+ oe_runmake -i install # yes, ugly i know... but i can't get rid of that bailing out docbook crap atm.
+}