aboutsummaryrefslogtreecommitdiffstats
path: root/packages/bootsplash
diff options
context:
space:
mode:
Diffstat (limited to 'packages/bootsplash')
-rw-r--r--packages/bootsplash/bootsplash_3.0.7.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/bootsplash/bootsplash_3.0.7.bb b/packages/bootsplash/bootsplash_3.0.7.bb
index e69de29bb2..da2290e202 100644
--- a/packages/bootsplash/bootsplash_3.0.7.bb
+++ b/packages/bootsplash/bootsplash_3.0.7.bb
@@ -0,0 +1,21 @@
+# bootsplash OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="Bootsplash shows pretty pictures during boot"
+HOMEPAGE="http://www.bootsplash.org"
+SECTION = "media-gfx"
+LICENSE = "GPL"
+SRC_URI="ftp://ftp.openbios.org/pub/bootsplash/rpm-sources/bootsplash/bootsplash-${PV}.tar.bz2"
+
+DEPENDS="freetype"
+
+do_compile() {
+ oe_runmake -C Utilities
+}
+
+do_install() {
+ install -d ${D}${bindir}/
+ install -m 0755 ${S}/Utilities/fbtruetype ${D}${bindir}
+ install -m 0755 ${S}/Utilities/splash ${D}${bindir}
+}