aboutsummaryrefslogtreecommitdiffstats
path: root/packages/btscanner
diff options
context:
space:
mode:
Diffstat (limited to 'packages/btscanner')
-rw-r--r--packages/btscanner/.mtn2git_empty0
-rw-r--r--packages/btscanner/btscanner-1.0/.mtn2git_empty0
-rw-r--r--packages/btscanner/btscanner-1.0/configure.patch45
-rw-r--r--packages/btscanner/btscanner_1.0.bb12
4 files changed, 57 insertions, 0 deletions
diff --git a/packages/btscanner/.mtn2git_empty b/packages/btscanner/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/btscanner/.mtn2git_empty
diff --git a/packages/btscanner/btscanner-1.0/.mtn2git_empty b/packages/btscanner/btscanner-1.0/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/btscanner/btscanner-1.0/.mtn2git_empty
diff --git a/packages/btscanner/btscanner-1.0/configure.patch b/packages/btscanner/btscanner-1.0/configure.patch
index e69de29bb2..a69d4df9e4 100644
--- a/packages/btscanner/btscanner-1.0/configure.patch
+++ b/packages/btscanner/btscanner-1.0/configure.patch
@@ -0,0 +1,45 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- btscanner-1.0/configure.in~configure.patch 2003-10-14 13:01:20.000000000 +0200
++++ btscanner-1.0/configure.in 2004-07-16 11:55:24.000000000 +0200
+@@ -10,9 +10,8 @@
+ AC_PROG_CC
+
+ # Checks for libraries.
+-AC_HAVE_LIBRARY(curses,,[AC_MSG_ERROR([Curses not found])])
++AC_HAVE_LIBRARY(ncurses,,[AC_MSG_ERROR([Curses not found])])
+ AC_HAVE_LIBRARY(bluetooth,,[AC_MSG_ERROR([Bluetooth not found])])
+-AC_HAVE_LIBRARY(sdp,,[AC_MSG_ERROR([SDP not found])])
+ AC_HAVE_LIBRARY(pthread,,[AC_MSG_ERROR([Pthreads not found])])
+ AC_HAVE_LIBRARY(gdbm,,[AC_MSG_ERROR([GDBM not found])])
+
+--- btscanner-1.0/Makefile.in~configure.patch 2003-10-14 14:16:23.000000000 +0200
++++ btscanner-1.0/Makefile.in 2004-07-16 11:54:45.000000000 +0200
+@@ -6,9 +6,12 @@
+ CP = cp
+ MV = mv
+ RM = rm
++INSTALL = install
+ GZIP = gzip
+ MKDIR = mkdir
+
++DESTDIR =
++
+ all: $(EXECS)
+
+ btscanner.o: btscanner.c btscanner.h
+@@ -34,7 +37,7 @@
+ $(CC) $(CFLAGS) -c $*.c
+
+ install: all
+- $(MKDIR) -p @prefix@/bin
+- $(CP) $(EXECS) @prefix@/bin/
+- $(MKDIR) -p @prefix@/etc
+- $(CP) oui.txt @prefix@/etc/oui.txt
++ $(INSTALL) -d $(DESTDIR)/@prefix@/bin
++ $(INSTALL) -m 0755 $(EXECS) $(DESTDIR)/@prefix@/bin/
++ $(INSTALL) -d $(DESTDIR)/@prefix@/etc
++ $(INSTALL) -m 0444 oui.txt $(DESTDIR)/@prefix@/etc/oui.txt
diff --git a/packages/btscanner/btscanner_1.0.bb b/packages/btscanner/btscanner_1.0.bb
index e69de29bb2..d45b7acd3a 100644
--- a/packages/btscanner/btscanner_1.0.bb
+++ b/packages/btscanner/btscanner_1.0.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "Extract information from Bluetooth devices in range."
+SECTION = "libs"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.pentest.co.uk/cgi-bin/viewcat.cgi?cat=downloads&section=01_bluetooth"
+DEPENDS = "bluez-libs gdbm ncurses"
+PR = "r2"
+LICENSE = "GPLv2"
+
+SRC_URI = "http://www.pentest.co.uk/src/btscanner-${PV}.tar.gz \
+ file://configure.patch;patch=1"
+
+inherit autotools