aboutsummaryrefslogtreecommitdiffstats
path: root/packages/classpath
diff options
context:
space:
mode:
Diffstat (limited to 'packages/classpath')
-rw-r--r--packages/classpath/.mtn2git_empty0
-rw-r--r--packages/classpath/classpath_0.14.bb28
-rw-r--r--packages/classpath/classpath_0.15.bb28
-rw-r--r--packages/classpath/files/.mtn2git_empty0
-rw-r--r--packages/classpath/files/disable-automake-checks.patch11
5 files changed, 67 insertions, 0 deletions
diff --git a/packages/classpath/.mtn2git_empty b/packages/classpath/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/classpath/.mtn2git_empty
diff --git a/packages/classpath/classpath_0.14.bb b/packages/classpath/classpath_0.14.bb
index e69de29bb2..3e1f51afd4 100644
--- a/packages/classpath/classpath_0.14.bb
+++ b/packages/classpath/classpath_0.14.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "GNU Classpath standard Java libraries"
+HOMEPAGE = "http://www.gnu.org/software/classpath/"
+LICENSE = "Classpath"
+PRIORITY = "optional"
+MAINTAINER = "Rene Wagner <rw@handhelds.org>"
+SECTION = "libs"
+PR = "r0"
+
+DEPENDS = "glib-2.0 gtk+ libart-lgpl pango jikes-native"
+RDEPENDS_${PN} = "${PN}-common (${PV})"
+
+SRC_URI = "${GNU_MIRROR}/${PN}/${P}.tar.gz \
+ file://disable-automake-checks.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-jikes"
+
+PACKAGES += " ${PN}-common ${PN}-examples"
+
+FILES_${PN} = "${libdir}/${PN}"
+FILES_${PN}-common = "${datadir}/${PN}/glibj.zip"
+FILES_${PN}-examples = "${datadir}/${PN}/examples"
+
+do_install() {
+ autotools_do_install
+ mv ${D}${libdir}/security ${D}${libdir}/${PN}
+}
diff --git a/packages/classpath/classpath_0.15.bb b/packages/classpath/classpath_0.15.bb
index e69de29bb2..3e1f51afd4 100644
--- a/packages/classpath/classpath_0.15.bb
+++ b/packages/classpath/classpath_0.15.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "GNU Classpath standard Java libraries"
+HOMEPAGE = "http://www.gnu.org/software/classpath/"
+LICENSE = "Classpath"
+PRIORITY = "optional"
+MAINTAINER = "Rene Wagner <rw@handhelds.org>"
+SECTION = "libs"
+PR = "r0"
+
+DEPENDS = "glib-2.0 gtk+ libart-lgpl pango jikes-native"
+RDEPENDS_${PN} = "${PN}-common (${PV})"
+
+SRC_URI = "${GNU_MIRROR}/${PN}/${P}.tar.gz \
+ file://disable-automake-checks.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-jikes"
+
+PACKAGES += " ${PN}-common ${PN}-examples"
+
+FILES_${PN} = "${libdir}/${PN}"
+FILES_${PN}-common = "${datadir}/${PN}/glibj.zip"
+FILES_${PN}-examples = "${datadir}/${PN}/examples"
+
+do_install() {
+ autotools_do_install
+ mv ${D}${libdir}/security ${D}${libdir}/${PN}
+}
diff --git a/packages/classpath/files/.mtn2git_empty b/packages/classpath/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/classpath/files/.mtn2git_empty
diff --git a/packages/classpath/files/disable-automake-checks.patch b/packages/classpath/files/disable-automake-checks.patch
index e69de29bb2..d6a55428ad 100644
--- a/packages/classpath/files/disable-automake-checks.patch
+++ b/packages/classpath/files/disable-automake-checks.patch
@@ -0,0 +1,11 @@
+--- sablevm-classpath-1.1.7/configure.ac.orig 2004-11-26 00:23:01.000000000 +0100
++++ sablevm-classpath-1.1.7/configure.ac 2004-11-26 00:23:46.000000000 +0100
+@@ -34,7 +34,7 @@
+ AC_SUBST(CLASSPATH_MODULE)
+
+ AC_PREREQ(2.59)
+-AM_INIT_AUTOMAKE([1.9.0 gnu std-options tar-ustar])
++AM_INIT_AUTOMAKE
+ AC_CONFIG_HEADERS([include/config.h])
+ AC_PREFIX_DEFAULT(/usr/local)
+