aboutsummaryrefslogtreecommitdiffstats
path: root/packages/classpath
diff options
context:
space:
mode:
Diffstat (limited to 'packages/classpath')
-rw-r--r--packages/classpath/classpath-gtk_0.93.bb9
-rw-r--r--packages/classpath/classpath-gtk_cvs.bb30
-rw-r--r--packages/classpath/classpath-initial_0.93.bb28
-rw-r--r--packages/classpath/classpath-minimal-native_0.93.bb23
-rw-r--r--packages/classpath/classpath-minimal-native_0.95.bb7
-rw-r--r--packages/classpath/classpath-minimal_0.90.bb9
-rw-r--r--packages/classpath/classpath-minimal_0.95.bb40
-rw-r--r--packages/classpath/classpath-minimal_0.96.1.bb17
-rw-r--r--packages/classpath/classpath-native.inc32
-rw-r--r--packages/classpath/classpath-native_0.96.1.bb6
-rw-r--r--packages/classpath/classpath.inc60
-rw-r--r--packages/classpath/classpath_0.14.bb10
-rw-r--r--packages/classpath/classpath_0.15.bb10
-rw-r--r--packages/classpath/classpath_0.17.bb10
-rw-r--r--packages/classpath/classpath_0.18.bb10
-rw-r--r--packages/classpath/classpath_0.19.bb10
-rw-r--r--packages/classpath/classpath_0.20.bb10
-rw-r--r--packages/classpath/classpath_0.95.bb20
-rw-r--r--packages/classpath/classpath_0.96.1.bb20
-rw-r--r--packages/classpath/classpath_cvs.bb35
-rw-r--r--packages/classpath/files/disable-automake-checks-v2.patch11
-rw-r--r--packages/classpath/files/disable-automake-checks.patch11
-rw-r--r--packages/classpath/files/fix-endian-arm-floats.patch11
-rw-r--r--packages/classpath/files/gconf_version.patch11
-rw-r--r--packages/classpath/files/gjar-prefix-patch.diff40
25 files changed, 210 insertions, 270 deletions
diff --git a/packages/classpath/classpath-gtk_0.93.bb b/packages/classpath/classpath-gtk_0.93.bb
deleted file mode 100644
index a3b39d92f8..0000000000
--- a/packages/classpath/classpath-gtk_0.93.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require classpath.inc
-
-DEPENDS = "glib-2.0 gtk+ cairo gconf libart-lgpl pango libxtst jikes-native zip-native"
-RDEPENDS_${PN} = "classpath-common (>= ${PV})"
-RCONFLICTS_${PN} = "classpath-minimal"
-
-SRC_URI += "file://disable-automake-checks-v2.patch;patch=1"
-
-EXTRA_OECONF = "--with-jikes --disable-plugin --disable-dssi"
diff --git a/packages/classpath/classpath-gtk_cvs.bb b/packages/classpath/classpath-gtk_cvs.bb
deleted file mode 100644
index 18d79decae..0000000000
--- a/packages/classpath/classpath-gtk_cvs.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-require classpath.inc
-
-PR = "r2"
-
-SRCDATE_${PN} ?= "20070501"
-PV = "0.93+cvs${SRCDATE}"
-
-### note from Laibsch: bug 2523 has information on how to build this package
-DEPENDS = "glib-2.0 gtk+ cairo gconf ecj-native zip-native virtual/java-native libxtst"
-RDEPENDS_${PN} = "classpath-common (>= ${PV})"
-RCONFLICTS_${PN} = "classpath-minimal"
-
-SRC_URI = "cvs://anonymous@cvs.savannah.gnu.org/sources/classpath;module=classpath \
- file://disable-automake-checks-v2.patch;patch=1"
-
-S = "${WORKDIR}/classpath"
-
-EXTRA_OECONF = "--with-ecj=${STAGING_BINDIR_NATIVE}/ecj --with-ecj-jar=${STAGING_BINDIR_NATIVE}/ecj.jar --disable-plugin --disable-dssi --disable-alsa"
-
-do_stage() {
- install -d ${STAGING_INCDIR}/classpath
- install -m 0755 include/jni* ${STAGING_INCDIR}/classpath/
- install -d ${STAGING_DATADIR}/classpath
- install -m 0755 lib/glibj.zip ${STAGING_DATADIR}/classpath/
-}
-
-do_install() {
- autotools_do_install
- mv ${D}${libdir}/security ${D}${libdir}/${PN}
-}
diff --git a/packages/classpath/classpath-initial_0.93.bb b/packages/classpath/classpath-initial_0.93.bb
new file mode 100644
index 0000000000..9e303f6eba
--- /dev/null
+++ b/packages/classpath/classpath-initial_0.93.bb
@@ -0,0 +1,28 @@
+# No later version of Classpath may be used because this is the latest that can be compiled
+# by jikes!
+
+require classpath-native.inc
+
+DESCRIPTION="Java1.4-compatible GNU Classpath variant that is used as bootclasspath for jikes-native."
+
+PR = "r0"
+
+DEPENDS = "zip-native fastjar-native jikes-native"
+
+EXTRA_OECONF = "\
+ --with-jikes=jikes \
+ --with-fastjar=fastjar \
+ --with-glibj \
+ --disable-local-sockets \
+ --disable-alsa \
+ --disable-gconf-peer \
+ --disable-gtk-peer \
+ --disable-plugin \
+ --disable-dssi \
+ --disable-examples \
+ --disable-tools \
+ --with-glibj-dir=${STAGING_DATADIR}/classpath-initial \
+ --with-native-libdir=${STAGING_LIBDIR}/classpath-initial \
+ --includedir=${STAGING_INCDIR}/classpath-initial \
+ "
+
diff --git a/packages/classpath/classpath-minimal-native_0.93.bb b/packages/classpath/classpath-minimal-native_0.93.bb
deleted file mode 100644
index 83cb60142c..0000000000
--- a/packages/classpath/classpath-minimal-native_0.93.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-require classpath.inc
-
-DEPENDS = "glib-2.0 libart-lgpl pango libxtst jikes-native zip-native"
-PR = "r1"
-
-SRC_URI += "file://disable-automake-checks-v2.patch;patch=1"
-
-S = "${WORKDIR}/classpath-${PV}"
-
-inherit native
-
-EXTRA_OECONF = "--with-jikes --disable-gconf-peer --disable-gtk-peer --disable-plugin --disable-dssi --disable-examples"
-
-do_stage() {
- install -d ${STAGING_INCDIR}/classpath
- install -m 0755 include/jni* ${STAGING_INCDIR}/classpath/
- install -d ${STAGING_DATADIR}/classpath
- install -m 0755 lib/glibj.zip ${STAGING_DATADIR}/classpath/
-}
-
-do_install() {
- :
-}
diff --git a/packages/classpath/classpath-minimal-native_0.95.bb b/packages/classpath/classpath-minimal-native_0.95.bb
deleted file mode 100644
index 28b25a7cb9..0000000000
--- a/packages/classpath/classpath-minimal-native_0.95.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-
-# classpath-minimal-native has no packages
-# primary goal is to speed up building of java virtual machines
-
-inherit native
-require classpath-minimal_${PV}.bb
-PR = "r0"
diff --git a/packages/classpath/classpath-minimal_0.90.bb b/packages/classpath/classpath-minimal_0.90.bb
deleted file mode 100644
index 8d9554c999..0000000000
--- a/packages/classpath/classpath-minimal_0.90.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require classpath.inc
-
-DEPENDS = "jikes-native zip-native"
-RDEPENDS_${PBN}-minimal = "${PBN}-common (>= ${PV})"
-RCONFLICTS_${PBN}-minimal = "${PBN}-gtk"
-
-SRC_URI += "file://disable-automake-checks.patch;patch=1"
-
-EXTRA_OECONF = "--with-jikes --without-x --with-glibj --disable-gtk-peer --disable-alsa"
diff --git a/packages/classpath/classpath-minimal_0.95.bb b/packages/classpath/classpath-minimal_0.95.bb
deleted file mode 100644
index bca7a46919..0000000000
--- a/packages/classpath/classpath-minimal_0.95.bb
+++ /dev/null
@@ -1,40 +0,0 @@
-DESCRIPTION = "GNU Classpath standard Java libraries"
-HOMEPAGE = "http://www.gnu.org/software/classpath/"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "Classpath"
-PROVIDES = "classpath"
-RPROVIDES = "classpath"
-PR = "r1"
-
-S = "${WORKDIR}/classpath-${PV}"
-
-SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz"
-
-DEPENDS = "ecj-native zip-native"
-
-inherit autotools
-
-
-EXTRA_OECONF = "--with-glibj \
- --with-ecj=${STAGING_BINDIR_NATIVE}/ecj \
- --disable-alsa \
- --disable-gconf-peer \
- --disable-gtk-peer \
- --disable-plugin \
- --disable-dssi \
- --disable-examples \
- "
-do_install() {
- :
-}
-
-do_stage() {
- install -d ${STAGING_INCDIR}/classpath-minimal/
- install -m 0644 include/jni.h ${STAGING_INCDIR}/classpath-minimal/
- install -m 0644 include/jni_md.h ${STAGING_INCDIR}/classpath-minimal/
- install -d ${STAGING_DATADIR}/java/classpath-minimal/
- install -m 0644 lib/glibj.zip ${STAGING_DATADIR}/java/classpath-minimal/
-}
-
-PACKAGES = " "
diff --git a/packages/classpath/classpath-minimal_0.96.1.bb b/packages/classpath/classpath-minimal_0.96.1.bb
new file mode 100644
index 0000000000..0597274915
--- /dev/null
+++ b/packages/classpath/classpath-minimal_0.96.1.bb
@@ -0,0 +1,17 @@
+require classpath.inc
+
+PR = "r3"
+
+SRC_URI += "file://gjar-prefix-patch.diff;patch=1;pnum=0"
+
+PROVIDES = "${PN} classpath"
+
+EXTRA_OECONF += "\
+ --enable-local-sockets \
+ --disable-alsa \
+ --disable-gconf-peer \
+ --disable-gtk-peer \
+ --disable-plugin \
+ --disable-dssi \
+ --disable-examples \
+ "
diff --git a/packages/classpath/classpath-native.inc b/packages/classpath/classpath-native.inc
new file mode 100644
index 0000000000..bb5abaf178
--- /dev/null
+++ b/packages/classpath/classpath-native.inc
@@ -0,0 +1,32 @@
+DESCRIPTION = "GNU Classpath standard Java libraries - For native Java-dependent programs"
+HOMEPAGE = "http://www.gnu.org/software/classpath/"
+LICENSE = "Classpath"
+
+S = "${WORKDIR}/classpath-${PV}"
+
+SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz"
+
+DEPENDS = "ecj-initial fastjar-native zip-native"
+
+inherit autotools native
+
+EXTRA_OECONF = "\
+ --with-glibj \
+ --with-ecj=${STAGING_BINDIR_NATIVE}/ecj-initial \
+ --with-fastjar=fastjar \
+ --enable-local-sockets \
+ --disable-alsa \
+ --disable-gconf-peer \
+ --disable-gtk-peer \
+ --disable-plugin \
+ --disable-dssi \
+ --enable-examples \
+ --enable-tools \
+ --includedir=${STAGING_INCDIR}/classpath \
+ --with-vm=java \
+ "
+
+do_stage() {
+ oe_runmake install
+}
+
diff --git a/packages/classpath/classpath-native_0.96.1.bb b/packages/classpath/classpath-native_0.96.1.bb
new file mode 100644
index 0000000000..e7d1d07a81
--- /dev/null
+++ b/packages/classpath/classpath-native_0.96.1.bb
@@ -0,0 +1,6 @@
+require classpath-native.inc
+
+PR = "r1"
+
+SRC_URI += "file://gjar-prefix-patch.diff;patch=1;pnum=0"
+
diff --git a/packages/classpath/classpath.inc b/packages/classpath/classpath.inc
index d9498c99d5..97c081af89 100644
--- a/packages/classpath/classpath.inc
+++ b/packages/classpath/classpath.inc
@@ -3,28 +3,62 @@ HOMEPAGE = "http://www.gnu.org/software/classpath/"
SECTION = "libs"
PRIORITY = "optional"
LICENSE = "Classpath"
-PROVIDES = "classpath"
-RPROVIDES = "classpath"
+PBN = "classpath"
-SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz \
- file://gconf_version.patch;patch=1 \
- file://fix-endian-arm-floats.patch;patch=1"
+DEPENDS = "virtual/javac-native fastjar-native zip-native"
+RPROVIDES = ""
+
+RDEPENDS_${PN} = "${PBN}-common (>= ${PV})"
+
+RPROVIDES_${PN} = "${PBN}"
+RPROVIDES_${PN}-gtk = "${PBN}-awt"
+
+SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz"
+
+S = "${WORKDIR}/${PBN}-${PV}"
+
+EXTRA_OECONF = "\
+ --with-glibj \
+ --with-ecj=javac \
+ --with-fastjar=fastjar \
+ --includedir=${includedir}/classpath \
+ --with-vm=java \
+ "
inherit autotools
do_stage() {
install -d ${STAGING_INCDIR}/classpath
- install -m 0755 include/jni* ${STAGING_INCDIR}/classpath/
+ install -m 0644 include/jni* ${STAGING_INCDIR}/classpath
+ install -m 0644 include/jni_md.h ${STAGING_INCDIR}/classpath/
+
+ install -d ${STAGING_DATADIR}/classpath
+ install -m 0644 lib/glibj.zip ${STAGING_DATADIR}/classpath
}
do_install() {
autotools_do_install
- mv ${D}${libdir}/security ${D}${libdir}/${PN}
+ mv ${D}${libdir}/security ${D}${libdir}/${PBN}
}
-PACKAGES =+ "classpath-common classpath-examples classpath-tools"
-FILES_classpath-common += "${datadir}/classpath/glibj.zip"
-FILES_classpath-examples += "${datadir}/classpath/examples"
-FILES_classpath-tools += "${datadir}/classpath/tools.zip ${datadir}/classpath/tools"
-FILES_classpath-dev += "${libdir}/*.so"
-FILES_classpath-dbg += "${libdir}/classpath/.debug"
+PACKAGES =+ "${PBN}-common ${PN}-examples \
+ ${PN}-tools ${PN}-tools-doc \
+ ${PN}-gtk ${PN}-gconf "
+
+FILES_${PN}-dev += "${libdir}/${PBN}/*.la ${incdir}/${PBN}"
+
+FILES_${PBN}-common = "${datadir}/${PBN}/glibj.zip ${libdir}/logging.properties ${libdir}/${PBN}/security"
+FILES_${PN}-examples = "${datadir}/${PBN}/examples"
+
+FILES_${PN}-tools = "${datadir}/${PBN}/tools.zip ${bindir}"
+FILES_${PN}-tools-doc = "${mandir}"
+
+FILES_${PN}-dbg += "${libdir}/${PBN}/.debug"
+FILES_${PN}-doc = "${infodir}"
+
+# gcjwebplugin - not built yet
+#FILES_${PN}-gcjwebplugin = "${libdir}/${PBN}/libgcjwebplugin.so"
+FILES_${PN}-gtk = "${libdir}/${PBN}/libgtkpeer.so ${libdir}/${PBN}/libjawt.so"
+FILES_${PN}-gconf = "${libdir}/${PBN}/libgconfpeer.so"
+FILES_${PN} = "${libdir}/${PBN}/lib*so*"
+
diff --git a/packages/classpath/classpath_0.14.bb b/packages/classpath/classpath_0.14.bb
deleted file mode 100644
index e4d73bbd3a..0000000000
--- a/packages/classpath/classpath_0.14.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-require classpath.inc
-
-DEPENDS = "glib-2.0 gtk+ libart-lgpl pango libxtst jikes-native zip-native"
-RDEPENDS_${PN} = "${PN}-common (${PV})"
-PR = "r2"
-
-SRC_URI = "${GNU_MIRROR}/${PN}/${P}.tar.gz \
- file://disable-automake-checks.patch;patch=1"
-
-EXTRA_OECONF = "--with-jikes"
diff --git a/packages/classpath/classpath_0.15.bb b/packages/classpath/classpath_0.15.bb
deleted file mode 100644
index e4d73bbd3a..0000000000
--- a/packages/classpath/classpath_0.15.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-require classpath.inc
-
-DEPENDS = "glib-2.0 gtk+ libart-lgpl pango libxtst jikes-native zip-native"
-RDEPENDS_${PN} = "${PN}-common (${PV})"
-PR = "r2"
-
-SRC_URI = "${GNU_MIRROR}/${PN}/${P}.tar.gz \
- file://disable-automake-checks.patch;patch=1"
-
-EXTRA_OECONF = "--with-jikes"
diff --git a/packages/classpath/classpath_0.17.bb b/packages/classpath/classpath_0.17.bb
deleted file mode 100644
index e4d73bbd3a..0000000000
--- a/packages/classpath/classpath_0.17.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-require classpath.inc
-
-DEPENDS = "glib-2.0 gtk+ libart-lgpl pango libxtst jikes-native zip-native"
-RDEPENDS_${PN} = "${PN}-common (${PV})"
-PR = "r2"
-
-SRC_URI = "${GNU_MIRROR}/${PN}/${P}.tar.gz \
- file://disable-automake-checks.patch;patch=1"
-
-EXTRA_OECONF = "--with-jikes"
diff --git a/packages/classpath/classpath_0.18.bb b/packages/classpath/classpath_0.18.bb
deleted file mode 100644
index 9b9e8c3451..0000000000
--- a/packages/classpath/classpath_0.18.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-require classpath.inc
-
-DEPENDS = "glib-2.0 gtk+ libart-lgpl pango libxtst jikes-native zip-native"
-RDEPENDS_${PN} = "${PN}-common (>= ${PV})"
-PR = "r1"
-
-SRC_URI = "${GNU_MIRROR}/${PN}/${P}.tar.gz \
- file://disable-automake-checks.patch;patch=1"
-
-EXTRA_OECONF = "--with-jikes"
diff --git a/packages/classpath/classpath_0.19.bb b/packages/classpath/classpath_0.19.bb
deleted file mode 100644
index 9b9e8c3451..0000000000
--- a/packages/classpath/classpath_0.19.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-require classpath.inc
-
-DEPENDS = "glib-2.0 gtk+ libart-lgpl pango libxtst jikes-native zip-native"
-RDEPENDS_${PN} = "${PN}-common (>= ${PV})"
-PR = "r1"
-
-SRC_URI = "${GNU_MIRROR}/${PN}/${P}.tar.gz \
- file://disable-automake-checks.patch;patch=1"
-
-EXTRA_OECONF = "--with-jikes"
diff --git a/packages/classpath/classpath_0.20.bb b/packages/classpath/classpath_0.20.bb
deleted file mode 100644
index 9b9e8c3451..0000000000
--- a/packages/classpath/classpath_0.20.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-require classpath.inc
-
-DEPENDS = "glib-2.0 gtk+ libart-lgpl pango libxtst jikes-native zip-native"
-RDEPENDS_${PN} = "${PN}-common (>= ${PV})"
-PR = "r1"
-
-SRC_URI = "${GNU_MIRROR}/${PN}/${P}.tar.gz \
- file://disable-automake-checks.patch;patch=1"
-
-EXTRA_OECONF = "--with-jikes"
diff --git a/packages/classpath/classpath_0.95.bb b/packages/classpath/classpath_0.95.bb
new file mode 100644
index 0000000000..6b167a2d47
--- /dev/null
+++ b/packages/classpath/classpath_0.95.bb
@@ -0,0 +1,20 @@
+require classpath.inc
+
+SRC_URI += "file://gjar-prefix-patch.diff;patch=1;pnum=0"
+
+PR = "r2"
+
+DEPENDS += "gtk+ gconf libxtst"
+
+EXTRA_OECONF += "\
+ --disable-alsa \
+ --disable-dssi \
+ --disable-qt4-peer \
+ --disable-plugin \
+ --enable-gconf-peer \
+ --enable-gtk-peer \
+ --enable-local-sockets \
+ --with-vm=java \
+ "
+
+
diff --git a/packages/classpath/classpath_0.96.1.bb b/packages/classpath/classpath_0.96.1.bb
new file mode 100644
index 0000000000..6b167a2d47
--- /dev/null
+++ b/packages/classpath/classpath_0.96.1.bb
@@ -0,0 +1,20 @@
+require classpath.inc
+
+SRC_URI += "file://gjar-prefix-patch.diff;patch=1;pnum=0"
+
+PR = "r2"
+
+DEPENDS += "gtk+ gconf libxtst"
+
+EXTRA_OECONF += "\
+ --disable-alsa \
+ --disable-dssi \
+ --disable-qt4-peer \
+ --disable-plugin \
+ --enable-gconf-peer \
+ --enable-gtk-peer \
+ --enable-local-sockets \
+ --with-vm=java \
+ "
+
+
diff --git a/packages/classpath/classpath_cvs.bb b/packages/classpath/classpath_cvs.bb
deleted file mode 100644
index 9e5ac2f000..0000000000
--- a/packages/classpath/classpath_cvs.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-DESCRIPTION = "GNU Classpath standard Java libraries"
-HOMEPAGE = "http://www.gnu.org/software/classpath/"
-LICENSE = "Classpath"
-PRIORITY = "optional"
-SECTION = "libs"
-PV = "0.20+cvs${SRCDATE}"
-
-DEFAULT_PREFERENCE = "-1"
-
-DEPENDS = "glib-2.0 gtk+ libart-lgpl pango libxtst jikes-native zip-native"
-RDEPENDS_${PN} = "${PN}-common (>= ${PV})"
-
-SRC_URI = "cvs://anoncvs@cvs.gnu.org/cvsroot/classpath;method=pserver;rsh=ssh;module=classpath \
- file://disable-automake-checks.patch;patch=1"
-S = "${WORKDIR}/classpath"
-
-inherit autotools
-
-EXTRA_OECONF = "--with-jikes"
-
-PACKAGES += " ${PN}-common ${PN}-examples"
-
-FILES_${PN} = "${libdir}/${PN}"
-FILES_${PN}-common = "${datadir}/${PN}/glibj.zip"
-FILES_${PN}-examples = "${datadir}/${PN}/examples"
-
-do_stage() {
- install -d ${STAGING_INCDIR}/classpath
- install -m 0755 include/jni* ${STAGING_INCDIR}/classpath/
-}
-
-do_install() {
- autotools_do_install
- mv ${D}${libdir}/security ${D}${libdir}/${PN}
-}
diff --git a/packages/classpath/files/disable-automake-checks-v2.patch b/packages/classpath/files/disable-automake-checks-v2.patch
deleted file mode 100644
index 0c1df1acae..0000000000
--- a/packages/classpath/files/disable-automake-checks-v2.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- sablevm-classpath-1.1.7/configure.ac.orig 2004-11-26 00:23:01.000000000 +0100
-+++ sablevm-classpath-1.1.7/configure.ac 2004-11-26 00:23:46.000000000 +0100
-@@ -34,7 +34,7 @@
- AC_SUBST(CLASSPATH_MODULE)
-
- AC_PREREQ(2.59)
--AM_INIT_AUTOMAKE([1.9.0 gnu std-options tar-ustar -Wno-portability])
-+AM_INIT_AUTOMAKE
- AC_CONFIG_HEADERS([include/config.h])
- AC_PREFIX_DEFAULT(/usr/local)
-
diff --git a/packages/classpath/files/disable-automake-checks.patch b/packages/classpath/files/disable-automake-checks.patch
deleted file mode 100644
index d6a55428ad..0000000000
--- a/packages/classpath/files/disable-automake-checks.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- sablevm-classpath-1.1.7/configure.ac.orig 2004-11-26 00:23:01.000000000 +0100
-+++ sablevm-classpath-1.1.7/configure.ac 2004-11-26 00:23:46.000000000 +0100
-@@ -34,7 +34,7 @@
- AC_SUBST(CLASSPATH_MODULE)
-
- AC_PREREQ(2.59)
--AM_INIT_AUTOMAKE([1.9.0 gnu std-options tar-ustar])
-+AM_INIT_AUTOMAKE
- AC_CONFIG_HEADERS([include/config.h])
- AC_PREFIX_DEFAULT(/usr/local)
-
diff --git a/packages/classpath/files/fix-endian-arm-floats.patch b/packages/classpath/files/fix-endian-arm-floats.patch
deleted file mode 100644
index a9af0611b2..0000000000
--- a/packages/classpath/files/fix-endian-arm-floats.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- classpath/native/fdlibm/ieeefp.h.orig 2006-04-14 22:33:09.000000000 -0400
-+++ classpath/native/fdlibm/ieeefp.h 2006-04-14 22:41:46.000000000 -0400
-@@ -13,7 +13,7 @@
- byte ordering was big or little endian depending upon the target.
- Modern floating-point formats are naturally ordered; in this case
- __VFP_FP__ will be defined, even if soft-float. */
--#ifdef __VFP_FP__
-+#ifdef __SOFTFP__
- #ifdef __ARMEL__
- #define __IEEE_LITTLE_ENDIAN
- #else
diff --git a/packages/classpath/files/gconf_version.patch b/packages/classpath/files/gconf_version.patch
deleted file mode 100644
index b1be1209a2..0000000000
--- a/packages/classpath/files/gconf_version.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- classpath-0.93/configure.ac~ 2007-03-29 15:52:30.000000000 -0500
-+++ classpath-0.93/configure.ac 2007-03-29 15:52:30.000000000 -0500
-@@ -496,7 +496,7 @@
-
- dnl gconf-peer
- if test "x${COMPILE_GCONF_PEER}" = xyes; then
-- PKG_CHECK_MODULES(GCONF, gconf-2.0 >= 2.11.2)
-+ PKG_CHECK_MODULES(GCONF, gconf-2.0 >= 2.6.0)
- AC_SUBST(GCONF_CFLAGS)
- AC_SUBST(GCONF_LIBS)
- dnl we also need gdk for locking
diff --git a/packages/classpath/files/gjar-prefix-patch.diff b/packages/classpath/files/gjar-prefix-patch.diff
new file mode 100644
index 0000000000..64b262cb41
--- /dev/null
+++ b/packages/classpath/files/gjar-prefix-patch.diff
@@ -0,0 +1,40 @@
+Index: tools/gnu/classpath/tools/jar/Entry.java
+===================================================================
+RCS file: /sources/classpath/classpath/tools/gnu/classpath/tools/jar/Entry.java,v
+retrieving revision 1.1
+diff -u -r1.1 Entry.java
+--- tools/gnu/classpath/tools/jar/Entry.java 8 May 2006 18:38:20 -0000 1.1
++++ tools/gnu/classpath/tools/jar/Entry.java 10 Dec 2007 22:20:05 -0000
+@@ -1,5 +1,5 @@
+ /* Entry.java - represent a single file to write to a jar
+- Copyright (C) 2006 Free Software Foundation, Inc.
++ Copyright (C) 2006, 2007 Free Software Foundation, Inc.
+
+ This file is part of GNU Classpath.
+
+@@ -49,12 +49,22 @@
+ public Entry(File file, String name)
+ {
+ this.file = file;
+- this.name = name;
++
++ /* Removes any './' prefixes automatically. Those caused trouble
++ * in (boot) classpath use-cases. See #32516.
++ */
++ int start = 0;
++ while (name.length() > start + 2
++ && name.codePointAt(start) == '.'
++ && name.codePointAt(start + 1) == File.separatorChar)
++ start += 2;
++
++ this.name = name.substring(start);
+ }
+
+ public Entry(File file)
+ {
+- this.file = file;
+- this.name = file.toString();
++ this(file, file.toString());
+ }
++
+ }