aboutsummaryrefslogtreecommitdiffstats
path: root/packages/coreutils/coreutils-5.1.3
diff options
context:
space:
mode:
Diffstat (limited to 'packages/coreutils/coreutils-5.1.3')
-rw-r--r--packages/coreutils/coreutils-5.1.3/.mtn2git_empty0
-rw-r--r--packages/coreutils/coreutils-5.1.3/install-cross.patch27
-rw-r--r--packages/coreutils/coreutils-5.1.3/man.patch42
3 files changed, 69 insertions, 0 deletions
diff --git a/packages/coreutils/coreutils-5.1.3/.mtn2git_empty b/packages/coreutils/coreutils-5.1.3/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/coreutils/coreutils-5.1.3/.mtn2git_empty
diff --git a/packages/coreutils/coreutils-5.1.3/install-cross.patch b/packages/coreutils/coreutils-5.1.3/install-cross.patch
index e69de29bb2..98ba3d916c 100644
--- a/packages/coreutils/coreutils-5.1.3/install-cross.patch
+++ b/packages/coreutils/coreutils-5.1.3/install-cross.patch
@@ -0,0 +1,27 @@
+--- src/install.c~ 2003-08-09 18:46:45.000000000 +0100
++++ src/install.c 2004-03-27 18:38:45.000000000 +0000
+@@ -516,7 +516,14 @@
+ strip (const char *path)
+ {
+ int status;
+- pid_t pid = fork ();
++ pid_t pid;
++ char *strip_name;
++
++ strip_name = getenv ("STRIP");
++ if (strip_name == NULL)
++ strip_name = "strip";
++
++ pid = fork ();
+
+ switch (pid)
+ {
+@@ -524,7 +531,7 @@
+ error (EXIT_FAILURE, errno, _("fork system call failed"));
+ break;
+ case 0: /* Child. */
+- execlp ("strip", "strip", path, NULL);
++ execlp (strip_name, "strip", path, NULL);
+ error (EXIT_FAILURE, errno, _("cannot run strip"));
+ break;
+ default: /* Parent. */
diff --git a/packages/coreutils/coreutils-5.1.3/man.patch b/packages/coreutils/coreutils-5.1.3/man.patch
index e69de29bb2..b067c380e2 100644
--- a/packages/coreutils/coreutils-5.1.3/man.patch
+++ b/packages/coreutils/coreutils-5.1.3/man.patch
@@ -0,0 +1,42 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- coreutils-5.1.3/configure.ac~man 2004-01-25 16:57:15.000000000 -0600
++++ coreutils-5.1.3/configure.ac 2004-06-29 14:22:10.000000000 -0500
+@@ -232,6 +232,20 @@
+ AM_GNU_GETTEXT([external], [need-ngettext])
+ AM_GNU_GETTEXT_VERSION(0.13.1)
+
++AC_MSG_CHECKING([whether to build man pages])
++AC_ARG_WITH(manpages,
++ AS_HELP_STRING([--with-manpages],
++ [Enable building of manpages (default=yes)]),
++ [cu_cv_build_manpages=$enableval],
++ [cu_cv_build_manpages=yes])
++# help2man doesn't work when crosscompiling, as it needs to run the
++# binary that was built.
++if test x"$cross_compiling" = x"yes"; then
++ cu_cv_build_manpages=no
++fi
++AC_MSG_RESULT($cu_cv_build_manpages)
++AM_CONDITIONAL(ENABLE_MANPAGES, test x"$cu_cv_build_manpages" = x"yes")
++
+ AC_CONFIG_FILES(
+ Makefile
+ doc/Makefile
+--- coreutils-5.1.3/Makefile.am~man 2003-11-09 14:23:02.000000000 -0600
++++ coreutils-5.1.3/Makefile.am 2004-06-29 14:18:14.000000000 -0500
+@@ -1,6 +1,11 @@
+ ## Process this file with automake to produce Makefile.in -*-Makefile-*-
+
++if ENABLE_MANPAGES
+ SUBDIRS = lib src doc man m4 po tests
++else
++SUBDIRS = lib src doc m4 po tests
++endif
++
+ EXTRA_DIST = Makefile.cfg Makefile.maint GNUmakefile \
+ .kludge-stamp .prev-version THANKS-to-translators THANKStt.in \
+ .x-sc_space_tab .x-sc_sun_os_names \