aboutsummaryrefslogtreecommitdiffstats
path: root/packages/db
diff options
context:
space:
mode:
Diffstat (limited to 'packages/db')
-rw-r--r--packages/db/.mtn2git_empty0
-rw-r--r--packages/db/db3-3.2.9/.mtn2git_empty0
-rw-r--r--packages/db/db3-3.2.9/autofoo.patch71
-rw-r--r--packages/db/db3-native_3.2.9.bb6
-rw-r--r--packages/db/db_4.3.27.bb89
5 files changed, 166 insertions, 0 deletions
diff --git a/packages/db/.mtn2git_empty b/packages/db/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/db/.mtn2git_empty
diff --git a/packages/db/db3-3.2.9/.mtn2git_empty b/packages/db/db3-3.2.9/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/db/db3-3.2.9/.mtn2git_empty
diff --git a/packages/db/db3-3.2.9/autofoo.patch b/packages/db/db3-3.2.9/autofoo.patch
index e69de29bb2..d385b95722 100644
--- a/packages/db/db3-3.2.9/autofoo.patch
+++ b/packages/db/db3-3.2.9/autofoo.patch
@@ -0,0 +1,71 @@
+--- dist/Makefile.in 2000-11-30 17:07:33.000000000 -0600
++++ dist/Makefile.in 2004-09-01 19:47:37.000000000 -0500
+@@ -2,6 +2,7 @@
+
+ srcdir= @srcdir@/..
+ builddir=.
++top_builddir=.
+
+ ##################################################
+ # C, C++
+--- dist/configure.in 2001-01-19 11:36:43.000000000 -0600
++++ dist/configure.in 2004-09-01 19:45:35.000000000 -0500
+@@ -38,7 +38,6 @@
+ AC_SUBST(LIBJSO_LIBS)
+ AC_SUBST(LIBS)
+ AC_SUBST(LIBSO_LIBS)
+-AC_SUBST(LIBTOOL)
+ AC_SUBST(LIBTSO_LIBS)
+ AC_SUBST(LIBXSO_LIBS)
+ AC_SUBST(MAKEFILE_CC)
+@@ -48,7 +47,6 @@
+ AC_SUBST(RPC_OBJS)
+ AC_SUBST(SOFLAGS)
+ AC_SUBST(SOLINK)
+-AC_SUBST(SOSUFFIX)
+
+ dnl $o is set to ".o" or ".lo", and is the file suffix used in the
+ dnl Makefile instead of .o
+@@ -205,27 +203,15 @@
+ dnl Dynamic library and libtool configuration; optional, but required for
+ dnl Tcl or Java support.
+ LIBDB_ARGS="libdb.a"
+-LIBTOOL="nolibtool"
+ POSTLINK="@true"
+-SOSUFFIX="so"
+ if test "$db_cv_dynamic" = "yes"; then
++ AM_PROG_LIBTOOL
+ SAVE_CC="${MAKEFILE_CC}"
+ SAVE_CXX="${MAKEFILE_CXX}"
+
+- # Configure libtool.
+- AC_MSG_CHECKING(libtool configuration)
+- AC_MSG_RESULT([])
+- ${CONFIG_SHELL-/bin/sh} $srcdir/ltconfig \
+- --no-verify $srcdir/ltmain.sh \
+- --output=./libtool $host_os \
+- --disable-static \
+- || AC_MSG_ERROR([libtool configure failed])
+-
+- SOSUFFIX=`sed -e '/^library_names_spec=/!d' -e 's/.*\.\([[a-zA-Z0-9_]]*\).*/\1/' ./libtool`
+ DEFAULT_LIB="\$(libso_target)"
+ DEFAULT_INSTALL="install_dynamic"
+ LIBDB_ARGS="\$(libso_linkname)"
+- LIBTOOL="\$(SHELL) ./libtool"
+
+ MAKEFILE_CC="\$(LIBTOOL) --mode=compile ${SAVE_CC}"
+ MAKEFILE_CXX="\$(LIBTOOL) --mode=compile ${SAVE_CXX}"
+@@ -373,13 +359,6 @@
+ AC_REPLACE_FUNCS(getcwd getopt memcmp memcpy memmove)
+ AC_REPLACE_FUNCS(raise snprintf strcasecmp strerror vsnprintf)
+
+-dnl XXX
+-dnl Nasty hack. AC_REPLACE_FUNCS added entries of the form xxx.o to the
+-dnl LIBOBJS variable. They have to be xxx.lo if we are building shared
+-dnl libraries. Use sed, configure already requires it.
+-tmp="`echo \"$LIBOBJS\" | sed \"s/\.o/${o}/g\"`"
+-LIBOBJS="$tmp"
+-
+ dnl Check for system functions we optionally use.
+ AC_CHECK_FUNCS(getuid pstat_getdynamic sysconf sched_yield strtoul yield)
+
diff --git a/packages/db/db3-native_3.2.9.bb b/packages/db/db3-native_3.2.9.bb
index e69de29bb2..13c6063669 100644
--- a/packages/db/db3-native_3.2.9.bb
+++ b/packages/db/db3-native_3.2.9.bb
@@ -0,0 +1,6 @@
+SECTION = "libs"
+inherit native
+include db3_${PV}.bb
+
+FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/db3-${PV}', '${FILE_DIRNAME}/db3', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
+PACKAGES = ""
diff --git a/packages/db/db_4.3.27.bb b/packages/db/db_4.3.27.bb
index e69de29bb2..3a233dcff1 100644
--- a/packages/db/db_4.3.27.bb
+++ b/packages/db/db_4.3.27.bb
@@ -0,0 +1,89 @@
+# Version 4 of the Berkeley DB from Sleepycat
+#
+# At present this package only installs the DB code
+# itself (shared libraries, .a in the dev package),
+# documentation and headers.
+#
+# The headers have the same names as those as v3
+# of the DB, only one version can be used *for dev*
+# at once - DB3 and DB4 can both be installed on the
+# same system at the same time if really necessary.
+SECTION = "libs"
+DESCRIPTION = "Berkeley DB v4."
+HOMEPAGE = "http://www.sleepycat.com"
+LICENSE = "BSD Sleepycat"
+PR = "r1"
+
+SRC_URI = "http://downloads.sleepycat.com/${P}.tar.gz"
+
+inherit autotools
+
+# At present virtual/db is only in the db4 file, but it
+# should probably be in the other candidates (db3, gdbm)
+# because it doesn't make any sense to have multiple
+# relational databases on an embedded machine...
+PROVIDES += " db4 virtual/db"
+
+# bitbake isn't quite clever enough to deal with sleepycat,
+# the distribution sits in the expected directory, but all
+# the builds must occur from a sub-directory. The following
+# persuades bitbake to go to the right place
+S = "${WORKDIR}/${P}/build_unix"
+
+# The executables go in a separate package - typically there
+# is no need to install these unless doing real database
+# management on the system.
+PACKAGES += " ${PN}-bin"
+
+# Package contents
+FILES_${PN} = "${libdir}/libdb-4*so*"
+FILES_${PN}-bin = "${bindir}"
+# The dev package has the .so link (as in db3) and the .a's -
+# it is therefore incompatible (cannot be installed at the
+# same time) as the db3 package
+FILES_${PN}-dev = "${includedir} ${libdir}"
+
+#configuration - set in local.conf to override
+DB4_CONFIG ?= "--enable-o_direct --enable-smallbuild"
+# Override the MUTEX setting here, the POSIX library is
+# the default - "POSIX/pthreads/library".
+# Don't ignore the nice SWP instruction on the ARM:
+EXTRA_OECONF = "${DB4_CONFIG}"
+EXTRA_OECONF_nslu2 = "${DB4_CONFIG} --with-mutex=ARM/gcc-assembly"
+
+# Cancel the site stuff - it's set for db3 and destroys the
+# configure.
+CONFIG_SITE = ""
+do_configure() {
+ echo '#!/bin/sh' >${S}/configure
+ echo 'rm ${S}/configure' >>${S}/configure
+ echo 'exec ../dist/configure "$@"' >>${S}/configure
+ chmod a+x ${S}/configure
+ oe_runconf
+}
+
+do_stage() {
+ # The .h files get installed read-only, the autostage
+ # function just uses cp -a, so do this by hand
+ # Install, for the moment, into include/db4 to avoid
+ # interfering with the db3 headers (which have the same
+ # name). -I${STAGING_INCDIR}/db4 to use db4, as opposed
+ # to db3.
+ rm -rf ${STAGE_TEMP}
+ mkdir -p ${STAGE_TEMP}
+ oe_runmake DESTDIR="${STAGE_TEMP}" install_include
+ mkdir -p ${STAGING_INCDIR}/db4
+ cp -af ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}/db4
+ rm -rf ${STAGE_TEMP}
+ oe_libinstall -so -C .libs libdb-4.3 ${STAGING_LIBDIR}
+}
+
+do_install_append() {
+ # The docs end up in /usr/docs - not right.
+ if test -d "${D}/${prefix}/docs"
+ then
+ mkdir -p "${D}/${datadir}"
+ test ! -d "${D}/${docdir}" || rmdir "${D}/${docdir}"
+ mv "${D}/${prefix}/docs" "${D}/${docdir}"
+ fi
+}