aboutsummaryrefslogtreecommitdiffstats
path: root/packages/devio/devio_r1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/devio/devio_r1.bb')
-rw-r--r--packages/devio/devio_r1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/devio/devio_r1.bb b/packages/devio/devio_r1.bb
index e69de29bb2..4dc70b2311 100644
--- a/packages/devio/devio_r1.bb
+++ b/packages/devio/devio_r1.bb
@@ -0,0 +1,25 @@
+# This package builds the devio program
+PR = "r0"
+DESCRIPTION = "devio - block devio io"
+HOMEPAGE = "http://devio.sourceforge.net/"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "base"
+LICENSE = "MIT"
+
+SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/devio;method=pserver;module=devio;tag=${PV}"
+# This accesses the head version, anonymous pserver access is
+# only updated once per day (and it is necessary to change
+# 'jbowler' to the name of a developer with ssh access.)
+#SRC_URI = "cvs://jbowler@cvs.sourceforge.net/cvsroot/devio;method=ext;rsh=ssh;tag=HEAD;module=devio"
+
+# The source will end up in the subdirectory 'devio' - no release name
+S = "${WORKDIR}/devio"
+
+# Just the one package at present
+PACKAGES = "${PN}"
+
+# Set the install dir to /sbin, not /usr/sbin, because devio is used
+# during bootstrap (we want it to be posible to mount /usr separately)
+sbindir = "/sbin"
+
+inherit autotools