aboutsummaryrefslogtreecommitdiffstats
path: root/packages/e17/entrance_20050810.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/e17/entrance_20050810.bb')
-rw-r--r--packages/e17/entrance_20050810.bb23
1 files changed, 18 insertions, 5 deletions
diff --git a/packages/e17/entrance_20050810.bb b/packages/e17/entrance_20050810.bb
index 251698c233..de00734985 100644
--- a/packages/e17/entrance_20050810.bb
+++ b/packages/e17/entrance_20050810.bb
@@ -2,18 +2,21 @@ DESCRIPTION = "Entrace is the Enlightenment login manager"
SECTION = "e/apps"
LICENSE = "MIT"
# can also use pam and crypt
-DEPENDS = "edb evas-x11 ecore-x11 edje esmart"
-RDEPENDS += "bash"
+DEPENDS = "edb evas-x11 ecore-x11 edje esmart gpe-dm"
+RDEPENDS += "bash gpe-dm"
HOMEPAGE = "http://www.enlightenment.org"
MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
CVSDATE = "${PV}"
-PR = "r0"
+PR = "r1"
SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/enlightenment;module=e17/apps/entrance \
file://longer-sleep.patch;patch=1 \
file://Xserver.patch;patch=1 \
file://config-db.patch;patch=1 \
- file://allow-missing-xsession.patch;patch=1"
+ file://allow-missing-xsession.patch;patch=1 \
+ file://Xinit.d \
+ file://Sessions"
+
S = "${WORKDIR}/entrance"
inherit autotools
@@ -21,4 +24,14 @@ inherit autotools
EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc \
--with-xsession=/etc/X11/Xsession"
-FILES += "${datadir}" \ No newline at end of file
+FILES += "${datadir}"
+
+do_install_append() {
+ install -d ${D}/etc/X11/Xinit.d
+ install -d ${D}/etc/X11/Xsession.d
+ install -d ${D}/etc/X11/Sessions
+
+ install -m 755 ${WORKDIR}/Xinit.d/* ${D}/etc/X11/Xinit.d
+ install -m 755 ${WORKDIR}/Sessions/* ${D}/etc/X11/Sessions
+
+}