aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ebtables/ebtables-2.0.6
diff options
context:
space:
mode:
Diffstat (limited to 'packages/ebtables/ebtables-2.0.6')
-rw-r--r--packages/ebtables/ebtables-2.0.6/.mtn2git_empty0
-rw-r--r--packages/ebtables/ebtables-2.0.6/gcc34.patch16
-rw-r--r--packages/ebtables/ebtables-2.0.6/installcreatedirs.patch25
-rw-r--r--packages/ebtables/ebtables-2.0.6/installnonroot.patch55
4 files changed, 96 insertions, 0 deletions
diff --git a/packages/ebtables/ebtables-2.0.6/.mtn2git_empty b/packages/ebtables/ebtables-2.0.6/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ebtables/ebtables-2.0.6/.mtn2git_empty
diff --git a/packages/ebtables/ebtables-2.0.6/gcc34.patch b/packages/ebtables/ebtables-2.0.6/gcc34.patch
index e69de29bb2..c5d341e225 100644
--- a/packages/ebtables/ebtables-2.0.6/gcc34.patch
+++ b/packages/ebtables/ebtables-2.0.6/gcc34.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- ebtables-v2.0.6/ebtables.c~gcc34 2003-11-02 12:22:56.000000000 -0600
++++ ebtables-v2.0.6/ebtables.c 2004-06-03 13:27:28.000000000 -0500
+@@ -1170,7 +1170,7 @@
+ if (!t->compare(t->t, u_e->t))
+ continue;
+ return i;
+-letscontinue:
++letscontinue:;
+ }
+ return -1;
+ }
diff --git a/packages/ebtables/ebtables-2.0.6/installcreatedirs.patch b/packages/ebtables/ebtables-2.0.6/installcreatedirs.patch
index e69de29bb2..86bc4f0a44 100644
--- a/packages/ebtables/ebtables-2.0.6/installcreatedirs.patch
+++ b/packages/ebtables/ebtables-2.0.6/installcreatedirs.patch
@@ -0,0 +1,25 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- ebtables-v2.0.6/Makefile~installcreatedirs 2004-06-03 13:34:17.000000000 -0500
++++ ebtables-v2.0.6/Makefile 2004-06-03 13:35:21.000000000 -0500
+@@ -47,14 +47,17 @@
+
+ $(MANDIR)/man8/ebtables.8: ebtables.8
+ mkdir -p $(@D)
++ install -d $(MANDIR)/man8
+ install -m 0644 $(INSTALLOWN) $< $@
+
+ $(ETHERTYPESFILE): ethertypes
+ mkdir -p $(@D)
++ install -d $(ETHERTYPESPATH)
+ install -m 0644 $(INSTALLOWN) $< $@
+
+ .PHONY: exec
+ exec: ebtables
++ install -d $(BINPATH)
+ install -m 0755 $(INSTALLOWN) $< $(BINFILE)
+
+ .PHONY: install
diff --git a/packages/ebtables/ebtables-2.0.6/installnonroot.patch b/packages/ebtables/ebtables-2.0.6/installnonroot.patch
index e69de29bb2..0211e62364 100644
--- a/packages/ebtables/ebtables-2.0.6/installnonroot.patch
+++ b/packages/ebtables/ebtables-2.0.6/installnonroot.patch
@@ -0,0 +1,55 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- ebtables-v2.0.6/Makefile~installnonroot 2003-11-02 12:22:56.000000000 -0600
++++ ebtables-v2.0.6/Makefile 2004-06-03 13:34:17.000000000 -0500
+@@ -7,6 +7,7 @@
+ MANDIR?=/usr/local/man
+ CFLAGS:=-Wall -Wunused
+ CC:=gcc
++INSTALLOWN=$(if $(filter 0,$(shell id -u)),-o root -g root)
+
+ ifeq ($(shell uname -m),sparc64)
+ CFLAGS+=-DEBT_MIN_ALIGN=8 -DKERNEL_64_USERSPACE_32
+@@ -46,15 +47,15 @@
+
+ $(MANDIR)/man8/ebtables.8: ebtables.8
+ mkdir -p $(@D)
+- install -m 0644 -o root -g root $< $@
++ install -m 0644 $(INSTALLOWN) $< $@
+
+ $(ETHERTYPESFILE): ethertypes
+ mkdir -p $(@D)
+- install -m 0644 -o root -g root $< $@
++ install -m 0644 $(INSTALLOWN) $< $@
+
+ .PHONY: exec
+ exec: ebtables
+- install -m 0755 -o root -g root $< $(BINFILE)
++ install -m 0755 $(INSTALLOWN) $< $(BINFILE)
+
+ .PHONY: install
+ install: $(MANDIR)/man8/ebtables.8 $(ETHERTYPESFILE) exec
+@@ -70,16 +71,16 @@
+ .PHONY: release
+ release:
+ mkdir -p include/linux/netfilter_bridge
+- install -m 0644 -o root -g root \
++ install -m 0644 $(INSTALLOWN) \
+ $(KERNEL_INCLUDES)/linux/netfilter_bridge.h include/linux/
+ # To keep possible compile error complaints about undefined ETH_P_8021Q
+ # off my back
+- install -m 0644 -o root -g root \
++ install -m 0644 $(INSTALLOWN) \
+ $(KERNEL_INCLUDES)/linux/if_ether.h include/linux/
+- install -m 0644 -o root -g root \
++ install -m 0644 $(INSTALLOWN) \
+ $(KERNEL_INCLUDES)/linux/netfilter_bridge/*.h \
+ include/linux/netfilter_bridge/
+- install -m 0644 -o root -g root \
++ install -m 0644 $(INSTALLOWN) \
+ include/ebtables.h include/linux/netfilter_bridge/
+ make clean
+ touch *