aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ecore/ecore-native_cvs.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/ecore/ecore-native_cvs.bb')
-rw-r--r--packages/ecore/ecore-native_cvs.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/packages/ecore/ecore-native_cvs.bb b/packages/ecore/ecore-native_cvs.bb
index e69de29bb2..6e5e1d1413 100644
--- a/packages/ecore/ecore-native_cvs.bb
+++ b/packages/ecore/ecore-native_cvs.bb
@@ -0,0 +1,14 @@
+include ecore_${PV}.bb
+LICENSE = "MIT"
+inherit native
+DEPENDS = "edb-native eet-native evas-native freetype-native"
+
+do_stage () {
+ for p in ${parts}; do
+ dir=`echo $p|tr A-Z a-z`
+ install -m 0644 ${S}/src/lib/$dir/$p.h ${STAGING_INCDIR}/
+ oe_libinstall -C src/lib/$dir lib$dir ${STAGING_LIBDIR}/
+ done
+ install -m 0644 ${S}/src/lib/ecore/Ecore_Data.h ${STAGING_INCDIR}/
+ install -m 0644 ${S}/ecore.m4 ${STAGING_DATADIR}/aclocal/
+}