aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ethload
diff options
context:
space:
mode:
Diffstat (limited to 'packages/ethload')
-rw-r--r--packages/ethload/.mtn2git_empty0
-rw-r--r--packages/ethload/ethload-native_1.2.bb7
-rw-r--r--packages/ethload/ethload_1.2.bb11
3 files changed, 18 insertions, 0 deletions
diff --git a/packages/ethload/.mtn2git_empty b/packages/ethload/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ethload/.mtn2git_empty
diff --git a/packages/ethload/ethload-native_1.2.bb b/packages/ethload/ethload-native_1.2.bb
index e69de29bb2..777868006a 100644
--- a/packages/ethload/ethload-native_1.2.bb
+++ b/packages/ethload/ethload-native_1.2.bb
@@ -0,0 +1,7 @@
+SECTION = "console/network"
+include ethload_${PV}.bb
+inherit native
+
+do_stage() {
+ install -m 0755 ethload ${STAGING_BINDIR}
+}
diff --git a/packages/ethload/ethload_1.2.bb b/packages/ethload/ethload_1.2.bb
index e69de29bb2..f65dd8bad9 100644
--- a/packages/ethload/ethload_1.2.bb
+++ b/packages/ethload/ethload_1.2.bb
@@ -0,0 +1,11 @@
+SECTION = "console/network"
+DESCRIPTION = "Ethload for Linux is a tool to send ROM images over ethernet using tftp."
+LICENSE = "GPL"
+SRC_URI = "http://ludovic.lange.free.fr/CETools/ethload-${PV}.tar.gz"
+S = "${WORKDIR}/ethload-${PV}"
+
+inherit autotools
+
+do_configure() {
+ oe_runconf
+}