aboutsummaryrefslogtreecommitdiffstats
path: root/packages/freetype/files/configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/freetype/files/configure.patch')
-rw-r--r--packages/freetype/files/configure.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/packages/freetype/files/configure.patch b/packages/freetype/files/configure.patch
index e69de29bb2..f11cf96be0 100644
--- a/packages/freetype/files/configure.patch
+++ b/packages/freetype/files/configure.patch
@@ -0,0 +1,47 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+Index: freetype-2.1.8/builds/unix/configure.ac
+===================================================================
+--- freetype-2.1.8.orig/builds/unix/configure.ac 2004-04-14 04:49:11.000000000 -0400
++++ freetype-2.1.8/builds/unix/configure.ac 2005-03-12 03:14:23.000000000 -0500
+@@ -111,8 +111,8 @@
+ # Check for system zlib
+
+ AC_ARG_WITH([zlib],
+- dnl don't quote AS_HELP_STRING!
+- AS_HELP_STRING([--without-zlib],
++ dnl don't quote AC_HELP_STRING!
++ AC_HELP_STRING([--without-zlib],
+ [use internal zlib instead of system-wide]))
+ if test x$with_zlib != xno && test -z "$LIBZ"; then
+ AC_CHECK_LIB([z], [gzsetparams], [AC_CHECK_HEADER([zlib.h], [LIBZ='-lz'])])
+@@ -127,7 +127,7 @@
+ # Whether to use Mac OS resource-based fonts or not
+
+ AC_ARG_WITH([old-mac-fonts],
+- dnl don't quote AS_HELP_STRING!
+- AS_HELP_STRING([--with-old-mac-fonts],
++ dnl don't quote AC_HELP_STRING!
++ AC_HELP_STRING([--with-old-mac-fonts],
+ [allow Mac resource-based fonts to be used]))
+ if test x$with_old_mac_fonts = xyes; then
+Index: freetype-2.1.8/builds/unix/unix-cc.in
+===================================================================
+--- freetype-2.1.8.orig/builds/unix/unix-cc.in 2003-11-09 03:37:13.000000000 -0500
++++ freetype-2.1.8/builds/unix/unix-cc.in 2005-03-12 18:37:24.613693760 -0500
+@@ -14,9 +14,11 @@
+
+ CC := @CC@
+ COMPILER_SEP := $(SEP)
++SHELL := @SHELL@
++top_builddir := $(BUILD_DIR)
+
+ ifndef LIBTOOL
+- LIBTOOL := $(BUILD_DIR)/libtool
++ LIBTOOL := @LIBTOOL@
+ endif
+
+