aboutsummaryrefslogtreecommitdiffstats
path: root/packages/frotz/files
diff options
context:
space:
mode:
Diffstat (limited to 'packages/frotz/files')
-rw-r--r--packages/frotz/files/.mtn2git_empty0
-rw-r--r--packages/frotz/files/Makefile-2.43.patch29
-rw-r--r--packages/frotz/files/Makefile.patch12
-rw-r--r--packages/frotz/files/remove_root_restriction.patch18
4 files changed, 59 insertions, 0 deletions
diff --git a/packages/frotz/files/.mtn2git_empty b/packages/frotz/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/frotz/files/.mtn2git_empty
diff --git a/packages/frotz/files/Makefile-2.43.patch b/packages/frotz/files/Makefile-2.43.patch
index e69de29bb2..7df2576ef1 100644
--- a/packages/frotz/files/Makefile-2.43.patch
+++ b/packages/frotz/files/Makefile-2.43.patch
@@ -0,0 +1,29 @@
+--- ./Makefile 2002-10-27 18:21:52.000000000 -0700
++++ ./Makefile-2.43.patch 2004-09-11 09:33:35.000000000 -0700
+@@ -73,15 +73,15 @@
+ # curses library won't work, comment out the first option and uncomment
+ # the second.
+ #
+-CURSES = -lcurses
+-#CURSES = -lncurses
++# CURSES = -lcurses
++CURSES = -lncurses
+
+ # Uncomment this if your need to use ncurses instead of the
+ # vendor-supplied curses library. This just tells the compile process
+ # which header to include, so don't worry if ncurses is all you have
+ # (like on Linux). You'll be fine.
+ #
+-#CURSES_DEF = -DUSE_NCURSES_H
++CURSES_DEF = -DUSE_NCURSES_H
+
+ # Uncomment this if you're compiling Unix Frotz on a machine that lacks
+ # the memmove(3) system call. If you don't know what this means, leave it
+@@ -213,7 +213,6 @@
+ fi
+
+ install: $(NAME)
+- strip $(BINNAME)$(EXTENSION)
+ install -d $(PREFIX)/bin
+ install -d $(MAN_PREFIX)/man/man6
+ install -c -m 755 $(BINNAME)$(EXTENSION) $(PREFIX)/bin
diff --git a/packages/frotz/files/Makefile.patch b/packages/frotz/files/Makefile.patch
index e69de29bb2..4486c127bd 100644
--- a/packages/frotz/files/Makefile.patch
+++ b/packages/frotz/files/Makefile.patch
@@ -0,0 +1,12 @@
+*** ./Makefile Sat Mar 9 17:24:16 2002
+--- ./Makefile.patch Tue Aug 3 10:30:33 2004
+***************
+*** 123,129 ****
+ install: $(BINNAME)
+ install -d $(PREFIX)/bin
+ install -d $(MAN_PREFIX)/man/man6
+- strip $(BINNAME)$(EXTENSION)
+ install -c -m 755 $(BINNAME)$(EXTENSION) $(PREFIX)/bin
+ install -c -m 644 $(BINNAME).6 $(MAN_PREFIX)/man/man6
+
+--- 123,128 ----
diff --git a/packages/frotz/files/remove_root_restriction.patch b/packages/frotz/files/remove_root_restriction.patch
index e69de29bb2..f2be13dec2 100644
--- a/packages/frotz/files/remove_root_restriction.patch
+++ b/packages/frotz/files/remove_root_restriction.patch
@@ -0,0 +1,18 @@
+--- ./src/curses/ux_init.c 2004-09-11 10:15:07.000000000 -0700
++++ ux_init.c.patch 2004-09-11 10:15:40.000000000 -0700
+@@ -139,15 +139,6 @@
+ char *home;
+ char configfile[FILENAME_MAX + 1];
+
+- if ((getuid() == 0) || (geteuid() == 0)) {
+- printf("I won't run as root!\n");
+- exit(1);
+- }
+-
+- if ((home = getenv("HOME")) == NULL) {
+- printf("Hard drive on fire!\n");
+- exit(1);
+- }
+
+ /*
+ * It doesn't look like Frotz can reliably be resized given its current