aboutsummaryrefslogtreecommitdiffstats
path: root/packages/frotz/frotz_2.43.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/frotz/frotz_2.43.bb')
-rw-r--r--packages/frotz/frotz_2.43.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/packages/frotz/frotz_2.43.bb b/packages/frotz/frotz_2.43.bb
index e69de29bb2..defe0d4cf6 100644
--- a/packages/frotz/frotz_2.43.bb
+++ b/packages/frotz/frotz_2.43.bb
@@ -0,0 +1,23 @@
+LICENSE = GPL
+DESCRIPTION = "Frotz is an interpreter for Infocom games and other Z-machine games."
+HOMEPAGE = "http://www.cs.csubak.edu/~dgriffi/proj/frotz/"
+SECTION = "console/games"
+DEPENDS = "ncurses"
+
+SRC_URI = "http://www.cs.csubak.edu/~dgriffi/proj/frotz/files/frotz-${PV}.tar.gz \
+ file://Makefile-${PV}.patch;patch=1 \
+ file://remove_root_restriction.patch;patch=1 "
+
+do_configure() {
+ rm -f ${SourceTree}/frotz.conf
+}
+
+EXTRA_OEMAKE = "CC='${CC}' INCL='${CFLAGS}' LIB='${LDFLAGS}' PREFIX=${prefix} CONFIG_DIR=${sysconfdir}"
+
+do_compile() {
+ oe_runmake frotz
+}
+
+do_install() {
+ oe_runmake PREFIX=${D}${prefix} MAN_PREFIX=${D}${mandir} install
+}