aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gal/gal-2.0_1.99.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gal/gal-2.0_1.99.11.bb')
-rw-r--r--packages/gal/gal-2.0_1.99.11.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/gal/gal-2.0_1.99.11.bb b/packages/gal/gal-2.0_1.99.11.bb
index e69de29bb2..50ba8c3e61 100644
--- a/packages/gal/gal-2.0_1.99.11.bb
+++ b/packages/gal/gal-2.0_1.99.11.bb
@@ -0,0 +1,22 @@
+LICENSE = GPL
+SECTION = "x11/libs"
+DEPENDS = "intltool libgnomeprint gtk+ libglade libgnomeui libgnomecanvas libxml2 libgnomeprintui"
+
+inherit gnome
+
+SRC_URI = "${GNOME_MIRROR}/gal/1.99/gal-${PV}.tar.bz2 \
+ file://configure.patch;patch=1 \
+ file://forward-decl.patch;patch=1 \
+ file://iconv-detect.h"
+
+S = "${WORKDIR}/gal-${PV}"
+
+do_configure_prepend() {
+ cp ${WORKDIR}/iconv-detect.h ${S}/
+}
+
+do_stage() {
+ gnome_stage_includes
+ oe_libinstall -C gal -so -a libgal-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -C gal/a11y -so -a libgal-a11y-2.0 ${STAGING_LIBDIR}
+}