aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc/avr32-gcc-cross_4.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gcc/avr32-gcc-cross_4.1.2.bb')
-rw-r--r--packages/gcc/avr32-gcc-cross_4.1.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/gcc/avr32-gcc-cross_4.1.2.bb b/packages/gcc/avr32-gcc-cross_4.1.2.bb
new file mode 100644
index 0000000000..e34098f840
--- /dev/null
+++ b/packages/gcc/avr32-gcc-cross_4.1.2.bb
@@ -0,0 +1,22 @@
+require avr32-gcc_${PV}.bb
+# path mangling, needed by the cross packaging
+require gcc-paths-cross.inc
+inherit cross
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
+# NOTE: split PR. If the main .oe changes something that affects its *build*
+# remember to increment this one too.
+PR = "r0"
+
+DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
+PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
+
+# cross build
+require gcc3-build-cross.inc
+# cross packaging
+require gcc-package-cross.inc
+
+SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
+
+EXTRA_OECONF += " --disable-libmudflap \
+ --disable-libunwind-exceptions \
+ --with-mpfr=${STAGING_DIR}/${BUILD_SYS}"