aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnome/libart-lgpl_2.3.16.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gnome/libart-lgpl_2.3.16.bb')
-rw-r--r--packages/gnome/libart-lgpl_2.3.16.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/packages/gnome/libart-lgpl_2.3.16.bb b/packages/gnome/libart-lgpl_2.3.16.bb
index 68bb1dee1a..8028c8ef3f 100644
--- a/packages/gnome/libart-lgpl_2.3.16.bb
+++ b/packages/gnome/libart-lgpl_2.3.16.bb
@@ -2,10 +2,11 @@ DESCRIPTION = "Library of functions for 2D graphics"
SECTION = "x11/gnome"
LICENSE = "LGPL"
PR = "r2"
+ART_CONFIG = "${HOST_ARCH}/art_config.h"
# can't use gnome.oeclass due to _ in filename
SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libart_lgpl/2.3/libart_lgpl-${PV}.tar.bz2 \
- file://${HOST_SYS}/art_config.h \
+ file://${ART_CONFIG} \
file://Makefile.am.patch;patch=1"
inherit autotools pkgconfig
@@ -18,7 +19,7 @@ FILES_${PN}-dev += "${bindir}/libart2-config"
S = "${WORKDIR}/libart_lgpl-${PV}"
do_configure_prepend() {
- cp ${WORKDIR}/${HOST_SYS}/art_config.h ${S}
+ cp ${WORKDIR}/${ART_CONFIG} ${S}/art_config.h
}
EXTRA_OECONF = "--disable-gtk-doc"