aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gpe-aerial/files/fix_makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gpe-aerial/files/fix_makefile.patch')
-rw-r--r--packages/gpe-aerial/files/fix_makefile.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/gpe-aerial/files/fix_makefile.patch b/packages/gpe-aerial/files/fix_makefile.patch
index e69de29bb2..dec00994d8 100644
--- a/packages/gpe-aerial/files/fix_makefile.patch
+++ b/packages/gpe-aerial/files/fix_makefile.patch
@@ -0,0 +1,21 @@
+diff -urNd ../gpe-aerial-0.2.11-r0/gpe-aerial-0.2.11/Makefile gpe-aerial-0.2.11/Makefile
+--- ../gpe-aerial-0.2.11-r0/gpe-aerial-0.2.11/Makefile 2004-08-03 15:36:47.000000000 +0100
++++ gpe-aerial-0.2.11/Makefile 2004-08-03 15:49:42.000000000 +0100
+@@ -3,7 +3,6 @@
+ CVSBUILD = no
+ DEBUG = no
+ INSTALL = install
+-STRIP=strip
+ PREFIX = /usr/local
+ DESTDIR = /
+
+@@ -52,8 +51,7 @@
+
+ install-program: $(PACKAGE) all-desktop
+ mkdir -p $(DESTDIR)/$(PREFIX)/bin
+- $(INSTALL) $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/
+- $(STRIP) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
++ $(INSTALL) -s $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/
+ mkdir -p $(DESTDIR)$(PREFIX)/share/pixmaps/
+ for i in $(PIXMAPS); do install -m 644 -D pixmaps/$$i $(DESTDIR)$(PREFIX)/share/pixmaps/$$i; done
+ mkdir -p $(DESTDIR)$(PREFIX)/share/applications