aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gpe-bluetooth
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gpe-bluetooth')
-rw-r--r--packages/gpe-bluetooth/.mtn2git_empty0
-rw-r--r--packages/gpe-bluetooth/gpe-bluetooth-0.36.3/.mtn2git_empty0
-rw-r--r--packages/gpe-bluetooth/gpe-bluetooth-0.36.3/segfault.patch30
-rw-r--r--packages/gpe-bluetooth/gpe-bluetooth-0.37/.mtn2git_empty0
-rw-r--r--packages/gpe-bluetooth/gpe-bluetooth-0.37/change-sdp-to-bluetooth.patch12
-rw-r--r--packages/gpe-bluetooth/gpe-bluetooth-0.37/hciattach-path.patch11
-rw-r--r--packages/gpe-bluetooth/gpe-bluetooth-0.37/icon-resize.patch43
-rw-r--r--packages/gpe-bluetooth/gpe-bluetooth_0.36.3.bb15
8 files changed, 111 insertions, 0 deletions
diff --git a/packages/gpe-bluetooth/.mtn2git_empty b/packages/gpe-bluetooth/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gpe-bluetooth/.mtn2git_empty
diff --git a/packages/gpe-bluetooth/gpe-bluetooth-0.36.3/.mtn2git_empty b/packages/gpe-bluetooth/gpe-bluetooth-0.36.3/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gpe-bluetooth/gpe-bluetooth-0.36.3/.mtn2git_empty
diff --git a/packages/gpe-bluetooth/gpe-bluetooth-0.36.3/segfault.patch b/packages/gpe-bluetooth/gpe-bluetooth-0.36.3/segfault.patch
index e69de29bb2..d18cb38aac 100644
--- a/packages/gpe-bluetooth/gpe-bluetooth-0.36.3/segfault.patch
+++ b/packages/gpe-bluetooth/gpe-bluetooth-0.36.3/segfault.patch
@@ -0,0 +1,30 @@
+Index: main.c
+===================================================================
+RCS file: /cvs/gpe/base/gpe-bluetooth/main.c,v
+retrieving revision 1.51
+retrieving revision 1.52
+diff -u -r1.51 -r1.52
+--- main.c 7 Mar 2004 17:41:27 -0000 1.51
++++ main.c 7 Sep 2004 00:01:17 -0000 1.52
+@@ -508,7 +508,7 @@
+ {
+ GtkWidget *window;
+ GdkBitmap *bitmap;
+- GtkWidget *menu_remove, *menu_file;
++ GtkWidget *menu_remove;
+ GtkTooltips *tooltips;
+ int dd;
+
+@@ -560,12 +560,10 @@
+
+ gtk_widget_show (menu_devices);
+ gtk_widget_show (menu_remove);
+- gtk_widget_show (menu_file);
+
+ gtk_menu_append (GTK_MENU (menu), menu_radio_on);
+ gtk_menu_append (GTK_MENU (menu), menu_radio_off);
+ gtk_menu_append (GTK_MENU (menu), menu_devices);
+- gtk_menu_append (GTK_MENU (menu), menu_file);
+ gtk_menu_append (GTK_MENU (menu), menu_remove);
+
+ if (gpe_load_icons (my_icons) == FALSE)
diff --git a/packages/gpe-bluetooth/gpe-bluetooth-0.37/.mtn2git_empty b/packages/gpe-bluetooth/gpe-bluetooth-0.37/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gpe-bluetooth/gpe-bluetooth-0.37/.mtn2git_empty
diff --git a/packages/gpe-bluetooth/gpe-bluetooth-0.37/change-sdp-to-bluetooth.patch b/packages/gpe-bluetooth/gpe-bluetooth-0.37/change-sdp-to-bluetooth.patch
index e69de29bb2..009b9a576f 100644
--- a/packages/gpe-bluetooth/gpe-bluetooth-0.37/change-sdp-to-bluetooth.patch
+++ b/packages/gpe-bluetooth/gpe-bluetooth-0.37/change-sdp-to-bluetooth.patch
@@ -0,0 +1,12 @@
+diff -urNd ../gpe-bluetooth-0.37-r0/gpe-bluetooth-0.37/Makefile gpe-bluetooth-0.37/Makefile
+--- ../gpe-bluetooth-0.37-r0/gpe-bluetooth-0.37/Makefile 2004-09-07 01:01:06.000000000 +0100
++++ gpe-bluetooth-0.37/Makefile 2004-10-18 11:55:53.000000000 +0100
+@@ -20,7 +20,7 @@
+ PACKAGE_CFLAGS += $(STANDARD_CFLAGS) $(GPECFLAGS) `pkg-config --cflags dbus-glib-1` `pkg-config --cflags libglade-2.0` `pkg-config --cflags mimedir-1.0` `$(LIBGPEVTYPE_PC_EXTRA) pkg-config --cflags $(LIBGPEVTYPE_PC)`
+ PACKAGE_CPPFLAGS += $(STANDARD_CPPFLAGS) -DDBUS_API_SUBJECT_TO_CHANGE -DGPE_BLUETOOTH
+ PACKAGE_CPPFLAGS += -DPACKAGE=\"$(PACKAGE)\" -DPREFIX=\"$(PREFIX)\" -DPACKAGE_LOCALE_DIR=\"$(PREFIX)/share/locale\"
+-PACKAGE_LDFLAGS += $(GPELIBS) -lbluetooth -lsdp `pkg-config --libs gthread-2.0` `pkg-config --libs dbus-glib-1` `pkg-config --libs libglade-2.0` -lopenobex `pkg-config --libs mimedir-1.0` `$(LIBGPEVTYPE_PC_EXTRA) pkg-config --libs $(LIBGPEVTYPE_PC)` -lsqlite
++PACKAGE_LDFLAGS += $(GPELIBS) -lbluetooth -lbluetooth `pkg-config --libs gthread-2.0` `pkg-config --libs dbus-glib-1` `pkg-config --libs libglade-2.0` -lopenobex `pkg-config --libs mimedir-1.0` `$(LIBGPEVTYPE_PC_EXTRA) pkg-config --libs $(LIBGPEVTYPE_PC)` -lsqlite
+
+ ifeq ($(CVSBUILD),yes)
+ BUILD = ../build
diff --git a/packages/gpe-bluetooth/gpe-bluetooth-0.37/hciattach-path.patch b/packages/gpe-bluetooth/gpe-bluetooth-0.37/hciattach-path.patch
index e69de29bb2..4b122668a6 100644
--- a/packages/gpe-bluetooth/gpe-bluetooth-0.37/hciattach-path.patch
+++ b/packages/gpe-bluetooth/gpe-bluetooth-0.37/hciattach-path.patch
@@ -0,0 +1,11 @@
+--- gpe-bluetooth-0.37/hciattach.sh.old 2004-11-23 14:11:16.000000000 +0000
++++ gpe-bluetooth-0.37/hciattach.sh 2004-11-23 14:11:23.000000000 +0000
+@@ -3,7 +3,7 @@
+ if [ -f /etc/sysconfig/bluetooth ]; then
+ . /etc/sysconfig/bluetooth
+
+- exec hciattach -n $BLUETOOTH_PORT $BLUETOOTH_PROTOCOL $BLUETOOTH_SPEED
++ exec /sbin/hciattach -n $BLUETOOTH_PORT $BLUETOOTH_PROTOCOL $BLUETOOTH_SPEED
+ else
+ echo "Bluetooth not configured"
+ exit 1
diff --git a/packages/gpe-bluetooth/gpe-bluetooth-0.37/icon-resize.patch b/packages/gpe-bluetooth/gpe-bluetooth-0.37/icon-resize.patch
index e69de29bb2..2580d9c3c8 100644
--- a/packages/gpe-bluetooth/gpe-bluetooth-0.37/icon-resize.patch
+++ b/packages/gpe-bluetooth/gpe-bluetooth-0.37/icon-resize.patch
@@ -0,0 +1,43 @@
+diff -u -r1.52 main.c
+--- gpe-bluetooth/main.c 7 Sep 2004 00:01:17 -0000 1.52
++++ gpe-bluetooth/main.c 19 Oct 2004 08:16:27 -0000
+@@ -503,6 +503,22 @@
+ g_timeout_add (time, (GSourceFunc) cancel_dock_message, (gpointer)id);
+ }
+
++gboolean
++configure_event (GtkWidget *window, GdkEventConfigure *event, GdkBitmap *bitmap)
++{
++ GdkPixbuf *buf;
++ int xoff, yoff;
++
++ buf = gpe_find_icon ("bt-off");
++
++ xoff = (event->width - gdk_pixbuf_get_width (buf)) / 2;
++ yoff = (event->height - gdk_pixbuf_get_height (buf)) / 2;
++
++ gtk_widget_shape_combine_mask (window, bitmap, xoff, yoff);
++
++ return FALSE;
++}
++
+ int
+ main (int argc, char *argv[])
+ {
+@@ -572,14 +588,14 @@
+ icon = gtk_image_new_from_pixbuf (gpe_find_icon (radio_is_on ? "bt-on" : "bt-off"));
+ gtk_widget_show (icon);
+ gdk_pixbuf_render_pixmap_and_mask (gpe_find_icon ("bt-off"), NULL, &bitmap, 255);
+- gtk_widget_shape_combine_mask (window, bitmap, 2, 0);
+- gdk_bitmap_unref (bitmap);
++ gtk_widget_shape_combine_mask (window, bitmap, 0, 0);
+
+ gpe_set_window_icon (window, "bt-on");
+
+ tooltips = gtk_tooltips_new ();
+ gtk_tooltips_set_tip (GTK_TOOLTIPS (tooltips), window, _("This is the Bluetooth control.\nTap here to turn the radio on and off, or to see a list of Bluetooth devices."), NULL);
+
++ g_signal_connect (G_OBJECT (window), "configure-event", G_CALLBACK (configure_event), bitmap);
+ g_signal_connect (G_OBJECT (window), "button-press-event", G_CALLBACK (clicked), NULL);
+ gtk_widget_add_events (window, GDK_BUTTON_PRESS_MASK);
+
diff --git a/packages/gpe-bluetooth/gpe-bluetooth_0.36.3.bb b/packages/gpe-bluetooth/gpe-bluetooth_0.36.3.bb
index e69de29bb2..763f9a739f 100644
--- a/packages/gpe-bluetooth/gpe-bluetooth_0.36.3.bb
+++ b/packages/gpe-bluetooth/gpe-bluetooth_0.36.3.bb
@@ -0,0 +1,15 @@
+LICENSE = "GPL"
+inherit gpe
+
+DESCRIPTION = "GPE bluetooth support"
+DEPENDS = "gtk+ libdisplaymigration libgpewidget openobex libgpevtype bluez-libs sqlite dbus libglade blueprobe"
+RDEPENDS = "bluez-utils blueprobe"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+SECTION = "gpe"
+PRIORITY = "optional"
+PR = "r3"
+
+SRC_URI += "file://segfault.patch;patch=1;pnum=0"
+
+FILES_${PN} += '${datadir}/bluez-pin'
+